Playback issue with high bitrate file


#44

Try:

echo '444,10bit' > /sys/class/amhdmitx/amhdmitx0/attr

#45

can you elaborate? i tried to input this line via ssh, but it just returns:

-bash: /sys/class/amhdmitx/amhdmitx0/attr: Permission denied


#46

Ha! Sam only runs as root. User osmc is for us lesser mortals.

You’ll need to run

echo '444,10bit' | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

#47

Thanks! i tried
sudo echo ‘444,10bit’ > /sys/class/amhdmitx/amhdmitx0/attr
which oviouslly was wrong.

Edit: I guess if it returns 444,10bit everything is fine?


#48

If you echo that file attr it should say 444,10bit now and it’ll be 10bit


#49

Hello,

I enabled yesterday 10-bit / HDR output via “echo ‘444,10bit’ | sudo tee /sys/class/amhdmitx/amhdmitx0/attr” and seems to bee working. The output are now the same as with the Oppo. Unfortunatelay the flickering is still present, tried again with the Oppo and no problems there.

best regards,

Sarge


#50

Hi — next update should resolve some flickering issues.

I’ll let you know when I have something to test

Sam


#51

Hi Sam,

ok, thank you! Except the problems with UHD-HDR very great product, use it almost every day (Vero 4k and Raspi 3 with OSMC) !

best regards,

Sarge


#52

Hi Sam,

installed the December update, unfortunately the flickering issues are still there. In addition I didn’t found any settings for HDR in the gui. Are they still to activate with this command?

echo ‘444,10bit’ | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

In the meantime I have to play the HDR-files with my Oppo with which it works without problems

best regards


#53

Yes.

We did not add the HDR GUI option just yet.

Sam


#54

I have trouble with playing UHD m2ts on vero4k Men.in.Black.1997.COMPLETE.UHD.BLURAY-COASTER\BDMV\STREAM\00001.m2ts

Media info

Opening the file as a smb share from Synology DS116 through gigabit lan.

What should I check. Unfortunately my desktop pc is not strong enough to test the file. MPC-HC player plays it very laggy but much quicker than vero4k.


#55

What protocol are you using?
How is it mounted?


#56

On Synology maximum smb protocol has set to SMB3, minimum set to SMB1. Transport encryption mode: Auto.
On Vero4k i connect to Synology as SMB share.

I reran that video playback. Vero4k started to play it, but stopped at every 14-20 second. I pressed pause the play again, than it resumed playing, but stopped again in 15-20 seconds…and again and again…


#58

@esox Are you using wired or wireless connection?


#60

It’s wired. I retry with NFS share today.


#61

I followed these steps on nfs shared directories and it seems it helped.

I’ll retest playback on tha big m2ts file later on today.


#62

My older Synology was much slower with transport encryption turned on so you could also try setting it to disabled. Although NFS (fstab mounted) should be faster.


#63

This should now be resolved. See Playback improvements for 4K HEVC UHD content.