Playback issue with high bitrate file


#21

First of all try to use fstab NFS mounts, as @fzinken has already said.

Since you’re on a Vero4K, you can go a bit wild on the caching and it still won’t “touch the sides”. I’d recommend you try 1 GB (<memorysize>1073741824</memorysize>). A readfactor of 4 or 6 should be more than enough for high bitrate files.

The problem is that with a high bitrate file you’re going to be consuming most of the bandwidth just viewing the movie, giving you little spare bandwidth with which to build up the read-ahead cache. So it’s easy to recommend a large cache size but, in practice, you might never get anywhere close to filling it. And every time the bitrate exceeds the available network bandwidth, you’re going to start depleting the read-ahead cache - and with a high bitrate spike that depletion could be quite rapid.

If you want to see the caching in action, you need to attach a USB keyboard to your Vero4K and then reboot. Once Kodi has restarted, type Ctrl-Shift-o and take note of the “Forward:” figure at the top of the screen. That’s the amount of read-ahead cache you have accumulated. Then play a few high bitrate movies and see what happens.

Assuming that you’ve used the 1 GB cache size above, the maximum read-ahead buffer will be 75% of 512 GB, which is 384 GB. That will give a little over 30 seconds buffer at 100 Mbits/sec but only around 8 seconds at 400 Mbits/sec.


#22

I think this is why I didn’t see any improvements with my advanced settings file.


#23

Very possibly. I recommend you try viewing the read-ahead cache in action using Ctrl-Shift-o. Seeing it in action can be instructive.

If you confirm that the cache keeps dipping to zero, followed by stuttering, it might be worth looking at a USB gigabit LAN adapter.

But first don’t forget about trying NFS through fstab.


#24

Hello,

I just tried FSTAB NFS mount and played with advancedsettings.xml. The movie has already at the beginning a high bitrate (over 90Mbit/s) so the problem maybe is as you said to build the read-ahead buffer. The move stops again at 00:01:48 but later (when the cache is build) it goes better. Anyway there are still micro stutter all the time playing the movie.

Other question: when buffer is enabled, wy does the movie play immediately instead of waiting a few seconds for buffering? Maybe my configuration is not working correctly!?

What USB gigabit LAN adapter can you recommend?

best regards,

Sarge


#25

Where is that bitrate coming from? If you’re just monitoring the network interface, Kodi will/should to try to run at close to full speed until it’s filled up the buffer.

Did you see how the read-ahead buffer was filling and emptying, and whether stutters only occurred once the buffer had emptied?

I think @sam_nazarko was looking at allowing a small delay to give a bit of read-ahead buffer right from the start. Not sure what the state of play is.

I don’t have one. Perhaps someone else can offer a recommendation.


#26

with the kodi app on my iPhone pressing long the button “i” i see the bitrate and cache rate (forward) that ist about. The stutters occurs also when the buffer is filling. Maybe there is another issue for that. I’m trying now with 59,94Mhz
Prior the FSTAB mount and advancedsettings I could play the movie but stopped after a few minutes (message source to slow or something similar)


#27

So does Kodi ever manage to fill the read-ahead cache? Does it ever empty it? (And did you change advancedsettings.xml?)

Just checking: were the tests so far on wired gigabit ethernet?


#28

the cache was never filled up to 100%, I make other tests tomorrow when I have more time. The tests are on wired gigabit ethernet. The micro stutters I noticed also with other 4k files with less bit rate, whereas with the Oppo not.


#29

Micro stutters might be related to something else, eg an issue with hardware acceleration.


#30

Hi

I’m sorry to hear you’re having problems.

Unfortunately a log would be needed to work out why you’d see micro-stutters.

That’s right. Kodi’s caching is a bit messy.
We also want to improve the out of box advancedsettings.

I’ll start a thread to kick this off tomorrow.

Sam


#31

Hi Sam,

I just created a log file experiencing the sutters for example with "Stranger Things"
https://paste.osmc.tv/hecogahiba

The Vero ist connected to the HDMI-Input of Oppo-UDP 203, the Oppo is connected to Sony A1. When I play the same file with the Oppo i don’t have any problems. I have the stutters also when I connect the Vero 4k directly to the Sony A1. Disabling Add-Ons does not solve the problem.

Thanks in advance,

Sarge


#32

Try local playback and see if it helps.
If it does, then I’d consider using an fstab based mount.


#36

Just to follow up on what Sam said, you have “Cinema 4K” on /etc/fstab but “TV Serien” and “Cinema HD” are still using Kodi’s NFS.


#37

Hi,

I tried to play the file via /etc/fstab and also local playback (copied the file to the Vero storage), the stutters are always the same. I think that there must be something with the configuration.


#38

If local playback doesn’t help it’s unlikely to be a throughput issue.

Make sure Adjust Refresh Rate is enabled
Knowing a bit more about your setup might be helpful and whether you get micro stutter with all videos or just some


#39

Hello Sam,

this was the right option! I enabled “adjust display refresh rate” (always) and the stutters are gone! Only with John Whick 2 I have the short break at 00:01:48 (that I don’t have with the Oppo), but I didn’t notice any stutters.

Thanks a lot for the (very fast) help and support!

best regards,

Sarge


#40

Great. I’d stick with the FSTAB based mounts as they will provide better performance.


#41

Hello Sam,

unfortunately I have now flickering issues instead of stutters :confused:
Maybe it is the same problem as described in this thread, but I have a Sony A1 OLED

for example in the 4k HDR movie “Guardians of the Galaxy” (visibile in the first scene in the clouds)
Logs: https://paste.osmc.tv/nekemicomi

best regards,

Juergen N.


#42

Have you enabled 10-bit / HDR output?


#43

where can I enable this option (didn’t found in the options)? Anyway the output is for sure HDR, but no sure about 10-bit