Pi now fails to boot


#24

I attempted to update two Pi’s today and both were bricked by the update. Not sure at this point how to recover. Any thoughts?

I always update as soon as I receive the email informing me of availability and have never had an issue like this before. I did leave each of them on for several hours hoping the issue would self-correct but it never did. Please help!

Thanks.


#25

First step to identify what is wrong. Plug the SD card into your PC and post here the exact directory output including filesize.

Also important to know if you used a SD Only or SD + USB Disk install?


#26

@slwalls,

moved your post here as this seems to be similar issues


#27

Thanks. Will check tomorrow on PC between meetings. It was an SD only install over wifi. Has always worked like a charm…up to now!


#30

So, I am trying to look at the card on the first Pi and my computer asks if I would like to format it. Appears the programs are all corrupt and I must start over now. Hope the update did not tank my sd cards.


#31

Test it with H2Testw before you use it for a new install


#32

so install worked on this Pi however i cannot connect to wireless. works with wired but cannot use wired on TV. Install version is january 2018


#33

Hi. My 2 cents on the matter, related to March update on RPI2:
After update, it would only boot into a limited console with busybox, could mount the SDCard partitions but that was all. I haven’t had enough time to dig more about how to boot from there. After many restarts and modifications to cmdline.txt and overwritten kernels, finally the boot partition gave up and couldn’t be mounted anymore. So I proceeded with a fresh install on another sdcard and updated OSMC without any hassle. Then I formatted the boot partition on the old sdcard and copied the content over from the new install. And then, magically, the device booted perfectly from the old sdcard. I was happy because I hadn’t made a backup in a long time.
Don’t know about other situations with RPi devices and the March update, but in my case that’s what really worked. Probably there is something wrong with the sdcard anyway, but I will replace it rapidly. Hope this helps somebody.


#34

Hi Livebest,
That is interesting in terms of updates and installs and I’m sure it’ll help somebody.
I’m not sure that it’s directly related to the problem here with the March update though. Yours does sound like a faulty SD card issue. Whereas my problem was one of a failed update on a Pi with the main bulk of stuff sitting on the hard drive and only the boot sitting on the SD card. That does seem to be a configuration issue with that update.


#35

Hi,
That’s exactly the critical point: the sdcard boot partition. I forgot to mention that I ran fsck multiple times on both partitions, /boot and /root and none revealed any problems. The fun fact is that I ran a couple of win utilities (h2testw and usb flash tester) and even an dd if=/dev/mmcblk0px of=/dev/null (from another linux machine) without resulting any issues, which derailed me a bit. To the moment I still don’t know how reformatting /boot solved my issue, but it did. I’m sure I’m missing something here…


#36

You might have some unstable memory cells on the card.