OSMC Security Update for OSMC 2016.04-1 and earlier


#22

Just updated my Pi3 from OSMC2016.04-1 to 2016.04-2 and now the connection to my Windows 7 SMB Share fails when I try to play my music. The original Samba was installed from the appstore. I wanted to include my kodi log file but the extension is not allowed.


#23

No need for the log file. We are aware of the problem. If you have used guest/password less share access currently the only way is to change that to non guest user based access with password until hopefully a fix will be provided from upstream.


[Quick Fix] Problem accessing legacy and guest samba shares after SMB security update on April 14th
#24

Thanks, I will try that.


#25

I’ve had trouble connecting to my Airport Extreme with error messages like:

22:46:03 34.123817 T:1626338288 ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://USERNAME:PASSWORD@HOSTNAME/PATH’
unix_err:‘2’ error : ‘No such file or directory’

The fix was fairly straightforward, disable SPNGO since AE supports only SMB1 protocol.

Add the following lines to ~/.smb/smb.conf into the [global] section:

[global] ... client use spnego = no client ntlmv2 auth = no


#26

@spity thanks for the tip can you check if that survive a reboot as I had the impression kodi dynamically generates the file


#27

It does on my install


#28

Thanks


#29

I can patch Kodi to add these two lines if some other users can confirm this helps. I built a version of Kodi that appended these lines to smb.conf before and @fzinken tested it but we didn’t have any joy.

Sam


#30

Here’s how I got these two lines (apt-get install samba first):

smbclient -d 255 -U USER -I HOSTNAME ‘\\’

… Server does not support EXTENDED_SECURITY but 'client use spnego = yes and 'client ntlmv2 auth = yes' …

I’ve added these lines into /etc/samba/smb.conf which fixed smbclient, however Kodi still didn’t work, I then added them to the user specific config and Kodi succeded connecting to the Airport.

I’m not sure this fixes Windows 10. However the test is simple, just smbclient the IP of your Windows 10 box.


#31

I gave this a try, but it did not seem to work (continued to receive “error opening” messages). Running Windows 7 and Pi2.

I also tried putting the new rows at the top of smb.conf, just under [global]. And I also tried setting them both to = yes. Reboot after each change, but nothing worked for me.

Maybe I did something wrong? Here are the details I used:

osmc@osmc:~/.smb$ sudo nano smb.conf

[global]
    preferred master = no
    local master = no
    domain master = no
    client lanman auth = yes
    lanman auth = yes
    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=65536 SO_SNDBUF=65536
    lock directory = /home/osmc/.smb/
    name resolve order = bcast host
    client use spnego = no
    client ntlmv2 auth = no

osmc@osmc:~/.smb$ sudo reboot

#32

If I remember correctly you have guest/passwordless shares.
This two lines are only fixing the issue accessing old (smb1) samba shares.


#33

Yes.

OK. Sorry for the misunderstanding.


SMB protocl share external HDD connected to the Pi2 to the local LAN by smb - disable loign and password
#34

I wish I had found this thread before trying to install OSMC and then after configuring it spend quite a while trying to access my non passworded shares on my Windows 10 Media Server :frowning:

Sadly I can’t access them at all and I am not going to change to a password media server as we have so many mobile devices in our house which, once accessed the home network, simply ahre everything fine, with the level of access we require.

Good luck with the resolve. I’ll put aside my attempts to test out OSMC.


#35

Just updated my Pi to 2016.05-1 and resolved the password less SMB share issue. In this release you can go to music>>files and select your shared file. It prompts you for a username and password and the option to remember it. Here I just entered my main Windows 7 Username and password and the share was opened and my music is playing again. I assume the same will apply to movies and videos, which I don’t use.
So as far as I am concerned, this problem is solved without having to go the password protected SMB share route…:smiley:


OSMC's May update is here
#36

Hi,
i have the same issues while trying to access via smb connection my shared folder in windows 7 where i have no account and no psw setted.
I’ve read the previous posts but i couldn’t understand how (and if) i can get through this in user friendly way.
Can you you please help me? Thank you.


#37

No need to do or change anything on the Windows 7 side. Just go to your files in OSMC and click on the share that you previously had. It will prompt you for a username and password. Just use the standard username and password that you normally use to log onto Windows 7 and after that you can use the share as before.


#38

Ok…
so do I need to set a password for my win 7 account even if i never had one before?

Thanks


#39

Hi Gierre, I always had a password on my Windows 7 account, so I don’t know what will happen if you don’t have such an account. You can try to type just your Windows username in OSMC with no password and see if it works. Let me know what happens.


#40

Hi AndreB,
i have tried sharing a folder (everyone access allowed) from a win 7 account with no pw setted and i can confirm that now i can access it via OSMC samba sharing protocol.
Do you think that i could have safety issues with such a basic configuration?


#41

Gierre, I guess it it always safer to have a password on your Windows account to help prevent attacks from the Internet. I am not sure if there is a danger from the OSMC side into your Windows PC because I don’t know enough about the underlying linux operating system. Maybe an OSMC expert or developer can answer that question better. Glad you managed to get access to your share via OSMC.