OSMC, bluetooth streaming and Bose QC35 headphones


Hi guys. First things first. Sam, thanks a lot for your AWESOME work for the RPI community.

Ok I’m streaming audio using bluetooth to my Bose QC35 headphones. A tip about this.

You have to add this line ControllerMode = bredr to the file: /etc/bluetooth/main.conf

Otherwise you couldn’t pair the QC35. After restarting the bluetooth system (or your RPI) you can comment that line or remove it, the problem happens just during the pairing process.

A couple of months ago I had yo disable the internal bluetooth device in my rpi3 (adding dtoverlay=pi3-disable-bt to the config.txt file) and use an external bluetooth dongle because nothing worked with the internal one.

Has that been fixed with the last version of OSMC? (krypton)



PD: Modify config.txt using the OSMC interface, avoid changing the file from a command line interface



Kodi Krypton and Bluetooth is an independent stack.
I wasn’t aware of this problem, but can you provide a link so I can see some further information so I can see what it actually fixes? If it improves things without regressions then I’d be happy to include it in OSMC.

We are aware of issues with the internal adapter, nothing so far, but we will stay up to date with the Pi kernel and firmware. So if any changes are made, we’ll bring them in with future updates.



Ok, allow me to explain myself better.

I had been using an RPI2 with OSMC and a bluetooth dongle for the last year. About one month ago I bought an RPI3 so I installed a fresh OSMC and tried to pair it with a Bose sound link II speakers and Bose QC35 headphones. I didn’t manage to pair with the Soundlink, I managed to pair with the QC35 using the main.conf modification I told you about but no sound at all, and even some freezings in the Kodi interface (while in My OSMC). After that I disabled the built-in bluetooth and I tried with my good old bluetooth dongle, and everything worked like a charm.

Today I have tried to re-enable the built-in interface and remove the bluetooth dongle and I nothing has changed. I can’t use the built-in dongle.




I need to do some research in to what the above line is doing and whether it’s a safe change.

Make sure you are on a recent version of OSMC.
I think I wasn’t clear re. internal adapter. It should be detected, it should pair and should on the whole work. But you may get slight dropouts with the internal adapter.



Apparently Bose QC35 had some problems pairing with LE. I got an explanation here:

Anyway the problem just happens during the pairing so you can just change the config file, pair the QC35 and undo the change, and the QC35 will be still working. So this “process” ends with the original config file and your headphones paired and working :smile:



I think a friend of mine has these headphones. I’ll see if I can borrow them off him for a couple of hours and see how to improve things.

I am unsure of the completeness of Pi’s BT LE implementation yet – I will mention this to @popcornmix at some point. It’s possible there’s just a bit of configuration to do in OSMC and that the internal adapter and current kernel driver is up to the task


Sorry for bothering this old thread. I’m trying to connect a pair of Bose QC35 headphones using the built-in bluetooth. I can connect but there isn’t any sound in the headphones. I tried to locate the /etc/bluetooth/main.conf file but there is no such file (I’m on the latest OSMC build 2017.07-1). Has anyone successfully connected to a pair of QC35?


Hi jimbju, did you find the solution ? because I have the same problem.