OSMC and Hyperion


Run it with -v flag instead of -d. It’s something that i cannot explain yet. But in my case -v is mandatory for it to run.


Can you reliably reproduce that fault?




  1. OSMC August update running on vero 4k
  2. hyperion.ng latest clone from github built with
  3. hyperiond deamon started with sudo hyperiond -v
  4. kodi idle in menu - hyperiond runs
  5. start a video - hyperiond crashes
  6. video paused, not returned to menu - hyperiond won’t even start again

I can use the color calibration tool of hyperion.ng no problem, it’s able to produce the images for calibration on-screen, only when video starts playing does it go byebye


Can you run readelf -A on your hyperiond? May need to install binutils


Here’s the result:

I ran it again for the bin installed to /usr/local/share and got a much more thorough output:

And just for fun I ran the same test again:

  1. sudo hyperiond -v
  2. start video in kodi
  3. crash

dmesg: http://paste.osmc.io/oqabasizaq.coffee


Thanks – looks OK.

Just added:

Try the staging repository.

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.


Disabled "Show empty TV shows" not working correctly

Nope, sadly still crashes. Here’s a dmesg: http://paste.osmc.io/idegedamic.coffee


Hi – doesn’t seem to be the issue then; but rather how Hyperion has been built.

I’m sure there are other users enjoying Hyperion on Vero 4K so maybe they can advise.



I’ve tried hyperion.ng a couple of time. Every time I had problems. Either it did not work or it crashed. Using -v as a workaround doesn’t give me a lot of confidence. Hyperion.ng is still marked as alpha. Guess that’s for a reason.

I’ve been running the “classic” hyperion ever since I got the Vero4K; I ordered it the day it was released so that’s > 6 months and it’s been working like a charm. Don’t understand why everyone is focusing on the NG build wich is alpha when there’s a perfectly working version already available. Once it enters beta I might give it a try, for now I’m sticking with the old version.


It’s a matter of which version runs on certain systems. Classic version doesn’t grab video in my case, only ng had. My starting point was heritage of the first Raspberry Pi 1, paired with an Arduino for controlling the led strip. I’m sure it’s the way I’m did the setup but I’m still trying to know how it really works in order to help others


I’ve started with an RPI1 with a Teensy to control the LED-strip, moved to an RPI2 and am now on my Vero4K. Moving from RPI to Vero4K required to change my config and recompile with other options (other grabber) but it works. If you want I can provide my install-package for the 4K along with my config. It just works… No need to -v or whatever :slight_smile:

Grab a Vero 4K for £99 today - OSMC

This would be awesome! Thank you very much.


I must admit I’ve never needed the -v option when running ng.
But as I couldn’t get the grabber working on classic (only responds to home screen, menus, OSD but not the video content itself) I was forced to move to ng too.
You’d think with the platform consistency we’d all be getting the same results. I guess it’s all in the software environment - subtle differences…


We’re lucky enough to have a Hyperion developer participating in this very thread.

Once NG is progressing further and My OSMC 2.0 is, we’ll have it included in our App Store.



Some of the variability could be down to when you downloaded/cloned the NG repository.

For instance there were some amlogic grabber changes a couple of days ago: https://github.com/hyperion-project/hyperion.ng/pull/469


I would like to try that :slight_smile: I still have a working config for my ambilight from my “old” install on the rpi2, which the vero 4k replaced. Nothing changed on the Hardware side, it’s still an Arduino Uno running adalight, so my old config and the “old” hyperion should work.


Just a headsup, with the help of @nrosier hyperion “classic” is working just fine on my vero 4k now


Cheers! :v::v::v:


@nrosier @Gymnae

I didn’t realise there has been a Classic with FULLY working grabber on 4k.

Were the binaries compiled on an Rpi and copied over or on the Vero4k itself?


yes. I had some problems compiling on the Vero. in order to compile it needed some packages (including mesalib which breaks qt on the Vero). so I installed everything on an RPI2 and compile it there. works without issues.