OSMC and Hyperion


#21

Ok. So are you ok if we continue in this topic about getting it installed etc? Or do you prefer another way of communicating?
After this command: cmake -DCMAKE_BUILD_TYPE=Release …
I see errors. Or do I need to fill in something instead of the … ?

These are the log files:
http://pastebin.com/sq2djdF3
http://pastebin.com/AXSLHDYT
http://pastebin.com/BWidqSTK


#22

You are building for dispmanx (Raspberry Pi).

Instead, try

sudo apt-get install vero3-userland-dev-osmc

When building Hyperion, pass `-DENABLE_AMLOGIC=1 DENABLE_DISPMANX=0``` will probably do the trick. Please use the OSMC pastebin in the future: it’s easier to read.

Sam


#23

Ok I ran the command you metion but it says it’s already installed.
Then I ran this to build it:
cmake -DENABLE_AMLOGIC=1 DENABLE_DISPMANX=0 -DCMAKE_BUILD_TYPE=Release …

and this is the result:
http://paste.osmc.io/iraxorarix.vhdl
Cmakeerror.log: http://paste.osmc.io/jofuyoyepu.js
Cmakeoutput.log wasn’t updated since last time.

Sorry I’m not so familiar with building and so.


#24
-- PLATFORM: rpi```

It's still trying to build for Pi. Try something like -DPLATFORM=amlogic instead.

#25

Ok, got me this:
http://paste.osmc.io/ucarutekec.vhdl


#26

It’s still trying to build dispmanx, maybe -DDISABLE_DISPMANX=1 or @penfold42 may have some ideas with the exact command to pass

Sam


#27

I see I made a typo earlier!
cmake -DENABLE_AMLOGIC=1 DENABLE_DISPMANX=0 -DCMAKE_BUILD_TYPE=Release …
tried now with this.
cmake -DENABLE_AMLOGIC=1 -DENABLE_DISPMANX=0 -DCMAKE_BUILD_TYPE=Release …

Have better result now and will continue with the rest.
http://paste.osmc.io/zaromikobi.vhdl


#28

I didn’t write the build infrastructure but from memory the platform detection is only used to set defaults for enable and disable.

Manually enabling and disabling components should work around any issues platform detection causes so you’re on the right track.

You might also need to disable the PWM based led device drivers cos they won’t work on non PI boxes


#29

Looking at the log file:
) try using ON and OFF instead of 1 and 0
I don’t know if it’ll work anyway (it might, I’ve never tried)
) is the qt5-serial support installed ?
) you can ignore the CMP0028 related junk and also the dozygen related messges


#30

Ok i got a few steps further :).
Seems installed now.
Will further test!


#31

Make install needs root…


#32

quick question. So i have the vero4k and want to run hyperion on that, but the actual leds are connected to my pi3 and I have hyperion already running on the pi3.
Should I be able to send the signal through from the hyperion.ng on the vero4k to the pi3 normal hyperion?


#33

I don’t think so

But @penfold42 will know


#34

It should work - there’s actually 3 ways to forward the data.

  1. run full Hyperion on the 4K and use the forwarding function

  2. use the udp led device type and just forward the 100 leds of data

  3. just run the aml grabber binary on the 4K and point it at the pi3

  4. maybe… on x86 platforms there’s a Hyperion kodi add on. I’ve never used it but I suspect it gets the screen data from kodi and sends it to Hyperion (on a Pi)


#35

I think I prefer option 1 (or maybe 2 or 3, but you’d have to explain it to me) but tell me which option has the least latency (and easy to setup).

Anyway I got it installed and Hyperion is running (though at the moment hyperion.ng only runs when I have this command active:
osmc@osmc2:~/hyperion/build$ bin/hyperiond myconfig.json) and it seems to properly grab the video image! :slight_smile:
I see at the live test feed that video is grabbed! So that seems to work well!

However it doesn’t send or receive it yet to the pi3 (where the actual leds are connected).
I changed the json/proto ports on the vero4k to something different than how it is on the pi3 because otherwise it would interfere with the pi3.
Also I started of course the JSON/PROTO forward component on the vero4k.

But how/where can I configure that it should forward to the pi3? Or how do I configure the pi3 hyperion to properly receive it?
This is the pi3 config: http://paste.osmc.io/yoboborali.cpp
Do I need to configure JSON/PROTO FORWARD CONFIG also on the pi3?

Also I assume I’ll have to configure the same leds configuration on the vero4k. But I assume the “led hardware controller type” stays FILE?

BTW you guys are building something very nice with this new webconfig for hyperion!!!
It looks very good already! Well done.


#36

You the ports should be ok cos they’re on separate hosts.

On the 4k under network services there’s a forwarder section that only shows up in EXPERT or ADAVNCED settings 8-(

Use the key on the menu to change from default level

Then you can forward json and protobuffer data from the 4K to the pi3
Don’t forget to activate it too!


#37

Ah thanks. Ok so I’ve been playing around for about an hour trying all kind of things, but the actual lights do not turn on.
Here is the vero4k hyperion.ng config: http://paste.osmc.io/ifuwusoxem.cpp (not sure if it was needed to configure the leds here as well, but I did it anyway).
and, not sure if needed, the config of my pi3 hyperion config: http://paste.osmc.io/banavatodi.cpp
Here is a log of the ssh side when I started Hyperion, did a Effects test, and ended Hyperion: http://paste.osmc.io/ixutuzazoc.xml

Mind you that I also have Home Assistant which can activate the lighs and that works fine (also over port 19444).
So I have the feeling it’s on the vero4k server side something is wrong.


#38

I have the feeling we are close, so if you can help me further that would be great :).

By the way I’m also willing to help out translating to Dutch. Send me a PM if you are interested.


#39

hello there, so I saw that today’s update of osmc added support for hyperion on the vero 4k but I’m unsure on what should I do to install it. hypercon isn’t working so… i’m a bit lost :slight_smile:


#40

Ok well so I had to remove mesa (FATAL: CApplication::Create: Unable to init windowing system) because OSMC wouldn’t boot anymore.

But now that I removed the mesa libs, I can’t start Hyperion.ng anymore :(.

Any help is appreciated!