OSMC and Hyperion


Well, it’s still not working atm. I am still figuring out which sketch (this?) to put in the Teensy and how to configure Hyperion config, as in controller type, which capturing hardware to select etc.
So far, no lights :wink:
Strip is confirmed working with the Teensy on the test bench when loading a simple running light script.
But selecting effects in the Hyperion doesn’t seem to work.
If I get it working (ever lol) I’ll hand out the other things I did to get it to work so you can update the guide if needed.


K, got it working today.
For some reason one of the most simple steps did the trick : reboot the vero :rofl:

Not sure if it was incorrectly in your guide, but although I sudo’d su to become root, everything got installed in home/osmc.
Hard parts were correcting that without any knowledge on how to do this from command line.
Perhaps a wee bit more instruction on how to actually create a service unit.

Eventually following things to the letter, as well from over here did the trick.

The settings I earlier mentioned are : controller type = adalight and hardware capture stayed on auto.

Hope I didn’t clutter this thread too much :wink:


nice to see you got it working… I’ll come back asking you when I set up mine :smiley:


Please tell me how you fixed that copy error. I run into the same now.
I also followed the guide to the letter.

So is it ok that it’s installed in /home/osmc/ ? or do I need to do something to have it in another location?


Is this actually breaking anything or just a warning? Does it appear if you run things a second time?
I seem to recall similar output on my installer if it was being run for the 1st time, which I hid to avoid concerning end users.

Also is there enough interest here for me to add hyperion.ng to the installer? I did try building it myself a while back but as the Android remote app seemed to have stopped working/stalled development I did not pursue it.


I resolved this error by using WINSCP to manually copy things to the correct folder.
Mind you, you need to log in as root, otherwise you don’t have write permissions in root folders.
After copying things to the correct directories things got easier.

It’s breaking things in a sense that things are being expected in root directories while they aren’t.
I have no clue where things go wrong during installation though.
Once you let the beast free things roar over your screen lol

In hindsight it is more than doable and she works a treat! hyperion.ng FTW!


Can you tell me please exactly what folder(s) you copied from where to where?


Thank you for the guide! Worked perfect. Trying to install the toggle add-on but having an issue figuring out where to place the .json file.


do you know the answer to my question above?


In the end it all came down to copying both hyperion.ng and .hyperion from /home/osmc to /root/
So I ended up with those two dirs at /root
To have access to the root dir I logged in WinSCP as root.
From there on things worked like magic and I was able to follow the guide further.


I’m unable to build your version on my Vero4K, I always get this error:

--  - Libraries: /usr/lib/arm-linux-gnueabihf/libusb-1.0.so
CMake Error at CMakeLists.txt:259 (find_package):
  By not providing "FindMbedTLS.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "MbedTLS", but
  CMake did not find one.

  Could not find a package configuration file provided by "MbedTLS" with any
  of the following names:


  Add the installation prefix of "MbedTLS" to CMAKE_PREFIX_PATH or set
  "MbedTLS_DIR" to a directory containing one of the above files.  If
  "MbedTLS" provides a separate development package or SDK, be sure it has
  been installed.

Any idea? libmbedtls-dev is installed but still this error.


That’s exactly why I “insisted” on compiling as ROOT in the guide :wink:

I hope I made it a bit clearer now:



Mhm, I’m a bit out of my depth with this one…

Are you trying this on a vanilla Vero 4K(+?)?

Maybe this could help you: https://github.com/JuliaLang/julia/issues/17497



Vanilla 4K. Installed all the additional packages to be able to compile (works with the original hyperion.ng) but still get the message mbedtls is not found.


I must admit my brain isn’t what it used to be :sleepy:

I asked this question myself in a github issue but can’t really remember how I solved this problem…:

After reading the comments on the issue again maybe this post was the solution:

merry christmas everyone


I finally managed to get my setup up and running. Thanks to Anthrax compile went smooth and I use a Aduino Uno R3 for my setup with 300 LEDS on a WS2812B stripe. So far its working… but it is way to slow and changing only every ~300ms… so it’s no fun yet.

I tried to increase the serial speed > 115200 but regardless what I use, it stops working.

Anybody got a hint? Is the Arduino limited to 115200?

Edit: I found something to edit the Arduino IDE to support more than 115200, but didn’t work either.


If I reduce my sketch to 255 LEDs speed is good… but I’m missing out on 45 LEDS, no one got a clue? I thought with ng it shouldn’t be an issue with >255.


Use this sketch:

If you change the baud rate in Hyperion you must also change it here in the Arduino sketch:
// Baudrate, higher rate allows faster refresh rate and more LEDs
//#define serialRate 460800 // use 115200 for ftdi based boards
#define serialRate 115200 // use 115200 for ftdi based boards
//#define serialRate 500000 // use 115200 for ftdi based boards


Doing the maths,
300 LEDs is 7200 bits

500,000 baud is 2uS per bit
LEDs run at 800 kHz = 1.25uS per bit

So, 3.25!uS per bit to receive and on send
3.25 * 7200 = 23.4 mS per frame best case.

There a variety of Arduino boards with FTDI, CH364 and other USB uarts - I’ve seen some work well at 500,000, some at 460,800.

My advice is always o start with 115,200 and then try faster speeds


thanks for the reply penfold42, I’m already using the sketch from hyperion.ng. also tried to increase the speed on the config as on the sketch of course above 115k. but it seems my arduino model doesn’t like it at all and stops working. I tried to google differences of all the boards, but the variety is sheer overwhelming and I’m not very good when it comes to electronics.

So if i get your math right best case with 500k baud would be a “responsiveness” of 42,7 fps so even with 115k i should get around 10fps in the best case?

But as soon as I drop down to 255 leds its so much better… not sure what to do next. I’ll try and see if I can find a different arduino board. sorry for my “noobyness”