No sound via HDMI Leia


#1

The problem with sound. In the settings, the change does not give a result.
The sound is only by minijack no sound via HDMI
Installed kodi v18
How does /boot/config.txt look like for you


#2

Why not post yours?


#3

Ive seen audio drop from my Pi’s but the cause was Vizio TV


#4

You haven’t told us anything about what the HDMI is connected to - which may be highly relevant.
To find what sort of video your RPi thinks your setup has, use tvservice -s, and report the results
Derek


#5

/boot/config.txt
gpu_mem_1024=256
hdmi_ignore_cec_init=1
hdmi_force_edid_audio=1
disable_overscan=1
start_x=1
disable_splash=1
hdmi_force_hotplug=1
gpu_mem_256=112
hdmi_safe=1
sdtv_aspect=1
gpu_mem_512=144

Result:

state 0x12000a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 59.94Hz, progressive

TV:
SAMSUNG LENOB5550 witch frimvere version T-CHL5DEUEUC-2010.1


#6

Try deleting this line and re-booting.


#7

So, if it is Kodi Leia this thread should be moved to “Development and Testing”.


#8

When I removed the lines:

 hdmi_force_edid_audio = 1

Nothing


#9

Just to be clear - you don’t even get gui sounds?

@JimKnopf Done!


#10

when I connected the raspberry to the other TV via HDMI, the weird thing is and the Samsung TV does not work

grahamh does not have any sound at all

Now I do not know by the laptop the sound on this TV works ok


#11

These 2 lines are going to prejudice the view, and modify what tvservice might have shown. They may have forced a mode which the TV doesn’t like.
Further, I don’t know enough for an authorative opinion, but
the hdmi_safe will, I think, override any of the previous settings and result in forcing audio to 3.5mm port only.
Best thing is to remove all those lines and then do an orderly test to see what OSMC comes up with 'on its own’
Derek


#12

Problem solved
It helped change the resolution to 1280x720 when it is different, my TV does not receive sounds via HDMI
Thank you very much for your help and commitment to solving the problem.