No remote control after lastest update


#21

And here’s mine

the outputs of
sudo lsusb

osmc@OSMC-RPi3:~$ sudo lsusb
Bus 001 Device 004: ID 045e:0284 Microsoft Corp. Xbox DVD Playback Kit
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

sudo usb-devices

osmc@OSMC-RPi3:~$ sudo usb-devices

T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 1
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=1d6b ProdID=0002 Rev=04.14
S: Manufacturer=Linux 4.14.78-2-osmc dwc_otg_hcd
S: Product=DWC OTG Controller
S: SerialNumber=3f980000.usb
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=480 MxCh= 5
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=02 MxPS=64 #Cfgs= 1
P: Vendor=0424 ProdID=9514 Rev=02.00
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=2mA
I: If#= 0 Alt= 1 #EPs= 1 Cls=09(hub ) Sub=00 Prot=02 Driver=hub

T: Bus=01 Lev=02 Prnt=02 Port=00 Cnt=01 Dev#= 3 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=ff(vend.) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=0424 ProdID=ec00 Rev=02.00
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=2mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=ff Driver=smsc95xx

T: Bus=01 Lev=02 Prnt=02 Port=02 Cnt=02 Dev#= 4 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=045e ProdID=0284 Rev=01.30
C: #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=58() Sub=42 Prot=00 Driver=(none)
I: If#= 1 Alt= 0 #EPs= 0 Cls=59() Sub=00 Prot=00 Driver=(none)


#22

A post was split to a new topic: CEC, back button duplicates


#23

Thx for all, looks like kernel modules are missing for these IR receivers in current OSMC release.
Sam will look at these.


#24

So I figured out what the problem was ( in my case anyway…) I’ve always had my PS3,my PI 2 and my PC connected to my TV. Same day I updated my PI , I upgraded my PC with a GPU. Now if I plug the HDMI cable on my motherboard ( as it always was) everything works fine. BUT if I connect my PC through the GPU, the remote stops working… weird problem… Hope this helps a bit…


#26

Remote issues should be fixed.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.


#27

Hi there,

I am new to this forum but I have the same problem and I just tried your suggested solution with the development kernel but unfortunately, it doesn’t work.

IR remote still not functional (however it did before the upgrade and it also works on another ubuntu system with kodi. So the remote itself is ok)

BT mini-keyboard works as before

Any other things to try?


#28

Please post a log so we can see you have upgraded properly.


#29

which log would you need? uname -a shows

Linux osmc 4.14.78-3-osmc #1 SMP PREEMPT Mon Nov 5 13:35:03 UTC 2018 armv7l GNU/Linux


#30

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/


#31

ok. thanks - sorry for not reading the rules :wink:
Maybe we do not need the logs. It works now. I just tried once more and it seems to be ok now.


#32

After the upgrade, my remote started working again. Thank you very much.


#33

Yup… back to the races… made a donation and thanks…


#34

the update woked for me as well, thanks a lot!!


#35

Thank you for your support.


#36

Bye to all…
Unfortunately, after the update I can not use the samsung remote control, when everything worked fine before, but not even attempts to set samsung-lircd in OSMC work …

I tried but not sure I did everything right with the command line written above…sorry my inexperienced background.

Thanks in advance

Help


#37

A log will show if you updated correctly.


#39

Hi to all.
Update:
I had to redo the new installation of osmc in raspberry, fortunately my samsung remote works as before.

Fiù, what a struggle :grin::hot_face: