NFS mounts from fedora laptop not working


#21

So, in summary looking at themount -v output we see that this nfs server is not able to talk nfs4 but nfs3 fails since the rpc communication is borked. So, the error seems to be outside the OSMC device.

I would check the output of rpcinfo -p 127.0.0.1 on the Fedora system to see what has been registered and is available. Also check the netmask of the used IPv4 configuration on both sides but now I’m running out of ideas for the moment.

Others are welcome to help nickc with his router and Fedora NFS server to get it run.


#22

@JimKnopf thanks very much for your help Jim, I really appreciate it and I have learnt a bit more about how NFS works :slight_smile: or at least is supposed to work.


#23

[root@localhost ncusack]# sudo rpcinfo -p 127.0.0.1
program vers proto port service
100000 4 tcp 111 portmapper
100000 3 tcp 111 portmapper
100000 2 tcp 111 portmapper
100000 4 udp 111 portmapper
100000 3 udp 111 portmapper
100000 2 udp 111 portmapper
100024 1 udp 52456 status
100024 1 tcp 43865 status
[root@localhost ncusack]# rpcinfo -p 127.0.0.1
program vers proto port service
100000 4 tcp 111 portmapper
100000 3 tcp 111 portmapper
100000 2 tcp 111 portmapper
100000 4 udp 111 portmapper
100000 3 udp 111 portmapper
100000 2 udp 111 portmapper
100024 1 udp 52456 status
100024 1 tcp 43865 status


#24

from an ifconfig
inet 10.0.0.107 netmask 255.255.255.0 broadcast 10.0.0.255


#25

On the Fedora there should be entries for nfs + port 2049 in the rpcinfo -p 127.0.0.1 output like

100003    3   tcp   2049  nfs
100003    4   tcp   2049  nfs
100227    3   tcp   2049
100003    3   udp   2049  nfs
100227    3   udp   2049

Something is wrong on the nfs server.


#26

@JimKnopf
ok, thanks. I will see if I can figure that one out.


#27

Short hint: Make the defaults option the first in sequence in the lines of /etc/fstab. Later options can overwrite options specified by defaults as far as I understood the semantic, so

... nfs defaults,noauto, ...

(Nothing to do with your actual issue on the Fedora system.)


#28

@JimKnopf thanks Jim. /etc/fstab sorted.

I was reading the Fedora manual on NFS and RPCBIND and it says to check using rpcinfo -p and no ip address. When I do that I see two entries for port 2049 labelled nfs. One is for the version 3 protocol and the other is for the version 4 protocol and both are for tcp.

I don’t know if that is significant or not to be honest but I will keep looking.


#29

Ok, I edited /etc/exports and added FSID=n where n is a number >0 to each export. I then restarted nfs-server.
I now see:
[ncusack@localhost /]$ rpcinfo -p 127.0.0.1
program vers proto port service
100000 4 tcp 111 portmapper
100000 3 tcp 111 portmapper
100000 2 tcp 111 portmapper
100000 4 udp 111 portmapper
100000 3 udp 111 portmapper
100000 2 udp 111 portmapper
100024 1 udp 52456 status
100024 1 tcp 43865 status
100005 1 udp 20048 mountd
100005 1 tcp 20048 mountd
100005 2 udp 20048 mountd
100005 2 tcp 20048 mountd
100005 3 udp 20048 mountd
100005 3 tcp 20048 mountd
100003 3 tcp 2049 nfs
100003 4 tcp 2049 nfs
100227 3 tcp 2049 nfs_acl
100021 1 udp 46664 nlockmgr
100021 3 udp 46664 nlockmgr
100021 4 udp 46664 nlockmgr
100021 1 tcp 40323 nlockmgr
100021 3 tcp 40323 nlockmgr
100021 4 tcp 40323 nlockmgr
so I am using 2049 for the nfs for both tcp and udp.
Unfortunately I am still not able to share


#30

Hi,

Whats the output of:

sudo mount -v /mnt/Expansion

now?

Thanks Tom.


#31

@Tom_Doyle
Hi Tom the output is:
osmc@osmc:/$ sudo mount -v /mnt/Expansion
mount.nfs: timeout set for Tue Mar 13 19:43:12 2018
mount.nfs: trying text-based options 'vers=4.2,addr=10.0.0.107,clientaddr=10.0.0.69’
mount.nfs: mount(2): Invalid argument
mount.nfs: trying text-based options 'vers=4.1,addr=10.0.0.107,clientaddr=10.0.0.69’
mount.nfs: mount(2): Invalid argument
mount.nfs: trying text-based options 'vers=4.0,addr=10.0.0.107,clientaddr=10.0.0.69’
mount.nfs: mount(2): No such file or directory
mount.nfs: trying text-based options 'addr=10.0.0.107’
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 10.0.0.107 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: trying 10.0.0.107 prog 100005 vers 3 prot UDP port 20048


#32

When I run rpcinfo -p 10.0.0.107 I now get
osmc@osmc:/$ rpcinfo -p 10.0.0.107
program vers proto port service
100000 4 tcp 111 portmapper
100000 3 tcp 111 portmapper
100000 2 tcp 111 portmapper
100000 4 udp 111 portmapper
100000 3 udp 111 portmapper
100000 2 udp 111 portmapper
100024 1 udp 52456 status
100024 1 tcp 43865 status
100005 1 udp 20048 mountd
100005 1 tcp 20048 mountd
100005 2 udp 20048 mountd
100005 2 tcp 20048 mountd
100005 3 udp 20048 mountd
100005 3 tcp 20048 mountd
100003 3 tcp 2049 nfs
100003 4 tcp 2049 nfs
100227 3 tcp 2049
100021 1 udp 50482 nlockmgr
100021 3 udp 50482 nlockmgr
100021 4 udp 50482 nlockmgr
100021 1 tcp 39423 nlockmgr
100021 3 tcp 39423 nlockmgr
100021 4 tcp 39423 nlockmgr


#33

Hi,

Try updating the fstab entry to:

10.0.0.107:/run/media/ncusack/Expansion /mnt/Expansion nfs defaults,nfsvers=3,noauto,x-systemd.automount 0 0

Then please provide the output of:

sudo mount -v -a
sudo mount -v /mnt/Expansion

Thanks Tom


#34

@Tom_Doyle thanks for the help.
I changed the entry as you indicated and I removed the other share just to keep it simple. The outputs are:
osmc@osmc:/$ sudo mount -v -a
/boot : ignored
/mnt/Expansion : ignored
osmc@osmc:/$ sudo mount -v /mnt/Expansion
mount.nfs: timeout set for Tue Mar 13 20:00:44 2018
mount.nfs: trying text-based options 'nfsvers=3,addr=10.0.0.107’
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 10.0.0.107 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: trying 10.0.0.107 prog 100005 vers 3 prot UDP port 20048
mount.nfs: mount(2): Device or resource busy


#35

Hi,

Try:

sudo umount /mnt/Expansion

Then

sudo mount -v /mnt/Expansion

Thanks Tom.


#36

@Tom_Doyle
I am guessing this means it worked

osmc@osmc:/$ sudo mount -v /mnt/Expansion
mount.nfs: timeout set for Tue Mar 13 20:14:08 2018
mount.nfs: trying text-based options 'nfsvers=3,addr=10.0.0.107’
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 10.0.0.107 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: trying 10.0.0.107 prog 100005 vers 3 prot UDP port 20048


#37

Hi,

If you:

ls /mnt/Expansion

Do you see your files, from the laptop?

If so update the fstab entry for /mnt/Elements and reboot, then check you access both mounts.

Thanks Tom.


#39

Hmmm,
ls /mnt/Expansion returned an command prompt straight away


#41

I did the same for Elements and it works, I must have an error in the Expansion definitions


#42

when I cd /mnt/Expansion I go to the directory but nothing is there. If I use the Fedora File Manager on the laptop it sees all the files on the drive