New Vero4k & Kodi user: request set-up help


Powered up my new Vero 4k yesterday and ran it through the initial setup. I was excited and probably rushed a bit, and ended up having some trouble adding content. I am still working on that but in the meantime, I took a step back to look at the Settings more thoroughly to be sure I had things setup properly.

By the way, for this I used the web interface from my PC, namely {IP-of-4k:8080}.


    Under (a) kodi.audiodecoder and (b) xmbc.audiodecoder , only a couple of them were enabled at first. However, one reason I upgraded to this high end box was to be able to play “almost anything”. Why wouldn’t we want ALL of the decoders enabled? I turned them all on.


(a) Audio output device -- I have 3 choices 
  (ii) AML-M8AUDIO (surround21:CARD=AMLM8AUDIO, DEV=0), PCM

It was set to the first one.  _What is this?_  Via a google search I couldn't find any explanation of this and why I should choose any of the 3.  My box outputs via HDMI to a high end AVR with 7.1 ([Denon X3000]( and the monitor is a 1080p projector ([Panasonic PT-AE8000](

(b) Number of channels -- I set this to 7.1

(c) Allow passthrough -- I was surprised to see this turned off by default.  I turned it on.

(d) Passthrough output device -- there is only one option (AML-M8AUDIO, HDMI ... same as third choice above).

Could you folks on the forum help me out ?



It looks like we’ve been in touch by email. Welcome to the forum.

These binary addons are for playing back more esoteric audio formats, that are usually found in retro-games. You don’t need them enabled to play normal movies and music.

If you’re outputting audio via HDMI, set it to HDMI.
PCM is for the analogue output.

Not all people have an AV receiver that supports passthrough. So that they get some sound out of the box, this is off by default.

Make sure you configure which formats your device supports (you may need to enable Expert Settings).

That’s fine.



Make sure you configure which formats your device supports (you may need to enable Expert Settings).

I did need to enable Expert Settings and configure the Audio Passthrough options. Most of them were “off” by default – and I get why – whereas my AVR supports them all.

For future readers… to turn on “Expert Settings Level” go to GENERAL --> WEB INTERFACE --> ADVANCED OPTIONS