Logitech diNovo Edge


Hi, I’m trying to connect this (Logitech diNovo Edge old) keyboard to my Vero4K device.

I have paired it in Networking > BlueTooth and it shows up as Logitech diNovo Edge in the Paired Devices
with a blue sign next to it, so it pairs just fine, but when I try to use it (before and after reboot),
it simply doesn’t respond. I have used this many years for my htpc so I know it should work fine.

I have tried:

  1. Pairing it with dongle connected from Networking > Bluetooth
  2. Pairing it without dongle connected from Networking > Bluetooth
  3. Connecting it through SSH :

Nothing seems to work.
For SSH I used this guide

Any ideas would be appreciated,
Debug is :

I didn’t know what to include or exclude so its the entire debug log,
I can try again and make a more detailted debug log if needed.
Thanks, SkyHead


If you exit and login with a physical USB keyboard to the command line, are you able to use it there?



Yes the regular USB keyboard works fine both in menu and command line, by pluggin the dongle for BT keyboard it does not


If I turn on bluetooth by “bluetoothctl” the usb keyboard stops working


Might be a power problem. Does it work when you replug it? Suggest to login via ssh and provide grab-logs -J after you loose the USB keyboard


It sounds like the keyboard comes with a dongle.

The keyboard can likely only be paired with the dongle or another BT device (Vero 4K).
Your answer only adds a spanner in to the works however. When you pair the keyboard with Vero 4K’s Bluetooth; and then exit Kodi, do you have any joy? If not, can you post a set of logs.



Sam :


Doesn’t seem to work after exiting and trying to press Escape




Yes the usb keyboard works when I replug it


Do you roughly know when (time) you lost USB Keyboard?


I’d guess around 10:55 CEST (10mins ago), I can do it again if needed


10:55 was the time when you uploaded the log.
Might be 10:52 when you plugged in the Logitech reciever

Oct 14 10:52:02 osmc kernel: usb 1-1: new full-speed USB device number 3 using xhci-hcd
Oct 14 10:52:02 osmc kernel: usb 1-1: New USB device found, idVendor=046d, idProduct=c534
Oct 14 10:52:02 osmc kernel: usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Oct 14 10:52:02 osmc kernel: usb 1-1: Product: USB Receiver
Oct 14 10:52:02 osmc kernel: usb 1-1: Manufacturer: Logitech
Oct 14 10:52:02 osmc kernel: input: Logitech USB Receiver as /devices/c9000000.dwc3/xhci-hcd.0.auto/usb1/1-1/1-1:1.0/0003:046D:C534.0003/input/input11
Oct 14 10:52:02 osmc kernel: hid-generic 0003:046D:C534.0003: input,hidraw2: USB HID v1.11 Keyboard [Logitech USB Receiver] on usb-xhci-hcd.0.auto-1/input0
Oct 14 10:52:02 osmc kernel: input: Logitech USB Receiver as /devices/c9000000.dwc3/xhci-hcd.0.auto/usb1/1-1/1-1:1.1/0003:046D:C534.0004/input/input12
Oct 14 10:52:02 osmc kernel: hid-generic 0003:046D:C534.0004: input,hiddev0,hidraw3: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-xhci-hcd.0.auto-1/input1


I tried again and it seems the usb keyboard works now without re plugin

Yes I lost the keyboard right before I plugged in

For some reason it dosen’t say bluetooth but Logitech diNovo edge after entering “bluetoothctl”


11:32 or 11:33
Log after working “bluetoothctl” and USB keyboard


So let’s try to summarize current status.

  1. Your USB Keyboard works all the way regardless of the Logitech being paired or not?
  2. Your Logitech pairs but doesn’t provide keyboard function even not on the command line?

  1. Yes
  2. Yes, and no it doesn’t

Thanks :stuck_out_tongue: Getting abit confused myself


Well from the logfile not much to find.
I googled a bit and there is a possible power issue, do you by any chance have a powered USB Hub to test with?
Also it seems the keyboard has a full and a HID compatible mode do you know how to switch between them?


Ok, so I borrowed it from a friend, but no experience with it.

I plug it into Vero4K with a USB two sides…
And I plugged both keyboards in it, but neither works.

I tried all ports to connect it with Vero4K

I have no idea about the hidden compatible mode, and cant find it on google

Coould you do a short summary of how I’m supposed to connec it?

USB Power to the HUB (external power source)
Logitech diNovo Edgee
USB Logitech Keyboard
USB to USB Vero4k

Btw the diNovo Edge has a seperate charging station and is not connected via USB other then the BT dongle


That looks right, can you show a picture?
Also check lsusb should show you what is connected

Also haven’t found anything on how to switch (was hoping you have a manual). This is where I read about this two modes


Here’s pictures without the power cord (to short of a cable to get it in a picture)

The Vero4K seems to power it and not connect it. (Is this cause the power cord is not connected?)

osmc@osmc:~$ lsusb
-bash: lsusb: command not found

The keyboard is to old for me to have any such manual, sorry.

This guy seems to get it working

but I have tried everything he did and nothing, but I guess this means the Vero4K can power it? It is based on RPi3 right?


Well if you have a USB hub with external power I sure suggest to use it to exclude power as one source for the issue

need to be installed `sudo apt-get install usbutils