Kernel modules missing for the PCTV 292e DVB stick



dvb_core comes from media_build now, so this commit
isn’t relevant.

media_build has patches for 64-bit -> 32-bit pointers already, so
some further investigation is needed.




I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Alternatively you can wait for the next update.



Hi Sam,

Sure, always happy to help! Expect my feedback tomorrow. I presume there’s no need to downgrade afterwards, since the current devel repo’s packages will become the next release anyway?

Already a huge THANK YOU for trying to make this work - and a happy 2nd anniversary :thumbsup:



We will probably release the update before then after some
positive results




I’ll try to get you some update tonight.


Sorry to say but the original error still persists:

2017-07-02 20:58:00.305 linuxdvb: Silicon Labs Si2168 : DVB-T #0 - DTV_CLEAR failed [e=Inappropriate ioctl for device]

I checked that the new kernel (3.14.29-25-osmc) is in use and Tvheadend is at 4.2.2 now.

Note that I now also see repeated (unrelated) messages, every 5 seconds, which seems like a regression:

2017-07-02 21:02:49.259 htsp: [ osmc | Kodi Media Center ]: Disconnected
2017-07-02 21:02:49.260 htsp: Got connection from
2017-07-02 21:02:49.260 htsp: Welcomed client software: Kodi Media Center (HTSPv25)
2017-07-02 21:02:49.260 htsp: [ Kodi Media Center ]: Identified as user 'osmc'
2017-07-02 21:02:49.260 htsp: [ osmc | Kodi Media Center ]: Privileges updated
2017-07-02 21:02:54.261 htsp: [ osmc | Kodi Media Center ]: Disconnected

If there’s anything more I can do, please let me know.



Don’t think that’s relevant and may be a possible TVH bug. Where do you see these logs? If it’s in TVH, then not likely to be related to OSMC.

I guess it may still be broken for some tuners for now. Will keep investigating, but it will miss this update.



Don’t think that’s relevant and may be a possible TVH bug. Where do you see these logs? If it’s in TVH, then not likely to be related to OSMC.

Yep, in TVH. As I said, unrelated. Just wanted to let you know.

Will keep investigating, but it will miss this update.

Yeah, too bad. I’m really eagerly waiting for this. This was my main reason to upgrade from the RPi3 to the Vero (apart from supporting OSMC of course!) :cry: Again, we can work more closely on this if it helps debugging. I don’t expect you to fix this alone remotely.



We’ll get it fixed soon enough. When we do, I’ll let you know.

There are many reasons to use the Vero 4K over Pi 3. But I understand that people want more DVB adapters to work, so that’s what we’re working on.



Sure, you know I appreciate that. Just be ensured I’m always available to help.



Hey @sam_nazarko,

I think I figured it out! I just stumbled upon the separate aarch64/arm64 package of the the OSMC TVH app, duh! MyOSMC always installs the armv7 version of it which can easily explain why the ioctl doesn’t work with a aarch64kernel/driver. It might just be the expected multi-arch issue after all. Unfortunately, I can’t install the aarch64 package since there’s an unresolved dependency on the dvd-firmware-osmc (arm64) package as well as a conflict with python-minimal which needs to be arm64 as well (won’t work because of other OSMC packages still needing the armv7 version). Please check your repo in this regard. Also, is there an easy way to cross-grade to arm64 entirely? I typically avoid multi-arch installations where possible.

If this is not a red herring we should get this thing fixed in no time…



No – Debian Jessie is buggy on aarch64 and doesn’t have several fixes for CPU errata. We discovered this in February 2017. We would also have problems with Netflix and Amazon Prime Video (support will come soon) if we moved to aarch64. There seems to be no performance gain from aarch64.

Yes – we are well aware that the issue is caused by 64-bit -> 32-bit pointer dereferencing and we have already fixed a couple of these issues in the kernel, but we are not quite there yet it seems.

The solution however is not to use an aarch64 version of TVHeadend.


Ah, too bad. Really looked promising this time…


Final one for tonight: I fixed the apparent regression (reconnects each 5 sec) by removing the existing TVH config and setting it up from scratch. Never mind.



Cheers, will let other users know about this if they get it too


Nah, forget it. It reappeared with 4.2.2 after the next reboot. Downgraded to 4.0.9 again, finally no more reconnect issues…


Hi @sam_nazarko,

Just deployed the July update. I presume there aren’t any DVB adapter fixes this time (according to the news)?



Hi @brevilo

Actually, we’ve now managed to get TVHeadend working on Vero 4K. See this link. Make sure you use the TVHeadend build suggested in that post for now.

No announcement of this is published as we want to get a bit more testing first and make sure everything is working as expected.


I’m sorry to say but it doesn’t work for me. Still the same ioctl error:

linuxdvb: Silicon Labs Si2168 #0 : DVB-T #0 - DTV_CLEAR failed [e=Inappropriate ioctl for device]

FYI, I purged the version that came with the latest July update and set up Tvheadend from scratch after installing the Dropbox package. Please note that the custom Tvheadend package has the same version number (4.2.0-2) as the one in the July update.

Darn :tired_face:


A full log will help.

At this point it might be an issue with the stick specifically, as we have had a few confirmations of positive reports after the test build.