Installer doesn't scale well on HiDPI screens


#1

The OSMC installer doesn’t seem to scale very well on HiDPI screens.
I have a Dell XPS 15 with resolution 3200x1800 and text size 200%, so it basically looks like 1600x900 and this is what the installer looks like:

It’s easy enough to workaround, just change resolution, text size and relogin to run the installer and reverse after. FYI the Rasbmc installer didn’t have this issue.

Ben


#2

Hi there

I don’t have a HiDPI screen to test things on, but I’ll see what we can do to solve this

Sam


#3

You could just test with any resolution with text size increased, just a standard feature of Win7+


#4

Do you also use “Set custom text size (DPI)” option? I’ll have a look if we can recognize the text size setting and scale accordingly.


#5

I’m not using a custom size, just setting the overall scaling in Windows 8.1:

It works pretty well at 125%, which would be common for people with a 15 inch 1080p screen. Some might even use 150% which may not work, but I haven’t tested. Obviously from my first screenshot 200% is no good.

I’ll admit I’m probably in the very small minority, but thought it best to report.

Ben


#6

And for completeness, it “just” works at 150%:


#7

Ah, right. Thanks for the update. I’ll have to rework the layout. Might take a while. I’ll come back here once there’s a fix-candidate


#8

Is there any news on this?
I ran across this problem with the current version as well.
On Windows 8.1, 3840x2160, 15,6" screen.
Scaling set to 200%


#9

I know… We need to move to Qt 5 too, add El Capitan support, quite a bit to do.

We will keep you posted when it’s done

Sam


#10

btw, I notice this last week on Windows and Linux.
But on Linux I could read enough to complete the installer.


#11

Yep, we still have not implemented HiDPI yet.


#12

Are you making any progress on this subject?
I’m having trouble selecting the correct options when running the installer on a Surface Pro 4.

Best regards
Poul Anker


#13

Not yet

Sam


#14

raising-the-dead
Yeah, this needs a major rewrite of the whole installer. And we are only so many people writing it :slight_smile:


#15

Looks like we’re going to have some fun over the next few months…


#16

This is an easy fix:

  1. Navigate to the directory you downloaded the osmc-installer.exe file to (default is c:/downloads).

  2. Right click on the osmc-installer.exe icon and go to “Properties”

  3. Click on the “Compatibility” tab, and check the box for “Override DPI scaling behavior.”

  4. Make “Scaling performed by:” set to “System.”

  5. Reboot the app and viola!

Hopefully this helps someone as I made an account just to say this was my solution.


#17

Might be able to patch this in the manifest for now…