Increasing max volume


#41

Apologies. I called the button the “pair button” but stand corrected.
The really odd thing is that with one bluetooth dongle (connected to my PC) - the Creatives connect with no hitch at all. But now I have tested two other dongles, and within the PC bluetooth control the Creatives are not seen; and from the Creatives, they will not connect. I conjecture that the Creatives use an implementation of bluetooth that is not supported in some bluetooth dongles, but it is in others.
It’s moot for me now, as I have found a way to get audio from the Vero - via the USB - and now want to boost the volume.
The really strange things are that:

  • the dongle that works with the Creatives T50, also detects a Soundblaster AXX200
  • a Vaio laptop running Win10, with built in intel bluetooth does not detect or pair with the Creatives or the Soundblaster.
  • the same a Vaio laptop does not detect or pair with the Creatives or the Soundblaster when the other bluetooth dongles are inserted.
  • the Vero, when bluetooth is activated does see the PC (with the dongle that works), but does not see, as previously noted, the PC when using the other dongles; nor does it see the Soundblaster.
    While puzzling, it’s moot for me now, as I have a way to get audio from the Vero - via the USB - and now want to boost the volume.
    Thanks for your reading and advice. Very much appreciated.

#42

I only have the VERO remote - and it does not have a + button.
Can I get at that setting via the terminal?


#43

Right. I found an “airmouse” that came with a now discarded xtreamer. It has volume on it and I’ve boosted kodi to 100%.
Q: will it preserve that setting between reboots? If not, how can I make it permanent?
I also went back into alsamixer via terminal. I found the volume on the soundblaster Paly!2 had reset to 40.
I boosted it to 87. It does not seem to retain the new setting between reboots.
Q: Is there some wah tto edit the configuration file to make that change to 87 permanent?
Thank you for reading and for advice. Much appreciated.


#44

This will be preserved between reboots

Normally that settings should be saved but there are currently some issues with the alsa package. Maybe revisit this after next month update.


#45

i tried the current kernel today (3.8.9 - vero364-image-3.14.29-37-osmc:arm64) and the amplification issue (as i previously described it) is still the same. such a disappointment…

i’m now trying to figure out how to revert to the previous kernel (which was working) without having to backup and flash the device. any help or hints would be appreciated…


#46

The issue may not necessarily be kernel related, by related to AML-M8AUDIO.conf.

Which kernel was it (do you remember the exact version)?
We keep some old kernels in our repository, but only for a short while.

I’m looking in to this further.

Cheers,

Sam


#47

hey sam, it’s all documented in this thread: the last kernel version in which both amplification and volume worked was vero364-image-3.14.29-25-osmc


#48

Hi

Unfortunately that kernel is not in the repository anymore.
But thanks for confirming the exact working version again. I may be able to build it for you again, although I’d rather take a stab at fixing the issue properly.

Sam


#49

here are my thoughts:

  • fixing the issue for good would be great, but in the meantime i need a workaround
  • if i am to test different kernel images or setups, i should be able to revert to the last working version without having to backup/flash/restore the vero 4k each time.
  • kernel-3.14.29-25-osmc.img is still available in /boot/. i just don’t know how to re-enable it. i also think about avoiding some mixed-up state which apt updates would mix up even more
  • i downloaded the 2017.06-1 image (the last working one) , extracted it and checked /usr/share/alsa/cards to see if there are differences in AML-M8AUDIO.conf. there is no AML-M8AUDIO.conf file in this image…

#50

Try:

sudo apt-get install --reinstall vero3-image-3.14.29-25-osmc

Edit: /etc/osmc/prefs.d/update_preferences and change autoremove kernels flag to 0.


#51
E: Unable to locate package vero3-image-3.14.29-25-osmc
E: Couldn't find any package by regex 'vero3-image-3.14.29-25-osmc'

#52

Sorry, typed that in a hurry, should be vero364-image.

You can use dpkg -l | grep vero364-image to see a list of kernels that are available on your system.


#53

so apparently there’s no need to reinstall the old kernel, as it is still installed:

dpkg -l | grep vero364-image

ii  vero364-image-3.14.29-25-osmc  25  arm64  Linux kernel binary image for version 3.14.29-25-osmc
ii  vero364-image-3.14.29-37-osmc  37  arm64  Linux kernel binary image for version 3.14.29-37-osmc

reinstalling does not work anyways:

sudo apt install --reinstall vero364-image-3.14.29-25-osmc

Reinstallation of vero364-image-3.14.29-25-osmc:arm64 is not possible, it cannot be downloaded.

still, the newer version is in use:

uname -a

Linux osmc 3.14.29-37-osmc #1 SMP Wed Sep 27 22:43:28 UTC 2017 aarch64 GNU/Linux

#54

We purge most old kernels after a period of time. However as your system shows that it’s installed on the system, it should be possible to reinstall without redownloading.

Can you post the contents of ls -l /boot and ls -l /lib/modules I can give you manual instructions.

Sam


#55

ls -lh /boot/
total 33M
-rw-r–r-- 1 root root 92K Jul 2 15:53 config-3.14.29-25-osmc
-rw-r–r-- 1 root root 93K Sep 28 00:38 config-3.14.29-37-osmc
-rw-r–r-- 1 root root 37K Jul 2 15:51 dtb-3.14.29-25-osmc.img
-rw-r–r-- 1 root root 40K Sep 28 00:35 dtb-3.14.29-37-osmc.img
-rw-r–r-- 1 root root 7.5M Jul 2 16:54 kernel-3.14.29-25-osmc.img
-rw-r–r-- 1 root root 7.7M Sep 28 01:11 kernel-3.14.29-37-osmc.img
-rw-r–r-- 1 root root 1.2M Feb 18 2017 splash
-rw------- 1 root root 2.7M Jul 2 16:30 System.map-3.14.29-25-osmc
-rw------- 1 root root 2.8M Sep 28 00:47 System.map-3.14.29-37-osmc
-rw------- 1 root root 5.5M Jul 2 16:30 vmlinuz-3.14.29-25-osmc
-rw------- 1 root root 5.6M Sep 28 00:47 vmlinuz-3.14.29-37-osmc

ls -lh /lib/modules
total 8.0K
drwxr-xr-x 3 root root 4.0K Jan 1 2015 3.14.29-25-osmc
drwxr-xr-x 3 root root 4.0K Oct 5 14:41 3.14.29-37-osmc


#56

I think the error from APT occurred because you ran apt install rather than apt-get install.

Anyway:

sudo -s
LANG=C /bin/dd if=/boot/kernel-3.14.29-25-osmc.img of=/dev/boot bs=1M conv=fsync
/usr/bin/fw_setenv upgrade_step 2
LANG=C /bin/dd if=/boot/dtb-3.14.29-25-osmc.img of=/dev/dtb bs=256k

Should do the trick. You can then reboot and check the kernel version with the uname -a command.

Sam


#57

i did execute apt-get not apt. nevertheless, the manual switch worked. i’ll stick with 3.14.29-25 for now… thanks


#58

FYI: this issue is still present after the osmc january update :unamused:


#59

What are you connecting to the Vero via the analogue port?


#60

analogue speakers with external power supply - same as before.
but does it matter? my issue is with the alsa settings which don’t work correctly since august.