Increasing max volume


#21

thanks @sam_nazarko. i had already reverted to vero364-image-3.14.29-25-osmc (that was the lowest version available) and then installed vero364-image-3.14.29-29-osmc after having some other issues.

now i can adjust the DAC Extra Digital Gain setting between 0 and 18 db, but the DAC Digital value is stuck at -11.25 db.

sudo alsactl store doesn’t hang anymore and now displays:
alsactl: get_control:256: Cannot read control '3,0,0,Playback Channel Map,0': Invalid argument

still, the current configuration works for me, at least for now. it feels like a very volatile situation…

below is some info to the current software state on the vero4k.

apt-cache policy vero364-image-3.14.29-29-osmc yields among other things: Installed: 29
apt-cache policy vero364-image-3.14.29-25-osmc yields among other things: Installed: 25
apt-cache policy for versions 27 and 28 yield Installed: (none) among other information
uname -r yields 3.14.29-25-osmc

quite a mess… :slight_smile:

i would be interested if my issue(s) can be reproduced by others.
please let me know if you need additional information ot if there is anything else i can do to help.


#22

Are you 100% sure this issue only occured in July?
I made a lot of audio changes in June, including to the way ALSA is handled and am surprised you didn’t see a problem there.

If you have a bit of time, can you confirm the June image on the website doesn’t exhibit these problems?

Sam


#23

i am quite sure that it was the july update. the update settings are unchanged and i apply them with a delay of at most 24h after receiving the newsletter or being notified in the kodi UI.

i’ll give the image on the website a try, but it might take a while to find the time.


#24

No problem – I’ll see what we can do on this side too.

Sam


#25

Yes. Before July update, Extra Digital Gain was working but distorting at 18dB. After update, Extra Digital Gain not working, main vol control working, but that’s a softvol device and the range and linearity of it is not good. There should be some way to control the DAC hardware, I’d have thought. The Ext Spk control has no effect. Unmuting Audio i2s turns off pcm audio. Audio spdif Mute has no effect on pcm audio.

The channels are reversed as reported here, and I have another issue: channel balance through headphones is correct, volume is inadequate. When feeding an amp, the volume on one channel (the one fed to the tip of the plug) is fine, the other channel is very quiet.

As you say, a bit messy ATM.


#26

by “messy” i meant the software state which i managed to have (multiple vero images installed, working amplification, non-working volume). but the way you describe it, it sounds messy too :slight_smile:

regarding the reversed channels:

as i had one of the 3.14.29-27+ vero images installed (i don’t remember which and i won’t touch my current messy/working state until i have a bit more time to sort things out a bit), i “saw” an additional item in alsamixer called something like “reverse audio l/r”. i said “saw” because it was not really visible, but it could be selected by pressing the right arrow key when the last visible item was selected. the only indication that it was selected, was the “item” name was displayed in the top-left corner. i didn’t pay much attention to it, but maybe you can use the information…


#27

Yes, I saw that and toggled it. But now I can’t toggle it back.


#28

I just flashed the june image (2017.06-1) and installed alsa-utils. The behaviour is as following:

  • it is possible to adjust the volume in kodi (using a software remote, I don’t know how to do it using the remote provided with the Vero 4k)
  • it is not possible to alter the value of DAC Digital in alsamixer (it’s stuck at 56). dmesg does not display anything when attempting to alter the value
  • it is possible to alter the value of DAC Extra Gain in alsamixer

I normally use a software remote to control the volume in kodi, so I did not notice the fact that the volume could not be altered in alsamixer in this version of osmc (it was irrelevant to the way I used the media center).


#29

After upgrading to the current version (3.14.29-34-osmc), the DAC Digital value can be altered and the DAC Digital Gain value can’t be altered.


#30

here’s my current “workaround”, since osmc kernel versions after 2017.06-1 (3.14.29-25) are unusable for me:

  • back up the entire osmc user home dir: tar cvzf <external path>/<backup file name>.tar.gz .
  • flash the 2017.06-1 osmc image
  • log in using SSH
  • stop the mediacenter: sudo systemctl stop mediacenter
  • delete everything in the osmc home dir so there won’t be a mix of settings later
  • restore the original content of the osmc user dir: tar xvzf <backup file name> .
  • hold back the osmc kernel image which comes with 2017-06-1: sudo apt-mark hold vero364-kernel-osmc
  • perform an upgrade and reboot: sudo apt update && sudo apt dist-upgrade && reboot

maybe the above will help someone who encounters the same issues as I do.

there are no older versions of the kernel available in the repository, so reverting to the one which works involves wiping and restoring the entire vero 4k, which is quite a cumbersome process.


#31

At least one previous kernel version used to be retained in /boot. I think that changed recently - maybe it could be revisited to keep just one previous.


#32

There should be the current and one previous kernel in /boot. The change you refer to was probably the one about stopping the previous kernel from being removed when apt-get autoremove was run from the command line.


#33

maybe I was unclear when I stated that i can’t revert to old packages. i meant that there is no way to revert to an old image using apt (so eventual dependencies won’t be broken when reverting). at least i don’t know how.

anyways, that was just an off-topic remark to point out my difficulty of reverting to a usable state. my mistake…


#34

Yes, we are straying off-topic but AFAIK, you can just boot from an old kernel image. It should pick up the right modules if there are still there. Had to do it many times in Ubuntu :wink:


#35

Hello. To return to topic (I hope).
I had bothers pairing my Creative T50s to the Vero via bluetooth…tried recommended fixes and still no luck and produced sound problems (see No sound out via headphone jack).
I was given a Sound Blaster Play! 2 - a USB - digital-analogue dongle. Works a treat, out of box. Except volume level is too low.
I could not find the kodi volume control; but as per Sam’s instructions, I installed alsa and, via terminal, increased the level to 84. That improved by about 15% the sound output - meaning I could reduce the volume on the speakers, from almost full (at the 16.00 hr mark, if you imagine the volume knob as a clock, to the 13.00 mark. But still it is too low. I usually have the volume at about the 11.00 mark for most playing, on my PC. The file being played is a FLAC, encoded from a CD.
Are there any suggestions for further boosting the sound?
For instance, would a toslink to analogue - speaker link be higher volume? Ot are there small headphone amplifiers that might do the trick?
I’m very new to all this and its a steep learning curve. Please be patient!
Thanks for your time and for reading. And your replies.


#36

So you are saying that when you put your Creatives into pairing mode (holding the bluetooth Connect button for 3 seconds and release) you cannot see it from the very neither when you go to scanning in MyOSMC nor when using bluetoothctl -> select -> scan on -> devices?

Have you increased the volume within Kodi already to 100%?


#37

Hello fzinken

Yes. that is correct. The Creatives do not show up in the Vero (but my ubuntu pc does); and when I press the pair button on the Creatives, pairing does not occur.


#38

based on the manual it is not a “pair” button but a “bluetooth connect” button that would put the creatives into discoverable mode.
Should they not be visible even in bluetoothctl after being put in discoverable mode that would be very very strange.


#39

I have tried to find the menu for that, but have been unable to. The interface that I see when it google it is nothing like that in the Vero.


#40

Just press the + key on your remote. If you don’t have a remote with that button you could use for example a remote on your mobile phone like yatse or kodi core.