[HOWTO] SainSmart I2S HIFI DAC / PiFi DAC+ V2.0 on a Raspberry Pi v2 with OSMC 2016.01-2


#1

2016-02-21 - Updated for OSMC 2016.01-2

I bought one of these on eBay. It came without instructions or drivers and I’ve spent a couple of days figuring out how to make it work. It appears to be a clone of the hifiberry dac+.

To save others the pain…

  1. Install OSMC. I’m on 2016.01-2
  2. In “My OSMC” / “Pi Config” / “Hardware support” - select “hifiberry-dacplus-overlay”
  3. In “My OSMC” / “Pi Config” / “Config editor” - remove “dtoverlay=lirc-rpi:gpio_out_pin=17,gpio_in_pin=18”. Check that the “dtoverlay=hifiberry-dacplus-overlay” line is present.
  4. SSH into your Pi and add /etc/asound.conf with contents:
pcm.!default {
        type hw
        card 1
}

ctl.!default {
        type hw
        card 1
}

NB1: the card number may not be ‘1’. Do aplay -l at the command line to list available hardware.
NB2: You need to create & edit the file as root, for example sudo nano -w /etc/asound.conf.
5. Reboot
6. In “Settings” / “System” / “Audio Output” - Audio output device - select "ALSA: Default (snd_rpi_hifiberry_dacplus Analog)"
7. Reboot again (maybe)
8. Enjoy!


Allo Boss i2S DAC
#3

hi. i bought similar card. PiFi Digi+. I follow your guide but in setting - audio output there isn’t ALSA: hifiberry. Is it possible that there is a conflict with ALSA; OSMC Bluethoot that i have installed on my rasp? In audio output there are only: HDMI; analog; HDMI & Analog; ALSA: OSMC streaming Bluethoot. thanks


#4

Hi @bengio.

I haven’t tried bluetooth on OSMC yet so can’t tell you much.

Does the DAC work without bluetooth installed? If so you’d better ask the OSMC developers. If you find that the howto needs updating for bluetooth users, let me know and I will.


#5

I followed your steps but it took quite a bit more fiddling to get my exact same setup working. Found https://github.com/guussie/PiDS/wiki/09.-How-to-make-various-DACs-work which also didn’t work until I combined with your steps. It took a bunch of trial/error and I regression tested enough to know that what I did is the only way to make it all work:

a. edit /etc/modules which for my install was completely empty. “snd_bcm2835” wasn’t listed so I didn’t need to comment it out… Then I added the four lines from the github page:

sudo nano /etc/modules
bcm2708_dmaengine
snd_soc_pcm512x
snd_soc_hifiberry_dacplus
snd_soc_bcm2708_i2s

b. edit /boot/config.txt to have:
sudo nano /boot/config.txt
dtparam=i2c_arm=on
dtparam=i2s=on
dtoverlay=hifiberry-dacplus-overlay
dtparam=audio=off

c. edit /etc/asound.conf

sudo nano /etc/asound.conf
pcm.!default {
type hw
card 0
}

ctl.!default {
type hw
card 0
}

d. reboot and “ALSA: Default (snd_rpi_hifiberry_dacplus Analog)” now shows up and the card outputs audio

Now to get airplay working…Sigh…


May 2017 update - No sound with PIFIDAC+ soundcard working before
#6

@Andrew_Renz Thanks for that. Nice sleuthing, it must have taken a while.


#7

Hi was just wondering if anyone has tried this sound card dac+berfore: WINGONEER PiFi Digi DAC+


#8

They all are based on a similar chip so you most likely will succeed with the existing overlay. But surely if it doesn’t work you are on you own. Only with the original hifiberry you will have a manufacturer in the background who fixes stuff


#9

I should have done more research on overlay brands. Have to do some programing and I’m a novice at best.


#10

HAT WORKING!!

So with the Pi 3, new install of OSMC last months img.
Using a WINGONEER PIFI Digi DAC+ HIFI DAC PCM5122 Sound card module I2s port v2

Installed system, changed sound card overlay in my osmc to: hifiberry-dacplus-overlay
reboot
Then changed w1gpio setting to: w1-gpio-overlay. (both in hardware support.)
Then added line in Config Editor: dtparam=audio=on
reboot
then change kodi system audio settings to ALSA
reboot

works awesome