[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC


#1436

Hi everyone!

I’ve successfully installed RetroPie following this guide and enabled the swap file in order to do so.

I’ve tried to disable it in 2 ways:

  1. sudo /touch disable swap

  2. sudo swapoff -a -v
    sudo rm swap

After the restart swap file is present again and in use.

Should I be concerned about SD card wear since swap is on and if yes, how can I disable/remove it?


#1437

Try:

sudo rm /enable_swap
sudo reboot


#1438

That did it, thanks @joakim_s!

I’ve seen that there were 2 empty files in the root - enable_swap and disable_swap.

If my understanding is correct, by deleting one of them you effectively enable/disable swap.

In my case, I needed to delete enable_swap and leave disable_swap in order do have the swap disabled after reboot.


#1439

You can remove both, the second one you created by doing your own touch command.

The touch command creates a 0 byte file, and OSMC just checks if there is an enable_swap file in root directory, if there is it will create a swap file.


#1440

Got it, thanks again.