[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC


#1396

Hello,

My launcher addon displays a loading screen and then it just stopped.
ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.program.retrosmc-launcher/) failed

Any ideas? I have uninstall and installed it again, not working.

Thanks


#1397

The add-on has been changed, you need to try again with the newer add-on

Try this link to explain, a few scripts have been removed and new ones used, so the launcher is looking for a script that isn’t there anymore or trying to run something it can’t find. It took me a long time to find that out

It explains how to update the RetroSMC script to the latest release and how to install the new launcher. It works fine after that

I have a different issue that things are running really slooow when trying to play ANY games. I know it worked perfectly before when I first found RetroSMC. I even reinstalled OSMC from scratch on a fresh and did everything exactly as the add-on suggests, still runs slow when trying to play ANY games. Overclocked PI3 that works perfectly otherwise running KODI 17.6


#1398

It looks like some progress has been made to get RetroPie to work with Debian Stretch. It’s of course up to @mcobit if he wants to up-date his tutorial to work with OSMC.

Sam


#1399

Thanks for that but since I have uninstall and now I can’t reinstall properly anymore emulestation due to memory issues. Weird.
I need a swap I guess but how?


#1400

Discussed numerous times in this topic:


#1401

Mea Culpa and thank you, I didn’t see that the main topic has been updated.
I have launched

  1. sudo touch /enable_swap

  2. sudo reboot

  3. ./install-retrosmc.sh > Install retrosmc > Manage Packages > Manage core packages > emulationstation > Install from source

  4. Result is still the same, please find logs https://hastebin.com/raw/duzazanuvo

Thanks for your support! I hope I will be able to play back again soon :slight_smile:


#1402

You need libboost-dev and libboost-date-time.


#1403

Libboost-date-time seems to still failing.
What is the proper install cmd for that package?


#1404

I’m sorry. I have not even installed it on stretch myself. So it is a bit hard for me to tell whats wrong here. I am a bit busy lately and thought Kodi 18 would come in time to solve this by itself with its retrogaming capabilities. Unfortunately stretch was faster.

I will revisit this but need more time to actually do anything with a raspberry.

I think there were some pointers some posts back.


#1405

OK!
Any help to fix this error is kindly welcomed :blush:
make[2]: *** No rule to make target '/usr/lib/arm-linux-gnueabihf/libboost_date_time.so', needed by 'emulationstation'. Stop.


#1406

When you have a search for libboost_date_time in this topic alone, you’ll get enough hints for how to maybe solve it :slight_smile:


#1407

I tried but nothing relevant. It’s not the same as people with the wrong version.
But I will be glad if you can assist!
Thanks


#1408

I don’t think its a version issue, I just don’t think these are available in debian stetch; hence the work around.

Thanks Tom.


#1409

Thanks but I already tried this. There is still the same error :frowning:


#1410

Was the initial RetrOSMC install done with Jessie (prior to January 2018) or Stretch (after January 2018)?

See the sequence above that worked for me.


#1411

Initially with Jessie but as it doesnt work I have removed everything and restarted with the Stretch test script.


#1412

No idea why it didn’t work with Jessie. :confused: Try the order from the post linked above then.


#1413

Stretch support seems to be OK now.
@mcobit any update planned on your side?


#1414

Hy Guys!

Im pretty new here so please be patient with me :slight_smile: First of all thank you for your awesome work, Im really appreciate it! Thanks!
So right now I have installed RetroPie via your script onto a freshly installed osmc, everything seems to work fine (as I can see) except 3 things:
0, As I understand in your script there is an option to add the main menu item, but it does nothing right now, I dont know its my fault or not but I added it manually.
1, At the startup I see the console output, but just some parts of it, then the osmc logo is pixelish, then on the main screen of osmc the resolution is fine (right after the install it was pixelish too but changed it to match my tv in settings and works well now)
2, The CEC functionality stopped totally. I applied the CECFIX parameter but it does nothing for me. Restarted the pi several times, tried to enable and disable the CEC plugin , tried to turn on off the tv and turn the cec functionality on and off on the tv , nothing worked.

The 0-1 doesnt bother me but missing the CEC functionality which was my main interface for the pi is a pain in the a**.

Could You help me with this? Im not a linux expert but nor a noob so if you need any technical details, logs, etc just let me know, I will try to provide everything.

EDIT: 2 days later:
Right now the raspberry pi running all day for me, but after a while, its not deterministic when it doesnt matter even if im in retropie or on the osmc screen , the pi freeze, the green led is on continously, cant establish an ssh connection, the processor is hot, the picture is frozen.


#1415

I have updated everything about RetroPie and running the last version of OSMC.
I still can install it as the build is failing for emulstation… (99%)

594:make[2]: *** No rule to make target ‘/usr/lib/arm-linux-gnueabihf/libboost_date_time.so’, needed by ‘emulationstation’. Stop.

Someone knows how to solve this? I have already made the ln tips mentioned above…

Thanks!