[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC


So i’m trying to get this working and keep running into what seems like disk issues or corruption, but they only appear after attempting to mess with the retroosmc scripts.

I’m installing a brand new fresh install of osmc … no issues there … everything is working and configured.

Then i start the process of the script and most of it works, but when the retro pie stuff always seems to fail and i start getting read only disk errors and dpkg failures all over the place. very odd. is the sd card just bad and somehow these additional installations make it more apparent?


If you get read only and stuff the card is certainly bad.
Try another one.


Ok, so I managed to install it this time, with no problems. Strangely, I have no idea why. I made exactly the same steps as when it was failing on me before, but this time it succeeded. Even without the addon! I just added a custom menuitem with System.Exec(/home/osmc/RetroPie/scripts/retropie.sh), just like I wanted to.


Is Retrosmc compatible with the new V4K?


Not at this time, but retrogaming is possible with Kodi v18 builds:



tried this with a new card and sure enough it worked like a dream.


so … I need to adjust overscan but the raspi-config menu doesnt do anything. just goes to a blank screen and then back to the previous menu. Is this due to the dual boot nature of the setup or is something else “afoot”?


Raspi config is not supplied with osmc as it can break things.

What you really should do is to set your tv to 1:1, just-scan or whatever that mode is called where the pixels are displayed 1:1 without any aspect correction.

You can also ditch the screencalibration in kodi then.


my tv doesnt give me options to fix it unfortunately. Its a 10+ year old samsung plasma… in KODI i have to adjust the “video calibration” settings a decent amount to make sure nothing is cut off … is there a backend config file i can adjust the values in?


You can edit /boot/config.txt directly if you really need to.

See here for reference:


The TV has no aspect ratio modes or wide-screen modes?



awesome. thanks. just out of curiosity … do you know if kodi/osmc stores the values of the “video calibration” in any of the configuration files? Seems logical … and if i can just pull those values from that … i’ll be good to go.

Thanks for your quick responses. Much obliged.


As actiona said, those are stored in guisettings.xml


doh! that reply didnt show up when i responded. thanks to both of you … i should be able to take it from here!


dude … its bad … i have a “game mode” and thats about it … srsly … its an OLD ass plasma …


can i just copy/paste the values from guisettings.xml?


here is my current setting from guisettings.xml


I guess not as those don’t look like something I would put in config.txt.
It also depends on the native resolution of your TV. You could calculate the actual overscan from those values though.

Did you try the game mode of your tv?


it doesnt really help and seems to screw up everything else.

the games themselves work fine, but emulationstation as a whole is just … too large for my screen …


You could try to set the resolution to the native resolution of your tv in cobfig.txt.


@mcobit Ok, I have a problem with installation but additional emulators (lr-ppsspp)

I do clean install of OSMC 2017.02-2 and just after installation run your script using guide from here: https://github.com/mcobit/retrosmc

After installation i go to optional emulators and install lr-ppsspp from source. I put ISO into raspberrry. Open the game and I have first screen (Locoroco - Languge selection) and when I select language it back to Emulation Station.

When I run the same game in RetroPie image everything works fine.