[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC


#1172

i never install retropie before.
I upgrade to osmc kodi 17 from osmc kodi december versión (kodi 16)
i run the sh and select basic install.

I receive this error during the instalation:

[ 21%] Building CXX object es-core/CMakeFiles/es-core.dir/src/components/DateTimeComponent.cpp.o
c++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.9/README.Bugs> for instructions.
es-core/CMakeFiles/es-core.dir/build.make:537: recipe for target ‘es-core/CMakeFiles/es-core.dir/src/components/ComponentList.cpp.o’ failed
make[2]: *** [es-core/CMakeFiles/es-core.dir/src/components/ComponentList.cpp.o] Error 4
make[2]: *** Waiting for unfinished jobs…
CMakeFiles/Makefile2:194: recipe for target ‘es-core/CMakeFiles/es-core.dir/all’ failed
make[1]: *** [es-core/CMakeFiles/es-core.dir/all] Error 2
Makefile:137: recipe for target ‘all’ failed
make: *** [all] Error 2
Removing additional swap
/home/osmc/RetroPie-Setup
Could not successfully build EmulationStation - Frontend used by RetroPie for launching emulators (/home/osmc/RetroPie-Setup/tmp/build/emulationstation/emulationstation not found).

in the blue screen i received this error:
"could not successfully build emulationstation - frontend used by retropie for launching emulators (/home/osmc/retropie-setup/tmp/build/emulationstation/emulationstation not foud)

and then continue and finish the install
when i launch with (/home/osmc/RetroPie/scripts/retropie.sh) i received this error:
openvt: exec: Permisión denied


#1173

This seems to be an out of memory error.
Please shut down the mediacenter before installing and try again.

Is this a pi1?


#1174

Ok, i will try un a few hours.
Is a pi2.
Wich is the comand to shut down the mediacenter?

Thanks a lot


#1175

Run "sudo systemctl stop mediacenter"
Before starting the install-retrosmc.sh script.


#1176

perfect. WORK NOW!!
thanks a lot.

i try snes games and Works fine. in mame the controller not respon and i dont know why :frowning:


#1177

You might have to select a libretro mame version or configure the controller by hand.
See the retropie documentation for reference.


#1178

Hi,

It all was working fine on v16, and after upgrading osmc and kodi to v17 Retropie starts fine but when I exit it doesn’t return to OSMC menu.
My workaround is to run a command sudo service mediacenter restart.

What is the problem? Anyone has suffer the same issue


#1179

I’ve not encountered this issue for myself. What happens when you select quit in Retropie?


#1180

Black screen, forever.

Ssh works fine though


#1181

It works fine for me.
How old is your retropie installation?


#1182

Like 8 months?
Yesterday night I was testing. The menu itself of going out of retropie is not working I tried to restart the pi from the menu and it didn’t worked either. The uptime is still a few days and the screen goes to black.
So… I checked the logs… dmesg shows nothing, kodi logs nothing.
Reinstalling is the solution?


#1183

Before reinstalling use the update scripts functionality of the install-retrosmc.sh script and try again.

If that doesn’t help, try to update the retropie installation itself by running the installation again and select Update RetropieSetup scripts from the retropie-setup menu.

If all of that fails, there might be no other way than to reinstall.

There should also be a emulationstation log in a hidden .emulationstation folder in ~.

You could have a look there.

This could also happen if the retropie-watchdog script is not started correctly.

I think I need some error handling here.

Also I am in the process of revamping my scripts and the launcher addon.
Will take a while though.


#1184

After updating OSMC to v17 Retropie itself starts, but games do not start anymore.
Should I apply an update to Retropie?


#1185

You can try. But I don’t know why that should happen at all.


#1186

Is this still working?

I can’t seem to install it. I’ve tried both on my Pi 2 and Pi 1, no luck.

Sometimes the installation won’t succeed, and sometimes it does, but even then RetroPie won’t start: I get openvt: exec: no such file or directory if I try to run it from within OSMC.

Any ideas?

P.S. I run it from a custom menuitem with the following command: System.Exec(/home/osmc/RetroPie/scripts/retropie.sh).


#1187

Can you just type openvt into a termknal to see if it is installed please? Is this a new osmc installation?

Edit: Can you try starting the script from ssh? Does that work? Also please try the addon.


#1188

Hey, sorry for the delay.

As for openvt: I’ll check that this evening when I get home. Shouldn’t Retrosmc pull it as a dependency, though? Since it’s clearly not part of OSMC, because I would have it then. (Or maybe Retrosmc tries to install it, but fails somehow, during the installation).

As for starting /home/osmc/RetroPie/scripts/retropie.sh directly from ssh: I tried that then and also had no luck, but it was giving me a different error. I don’t remember what exactly, wish I had wrote it down. Will try that this evening, too, and get back to you.

Yes, it’s a fresh 2017.02-2 OSMC installation. And like I mentioned before - it’s the same whether I try it on my Pi 1 or my Pi 2 (and tried it multiple times).

If it helps, I could record a short video demonstrating the whole process, so you can see for yourself and maybe spot something that I’m not seeing/something I’m doing wrong.

I’m desperate to get it to work - switching cards between my OSMC and RetroPie is kind of a pain :).


#1189

I don’t have a lot of other reports that it doesn’t work right now and it also works for me, so maybe something specific to your installation.

Can you also please try to start it from the addon?


#1190

i cannot start retropie because there is no launcher in programs even after installed the launcher within ssh menu of retropie installtion i did a fresh installation of the latest osmc 17.2 then intsalled retropie but cannot start the emulator


#1191

You have to activate the addon in kodis addon settings.