[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC


Do you use a different shell than bash?

That sudo and service are not found doesn’t seem to be a good thing.

Did you try to just type “emulationstation” without quotemarks in ssh?

If that doesn’t work, there should be more output.


Sorry, can’t answer your question about what shell I’m using. But I’m using a regular OSMC installation on RPi3, no custom installations or such.

This is what i get when trying emulationstation in SSH:

osmc@osmc:~$ sudo systemctl stop mediacenter
osmc@osmc:~$ emulationstation
pure virtual method called
terminate called without an active exception
/usr/bin/emulationstation: line 13:  3962 Aborted                 $es_bin "$@"


I really don’t get why this should happen.

Try to reinstall retrosmc.


I’ve tried that like 10 times already haha. I will try and whipe my SD card and do it from a clean slate, wish me luck! If that doesn’t work I give up. :confused:

Even though unable to resolve this, thanks for your help and effort!

Cheers! :slight_smile:


I was just wondering if it was possible to add a Splashscreen for when exiting RetroPie and booting back into OSMC/Kodi?


This is not booting. It is just quitting the one and starting the other.

I actually had an animated splashscreen but I removed it as it could interfere with the switching process and a lot of people had problems with it.

If you find a stable way that doesn’t slow down the transition feel free to submit a pull request.


@djisou and @mcobit, I had the same problem of “pure virtual method called” after updating everything (including cores). My system was running perfectly beforehand, and I reinstalled several times and it did not work. I though that the problem is in the binary of emulationstation and I tried to install it from source (with the retropie setup script), but it fails the compilation. I build emulationstation by myself (takes a while) and put the generated binary into /opt/retropie/supplementary/emulationstation/emulationstation and now Retropie launch. Nevertheless, the controllers are not working within the games but only in Retropie. I don’t know how to solve this problem, but at leas the system is working now. Myabe you could find a solution…


Need to check.
When did you update and do others have these problems?


I finally solve it: I compiled in my first try emulationstation for the old repository. I compiled the fork from Retropie by my own and copied it to the folder that I mentioned in my previous folder. With that, there is no other complain and it works as before. I think that this is an issue in Retropie and should be reported there.

Just for your information: I updated yesterday both OSMC (to the January releasy) and the Retropie cores.


My first attempt at installing seems to go well but when I attempt to launch retropie from osmc it hangs for a few seconds and then reboots my pi. Trying second attempt now.
I’m using a brand new rpi3 model b with a clean install of latest osmc and then following these instructions. Haven’t added any roms or anything else.
Wouldn’t it be possible to have an image of a working retrosmc setup available?


Did anything change in RetroPie that would cause such behaviour?


Could be gcc binary ABI compatibility issue between Raspbian and Debian Jessie (armv6 vs armv7 userland). I will test. If it’s what I think, i will have to disable some packages from a binary install on OSMC and have them install from source…


I can confirm it and it is the problem I thought. While I do some work to exclude certain packages from a binary install you will need to install ES from source (builds/runs fine for me on OSMC on rpi3). Other packages affected are ppsspp, lr-ppsspp, zdoom and lr-dinothawr.

Raspbian has an armv6 userland and when building threaded C++ applications for armv7, there is a problem - https://github.com/raspberrypi/firmware/issues/491 / https://gcc.gnu.org/bugzilla/show_bug.cgi?id=42734#c49

We workaround this, but the workaround makes it incompatible with the ABI on armv7 userland on OSMC Debian. The reason this has just cropped up is because we have some new changes in Emulation Station involving threading.


I see. Unfortunately I cannot do a lot of testing right now as I can’t really use a PC atm.
So the workaround for now would be to compile es from sources from the menu?


I’ve included some code changes now - now binary install will not be available for the mentioned packages and they will instead be installed from source.


I can confirm that with a clean install of OSMC and updated installation-scripts it is working as expected now. Thank you!


i try to install after upgrade to kodi17 and not work for me :frowning:


I have Kodi 17, and addons stable. I am trying to integrate retropie like I had on kodi 16. I tried running this script on kodi 17, and it did not work this time.

Has anyone intergrated kodi 17 and retropie yet?


What eyactly is the problem?
I have updated and it still works.
The launcher is in program addons and I can start it from there.


Did you do an update or a clean reinstall of osmc?
Nothing should change when you update.
Is there any error?
What exaclty doesn’t work?
Did you update the retropie scripts? Did you update the installerscript?