[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC


I have uninstall the new version by script and removed retrosmc inside opt manually.
I’m launching a new fresh install now with the script. Let see in few minutes.

Job is done. It was probably a conflict! Thanks for your support.

Quick question, is there a way to directly call all your update scripts from another house keeping and update script I have?
Like updating with last version and after all them?

It will be great.


Sorry. Not sure I understand your question.


Just looking for a way to launch an update without any human steps :slight_smile:


This will not be possible as this is not a functionality built into the retropie-setup script.
If you want to have automatic updates, ask the retropie guys.


But is there anything from your script I can use with cron?


And I would advise against it anyway. Updating retropie should always be a manual operation.
There is no real need to update if it works for you. So only update manually if you need new functionality.


Cant get SNES to work, tried changing the emulator. None of the emulators that begin with lr- work. armsnes, snes9x-next etc dont work. pisnes also doesnt work. Snes9x is the only one that launches, but the controller doesnt work with that.


You might have a problem with the romfile you are using.
Try a different one (from other source).

If the controller doesn’t work with non-retroarch emus, set it up yourself. Refer to the retropie documentation.


tried different games, weirdly doesnt work, just goes to the screen where it says i can click a button to change config, after that it goes back to my list of games. Where can i configurate the controls for non-retroarch emus?


As said, do not try different games. Try different roms for the same games!

For the rest refer to the retropie documentation.


Hi mcobit,

Really looking forward to giving this a go.

I’m currently getting the below output after running the wget command outlined at the beginning of the steps. Do you think this could be from github mirrors being flakey? I have made sure my system clocks are sysnced and on the right time zone. Any help greatly appreciated!

Connecting to raw.githubusercontent.com (raw.githubusercontent.com)||:443… connected.
GnuTLS: A TLS fatal alert has been received.
GnuTLS: received alert [0]: Close notify
Unable to establish SSL connection.




Yeah. Probably. Others had those problems, too. Just search this thread.
Problem is that later in my scripts they rely on a connection to github.
So better to sort those errors out first before going further.


Hi. This is great and installation was seamless. I seem to be having trouble with launching it through Kodi though.

Running OSMC on an Raspberry Pi 2, with the Amber skin.

RetroPie doesn’t appear in my Program Addons so figured I’d have to create a menu item and use System.Exec, but couldn’t get it working. (I’ve never done custom menu items before)

If I SSH to the pi, and run retropie.sh, it launches fine, so the script is good. I tried creating a new shell script with “System.Exec(/home/osmc/RetroPie/scripts/retropie.sh)” and called it through File Manager, nothing.

After some searching I saw there may be issues with using System.Exec so I tried a Python script that has the following;

#!/usr/bin/env python
import os
os.system ('/home/osmc/RetroPie/scripts/retropie.sh')

This works fine through File Manager (yay) but when I add the python script as a favourite and try to launch it from there, nothing (boo).

I’ve looked through existing posts but haven’t seen anyone having similar issues. Am I missing something obvious?


I got it running in the Amber skin, this is the entry in the settings.xml


Did you installed the launcher first?

If you have installed the Launcher Addon, you will find your shortcut in the Programaddons in kodi.


Thanks Theetjuh. I tried this, but whenever I reload the skin the setting vanishes from the xml file.

Got it in the end! Ended up stopping Kodi, editing the settings.xml then starting Kodi again. I figured the Amber settings were being re-written on reload/exit.

raspdealer, no, I don’t have Launcher Addon installed. When I read it I assumed it was the Add-Ons menu on the home screen, but when I searched for an Addone called “Launcher Addon” I didn’t find anything, though I didn’t search very hard


Yeah stopping Kodi is mandatory :slight_smile:



I have been on a considerable journey in attempting to build a system incorperating RetroPie into my build of OSMC and getting various bluetooth PS3 controllers to work with it.

After much much frustration I have managed to finally get my SZMY Power controller ( a PS3 immitation controller) to pair with RetroPie,in order for this to work I basically need to manually via SSH reset and activate the Sixad Daemon in order to overide OSMC’s own bluetooth stack.If I do this I can get the controller to pair everytime without a problem.However it is obviously rather annoying that everytime I want to launch into RetroPie to play a game that I would have to manually reset the Sixad Daemon via SSH.

Can anyone possibly point me in the right direction of making this an automated process via a script so that when Emulation Starts the Sixad Daemon is automatically restarted?And even possibly made inactive again when quitting out of RetroPie back into OSMC in order to restore OSMC’s bluetooth stack.

Any help with this would be greatly appreciated as it means after many many months I might actually be able to play some games rather than mucking around trying to get bluetooth controllers to work!


I’d edit the /home/osmc/Retropie/scripts/retropie_watchdog.sh

and put the commands needed to start Sixad, before sleep 8.

And if you know how to, stop Sixad and reload the original bluetotth stack after “# restart kodi” and the sudo line close after it.



Firstly thanks for the pointer.

I’ve never really delved too deeply into scripting,so could maybe do with a little guidance.

The command to restart sixad is:

sudo /etc/init.d/sixad restart

I can see in /home/osmc/Retropie/scripts/retropie_watchdog.sh that the ‘sleep 8’ is on line 25,I’m just not sure how exactly to ‘wrap’ the actual code.