[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC


In this case the retropie serup script was not run. So nothing was installed.
You can scroll up on the last screen to see any errors.


No clue. You should ask at the retropie forums or read the mupen documentation.


I restarted the whole procedure and this time it worked. Emustation starts but i can not play any games. the logo of the emulators are not shown in the main menu I just see “retropi”


You need roms. The systems will not show up if no roms are present.
This was discussed a lot of times here.


Sorry you are right :slight_smile: thanks for your work so far!


Hi @mcobit !
Thanks for this. I have installed it a year ago and it works like a charm (except few sound issues and some ROM which doesn’t start)

How can I launch an update of the Retropie Core?


Start my script again, then use the update scripts functionality.
Start the retropie installation and update the retropie-setup script from the menu. Then choose update all installed packages from the package manager in the retropie-setup script.


Done. Now it makes my pi crashes. I will check logs.

EDIT: I had to reinstall but it seems ok now. Thanks


Hi again @mcobit

So now, after update I can’t play games. More games be launched which were crashing before but others doesnt work properly anymore.

Interface is working fine, games can be launched but the remote seems to not be recognized anymore.

And Start + Select is not exiting the game anymore too, so I have to reboot everytime to quit a non working game.

Any ideas?


No clue. It is working great for me.
With remote you mean gamepad?


yes. I can use it in the menu and it works fine.
But as soon as the game is launched, nothing!


Try to reconfigure it using the builtin tool in es.
Else try to delete the autoconfig file for your controller and reconfigure then.

Do all emulators have this problem or only retroarch?


I have trying to redefine settings with the interface, still the same.
I also removed es_input.cfg file and after a reboot, a prompt request to add the controller.
Still not working in a game.

I have only snes emulators so I can’t tell.


So try to remove the retroarch config for your controller.


Can you please tell me where is it located?

Is it normal to have retropie AND retrosmc inside /opt?



You have both in opt if you installed a really old version before.


It redirects me to /opt/retropie/configs/all/retroarch/autoconfig which is empty.

Yes may be I have an old version and there is now a conflict after my reinstall.
Can you tell me how to clean it up completely?


As you don’t seem to have uninstalled the old version before installing the new one, I am not sure if this is possible anymore.

A clean install of osmc might make more sense.


I didn’t had the old sh file, I’ve uninstall with the new one may be doesnt keep backward compatibility?

Is there folder, file, etc to delete if I want to clean everything?
I don’t care if my current RetroPie install is removed too.

A clean install of osmc might make more sense.

I really want to avoid that :S


With the chroot version the uninstall should be as simple as deleting the retrosmc folder in /opt
After that try to install with the new version again.