[HowTo] Moonlight-Embedded (former Limelight) using Luna Launcher


Heya @NullTie,
already received some more input regarding this problem on Luna’s GitHub repo. From what I could gather so far it looks like the config file isn’t created for completely new installations. I’m actually working on this right now and I’ll report back once this is fixed.
Sorry for the inconvenience :frowning:

This should be resolved in Luna 0.4.1-alpha.
If you can launch the add-on you should be able to update using the ‘Check for Updates’ menu item. Otherwise please uninstall and reinstall the new version.

Even though I was able to reproduce the issue and tested the new release (by deleting all of Luna’s data manually and completely reconfiguring it (including the pairing step) using the updated version) it’d be great to know wether this works for you or not.

If you should have any other problems / questions just let me know (and if possible mention me in your post so I get an email notification which makes me reply way faster :slight_smile: )


Hey @exxe,

I downloaded the update and it works perfectly! For the last hour I have been playing The WItcher 3 at 1080p60fps on my pi2 and it has been marvelous. Thanks for your hard work and responding to me!


Hello everyone. I have been trying to get this working for a while but today I tried the Luna addon. I followed the instructions in the OP and paired to a computer but when I go into Luna and select “Games” it only has one item that says “erating certificate… done”. Did I do anything wrong or is there something else I have to setup on the gaming computer end? This is on a fresh OSMC installation on a Rpi2 using Luna 0.5.0. Any help would be appreciated. Thanks!


Now that’s something new … looks like Luna grabbed a part of the pairing process and threw it into the games list instead. I can’t answer exactly why this happened, but here’s a few things you could try:

  • check if moonlight list (run from CLI) returns your games (or at least Steam)
  • go into Luna’s settings > Scraper > Remove Game Cache (this deletes all local game information, including the storage where it saves the objects, essentially forcing Luna to get a fresh list from moonlight)

Please let me know if this helps. I’ll try pairing my machines again later (doing that rarely during development because it’s a pain after you did that about a hundred times already :wink: ) and see if I can reproduce this.

Edit: Tried pairing and getting a game list over and over again for the last 40min or so and no “luck”. Only thing I observed is that TGDB seems to have server issues (or they changed something) as sometimes they’re sending back a status 200 with a malformed XML as payload, containing an error message. I’ll wait for your reply for the time being …


Wow thanks so much. That was simple. I tried deleting the cache before but I guess the command didn’t go through but this time I got the prompt asking if I was sure I wanted to delete it and after that it listed all the games the command line listed! Thanks again for such a fast response!


For some reason it sometimes takes a veeeeery long time until that window appears (same with the game information windows, they’re painfully slow at times) :wink: Yet there’s still other stuff to do so performance improvements aren’t on my top priority list for now. On the other hand, sometimes my TV doesn’t even register my input so I have to press twice.
Anyway, glad this works now and enjoy using it. If you should have any suggestions (apart from it being slow at times :P) just tell me on Luna’s thread in the general section on this forum and I’ll see what I can do.
Happy gaming!


Christ, I spent HOURS thinking something was wrong when I should’ve cleared a cache. Frankly I’m embarrassed.

I signed up just to say thank you for saving me and probably quite a few more people several hours of unnecessary work.


Does host machine have to be Nvidia? Sucks if so, only got Radeons.


Yes, it’s their technology.


damn, wish I’d thought to ask before I installed it all and wondered why it wasn’t working lol. Oh well, I’m sure it works marvelously for all you Nvidia types :cry:


help, can’t get it installed on rpi 2 with osmc

followd guide above as in (copy paste command style)

here’s what i get:

root@osmc:/home/osmc# cat /boot/config.txt

root@osmc:/home/osmc# sudo “dtparam=audio=on” | tee -a /boot/config.txt
usage: sudo -h | -K | -k | -V
usage: sudo -v [-AknS] [-g group] [-h host] [-p prompt] [-u user]
usage: sudo -l [-AknS] [-g group] [-h host] [-p prompt] [-U user] [-u user]
usage: sudo [-AbEHknPS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p
prompt] [-u user] [VAR=value] [-i|-s] []
usage: sudo -e [-AknS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p
prompt] [-u user] file …\

root@osmc:/home/osmc# sudo -s
echo “deb http://archive.itimmer.nl/raspbian/moonlight jessie main” > /etc/apt/sources.list.d/moonlight.list

root@osmc:/home/osmc# sudo apt-get update && sudo apt-get install -y moonlight-embedded\

sudo apt-get update && sudo apt-get install -y moonlight-embedded
Hit http://security.debian.org jessie/updates InRelease
Ign http://archive.itimmer.nl jessie InRelease
Hit http://ftp.debian.org jessie-updates InRelease
Ign http://archive.itimmer.nl jessie Release.gpg
Hit http://archive.itimmer.nl jessie Release
Hit http://apt.osmc.tv jessie InRelease
Hit http://security.debian.org jessie/updates/non-free armhf Packages
Ign http://archive.itimmer.nl jessie/main armhf Packages/DiffIndex
Hit http://security.debian.org jessie/updates/non-free Translation-en
Hit http://security.debian.org jessie/updates/main armhf Packages
Get:1 http://ftp.debian.org jessie-updates/main armhf Packages/DiffIndex [367 B]
Hit http://security.debian.org jessie/updates/contrib armhf Packages
Hit http://security.debian.org jessie/updates/contrib Translation-en
Hit http://ftp.debian.org jessie-updates/contrib armhf Packages
Hit http://ftp.debian.org jessie-updates/non-free armhf Packages
Hit http://security.debian.org jessie/updates/main Translation-en
Hit http://ftp.debian.org jessie-updates/contrib Translation-en
Hit http://ftp.debian.org jessie-updates/non-free Translation-en
Hit http://ftp.debian.org jessie-updates/main Translation-en
Get:2 http://apt.osmc.tv jessie/main armhf Packages/DiffIndex [2023 B]
Ign http://apt.osmc.tv jessie/main Translation-en
Err http://archive.itimmer.nl jessie/maindeb armhf Packages
404 Not Found
Err http://archive.itimmer.nl jessie/http://archive.itimmer.nl/raspbian/moonlight armhf Packages
404 Not Found
Err http://archive.itimmer.nl jessie/jessie armhf Packages
404 Not Found
Err http://archive.itimmer.nl jessie/http://ftp.debian.org/debian armhf Packages
404 Not Found
Get:3 http://archive.itimmer.nl jessie/main armhf Packages [601 B]
Err http://archive.itimmer.nl jessie/contrib armhf Packages
404 Not Found
Err http://archive.itimmer.nl jessie/non-free armhf Packages
404 Not Found
Ign http://archive.itimmer.nl jessie/contrib Translation-en
Ign http://archive.itimmer.nl jessie/http://archive.itimmer.nl/raspbian/moonlight Translation-en
Ign http://archive.itimmer.nl jessie/http://ftp.debian.org/debian Translation-en
Ign http://archive.itimmer.nl jessie/jessie Translation-en
Ign http://archive.itimmer.nl jessie/main Translation-en
Ign http://archive.itimmer.nl jessie/maindeb Translation-en
Ign http://archive.itimmer.nl jessie/non-free Translation-en
Fetched 2390 B in 1s (1534 B/s)
W: Failed to fetch http://archive.itimmer.nl/raspbian/moonlight/dists/jessie/maindeb/binary-armhf/Packages 404 Not Found

W: Failed to fetch http://archive.itimmer.nl/raspbian/moonlight/dists/jessie/http://archive.itimmer.nl/raspbian/moonlight/binary-armhf/Packages 404 Not Found

W: Failed to fetch http://archive.itimmer.nl/raspbian/moonlight/dists/jessie/jessie/binary-armhf/Packages 404 Not Found

W: Failed to fetch http://archive.itimmer.nl/raspbian/moonlight/dists/jessie/http://ftp.debian.org/debian/binary-armhf/Packages 404 Not Found

W: Failed to fetch http://archive.itimmer.nl/raspbian/moonlight/dists/jessie/contrib/binary-armhf/Packages 404 Not Found

W: Failed to fetch http://archive.itimmer.nl/raspbian/moonlight/dists/jessie/non-free/binary-armhf/Packages 404 Not Found

W: Failed to fetch http://archive.itimmer.nl/raspbian/moonlight/dists/jessie/main/binary-armhf/Packages Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.


Got a full list of games a few days ago but it grabbed the last two lines of the pairing texts and threw it into the games list. This is what shows up:

nect to xxx.xxx.xxx.xxx
nlight Embedded 2.1.3 (EMBEDDED;PI)

Selecting a game would start it on the PC but no audio or video. All connections with ANY of my moonlight devices failed during RTSP handshake. I updated a few things to see if it would help. The latest GFE 2.11.x.x cause the connection to fail at the RTSP handshake. I cannot get past RTSP after pairing. Had to roll GFE back to

Once I rolled back to 2.10, I started getting the following in games again and nothing else:

nect to…
nlight Embedded 2.1.3 (EMBEDDED;PI)

Let me know if I can provide any logs or info. Unfortunately we might all be stuck until the new GFE 2.11 issues are all patched up.


The newest version of GFE that’s available for me is I don’t have beta updates enabled, so this might already be the reason why there’s no 2.11.x.x version showing up for me. If you can tell me how you got your hands on that version I’m always happy to give it a try :slight_smile:
I’ll have a look as to why some of those lines get stuck inside your game list. I’m pretty sure this is an issue with Luna itself as the moonlight list command doesn’t include those lines (at least not on my installation and there was no update available when I last checked a few days back). This will probably be the case tomorrow as I’m busy tonight.
Again, sorry for the inconvenience caused and thanks for reporting your issues instead of just giving up! I really appreciate all the input as this gives me the opportunity to make Luna work as good as possible for everyone. If I should need any additional information I’ll contact you and update this post accordingly once I figured out the underlying problem.


Oh dude it’s no problem at all. I’m more than happy to provide data as long as someone is willing to work on it. If I knew how to code, I’d jump in too. Second best thing I can do is to provide some solid documentation and data.

I enabled beta updates for GFE, that’s how I got 2.11.

Shortly after updating, connecting moonlight to the PC stopped working. I’m playing with OSMC for the first time so I didn’t know if I was being a noob and messing up my installs or something. After about 4 hours, I learned it was GFE. What a giant waste. At least we all know the culprit though.

Some of the conversation with one of the devs in a moonlight git confirmed it. https://github.com/moonlight-stream/moonlight-ios/issues/203

It also occurred on my android app, fire TV stick, and iPad so it was not device-specific. Had to be the PC. I reverted back to 2.10 and now all devices work except the Pi. The funny thing is I got the games list when I ran 2.11, but now that it’s back to 2.10 it doesn’t show the games at all anymore.

Edit: This is actually what prompted me to update - when I couldn’t reach the games list while on 2.10.


@exxe I did a fresh install of OSMC, Moonlight and Luna. Thanks again to you and @dodslaser . This is great plugin; everything works perfect with zero lag but I have a black screen problem with Luna:

I tried different resolutions on PC and RPi (with Luna settings) but I can’t get rid of it. A sidebar appeared completely at everytime on the left side of screen. But there is no problem with Steam streaming.

Thanks for your help!


@Merih Have you tried running it without setting a specific resolution in Luna (i.e. not enabling the ‘override moonlight’s default resolution’ setting)? Does it happen with every game or only a few ones?
And are you using a 1920x1080 resolution on both your PC and your TV? Just asking because I’ve had a whole lot of strange issues with games not having their resolution set properly, e.g. Witcher 3 always used the 2560x1080 resolution my main screen is using and I had to set it to 1920x1080 manually in the game options when I streamed it to my TV. If you’re using mismatched resolutions and Steam Big Picture works fine (i.e. no black bars) the above may very well be the case for you as well.

Hope this already helps. Let me know!


Finally, I’ve solved this; Geforce Experience (GFE) is the main problem. I tried older versions and v2.5.15.46 worked well and black bars are gone (The latest GFE Beta version is not running with Moonlight OSMC). Like you said, screen resolutions should be equal on PC and RPi for best experience.

I use Xbox 360 Wireless Gamepad but some buttons (i.e. right trigger) of controller suddenly stopped responding. If you connect a gamepad to your PC, GFE can cause some problems because the emulated Shield controller appears to games as Controller 1 (If you run Xbox360 Gamepad utility, you’ll see 2 controllers).

Here is the solution (32&64bit):

  1. Navigate to C:\Program Files\NVIDIA Corporation\NvStreamSrv
  2. Rename rxinput.dll to rxinput.dll.old
  3. Do it again on X86 folder: Navigate to C:\Program Files (x86)\NVIDIA Corporation\NvStreamSrv
  4. Rename rxinput.dll to rxinput.dll.old

Plug your Xbox 360 controller wireless receiver into your PC. It’ll work flawless now and you don’t need to plug it on RPi.

Also, you should stop GFE auto-update:

  1. Navigate to C:\ProgramData\NVIDIA Corporation\GeForce Experience\Update
  2. Delete setup.exe

That’s all! So I can play my games on my big TV :slight_smile:
Thanks @exxe Keep up the good work!

[HowTo] Luna - yet another moonlight configurator/launcher add-on

Hi, I’m using a RPI2 with OSMC and Luna launcher addon. I’m having trouble with selecting the audio output device.
By default, when I launch something from Luna, the sound is streaming via HDMI to my TV, but I am using a USB soundcard on my raspberry which normally plays audio from Kodi, and I want the audio stream from Moonlight to go through the USB card as well, not my TV speakers.

The output form cat /proc/asound/cards is this:
0 [ALSA ]: bcm2835 - bcm2835 ALSA bcm2835 ALSA 1 [Device ]: USB-Audio - USB PnP Sound Device USB PnP Sound Device at usb-3f980000.usb-1.4, full speed

I’ve tried locating the moonlight-embedded config file but I just can’t seem to find it (I’m a noob at linux). My guess is if I edit the moonlight config file, anything that Luna lauches will play audio on whatever device is set in the conf file.

Also, when I try to start moonlight via SSH with the -audio “1” paramater it gives me:

Starting audio stream...ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM 1


Heya @Trondomer,
moonlight-embedded’s config file is usually located at either ./usr/etc/moonlight.conf or ./usr/local/etc/moonlight.conf. Additionally the config file generated by Luna and passed to moonlight is located at /home/osmc/.kodi/userdata/addon_data/script.luna/.storage/luna.conf. Using the ‘audio’ parameter in either of these files should probably do the same thing (though I’m not completely sure about the moonlight.conf files, you should have only one of them and the fact that I got two is just due to the fact that I didn’t properly clean up the self-compiled version of moonlight). However specifying it in the config files does the same thing as calling moonlight -audio <device> , so you should make sure it’s working properly when starting moonlight from terminal.
As of right now I can’t give you any more assistance on how to use the -audio parameter because I don’t own a USB audio device so you’d need to figure that out by yourself, wait for someone else who managed to get it working or wait for me to find someone who’s willing to borrow me their soundcard. Either way I’d be glad if you could share your findings in this thread - that way I can look into a way of selecting the audio device to be used for moonlight right in Luna’s settings (which would be a cool feature to have for some people, especially if they’re using a surround setup and a good AV receiver).


Hey, thanks for your swift reply!

Someone over at github offered a solution. LINK

Using -audio hw:1,0 makes the audio go through my USB soundcard while hw:0,0 seems to be the default audio device over HDMI. Adding audio = hw:1,0 to luna.conf works, i.e. anything luna launches has audio on the selected device.
I’m curious, can someone explain what does hw:1,0 stand for? I’m guessing 1 points to 1 [Device ]: USB-Audio, but what about the zero after the comma?

Btw. if you cant find someone to borrow you a USB soundcard you can get them on ebay for dirt cheap. And I do mean dirt cheap, I got mine for $2. The sound is nothing to brag about but it doesnt produce the annoying noise that the audio jack on the RPI does.