[HowTo] Luna - yet another moonlight configurator/launcher add-on


Yes that’s the bug I’m having.
meanwhile I’m back at 0.6.3 and moonlight refuses to play the stream…
always getting Waiting for IDR frame.
This has nothing to do with luna. Starting moonlight from the command line ends up the same(streams starts on host, osmc on black screen)

I’ll be glad to test and give feedback on the pre-release versions! You got nothing to apologise, these are just normal bumps on an app lifecycle!
I’m glad to help!


I’ve seen that on the other thread. Sadly there’s nothing more I can tell you about this, except that I’m using GFE currently and that’s working fine so far (except GFE not reporting some games that are listed it’s main menu). I’m a bit reluctant when it comes to updating GFE and the drivers (e.g. the latest driver is known to cause flickering in Paragon, and I really can’t have that), so I can’t tell you if it’s the version per se.

You could try downgrading and see if this resolves the issue. Or completely wiping the drivers using DDU in Windows’ safe mode and do a clean reinstall. Admittedly, it’s a shot in the dark, but it does help sometimes and it can’t really make things worse.


Looks like it’s a geforce update that’s causing it.
It’s already patched on moonlight so I’ll just have to wait for a release from embedded:


RC2 should make things usable again.

I didn’t specifically have a look at the zeroconf / IP input at this time, as the two other issues have been more pressing. Yet I’m still under the impression that you shouldn’t have to deal with the IP input field if zeroconf is installed, but we might need to debug that on your end (I had to test the entire process from installation to pairing to listing games for two machines for RC2 and zeroconf worked both times :confused: )

Again, thanks for your valuable feedback!


Hi, first of all, thanks a lot for your work, its amazing this addon. I have everything running smooth (I can play with keyb + mouse), I only have problem with my gamepads “rumblepad wireless 2”.

It is detected, through Steam I can navigate and lauch game without problem, but when game is launched, all goes wrong, buttons, pad…

I try calibrate at luna settings, it is detected as Rumblepad, but when I go to map buttons, it dont detect when I press buttons or pad :frowning:

I have this gamepad fine calibrated and configurated on the other addon called Retrosmc… and I can play with it at mame.

Can I copy my emulestation configuration (I think is called .map on linux) to luna? I didnt see .map created at emulestation, only .cfg

Maybe is there other way to map my gamepad?

Thanks in advance and sorry my english :frowning:


Just tested RC2 and it’s working fine on estuary and osmc skin.
The one thing that remains is zeroconf. I always end up having the IP input field show up on both skins.
seems to be a zeroconf problem… But not a big deal since the rest is working OK.

Thanks exxe


Might be the same issue I was having with newer GFE versions and the current zeroconf release: click
When I install 0.17.7-dev it’s working fine for my desktop (which is at 3.1.x), 0.17.6. is always only picking up my notebook (2.11.x) :confused: That might be something you could try as well.

You’re welcome :slight_smile:


Hello, i try to connect my dualshock 4 controller, it works… kinda. The buttons are all wrong. I tried using the ds4 mapping someone posted on github, doesnt help. Left is down, right is up etc. Triggers dont work. A=X etc. Can someone help?


I have also a question regarding controllers…
I have no controllers attatched to my Pi (Client). I control the games on my Windows-machine (Host) with keyboard+mouse and the Pi displays all on a big screen for others to view.
I control Osmc on my Pi with the TV-remote with CEC. So i navigate to Luna-Addon and start the stream+the game. But how can I exit the stream? The moonlight-embedded command “Ctrl+Alt+Shift+Q” doesn’t work on the host-machine. And I can’t use it at my Pi, because no keyboard is attatched.
The only “soultion” I found is logging in with SSH to my Pi and reboot. Also the Windows-machine needs a reboot or relogin to fully stop everything.
Is there a way to use my TV-remote to exit/end the stream?