[HowTo] Luna - yet another moonlight configurator/launcher add-on


Thanks for letting me know, I appreciate the help. Will that command have any adverse effects if I already ran it?




This sounds like moonlight-embedded isn’t launching properly / crashing right after initiating the screen. Just as a side note: Even when the game shows on your TV, it will still be visible on your computer screen.

Try shutting down Kodi and launching moonlight-embedded from command line to see its output in your terminal window. This should give you or us an idea of what’s wrong. If you need detailed instructions simply tell me and I’ll provide them.


Thanks exxe for the advice, I’ll try launching Moonlight from the command line tonight after work. I’ll let you know what output I receive.


Alright, so I exited the OSMC Kodi interface and rebooted directly to the command line. I was able to use: moonlight stream xxx.xxx.x.x to successfully start streaming and bring up Steam’s big picture mode. It would appear that moonlight is installed and working, so perhaps there is a problem with the Luna launcher from within Kodi.

As a side note, most of my games would not actually start from Steam and Steam assumed I was using a controller rather than a keyboard and mouse. however, I think that is probable a Steam rather than Moonlight issue.


That’s probably an issue with the config file Luna is using to start moonlight. To confirm, try launching moonlight from command line again, but make it load the same config file:
moonlight -config /home/osmc/.kodi/userdata/addon_data/script.luna/.storage/luna.conf

There’s only two possibilities:

  • if it’s working using the same config file Luna uses, there’s indeed an issue with starting moonlight and we’ll have to have a look at the Kodi logs
  • if it isn’t working you’ll need to play with the settings a bit :wink: You’ll probably also get an error as to why moonlight isn’t starting properly

Did Steam present you with an error message when you tried starting a game or did it simply refuse to do anything?


I tried starting moonlight with the Luna configuration file and received the following error:

osmc@MediaPi:~$ moonlight -config /home/osmc/.kodi/userdata/addon_data/script.luna/.storage/luna.conf xxx.xxx.x.x (I used my IP address :wink: )
Moonlight Embedded 2.2.2 (EMBEDDED;PI)
Connect to xxx.xxx.x.x…
NVIDIA GeForce GTX 750 Ti, GFE (protocol version 7)
xxx.xxx.x.x is not a valid action
osmc@MediaPi:~$ moonlight stream -config /home/osmc/.kodi/userdata/addon_data/script.luna/.storage/luna.conf
Moonlight Embedded 2.2.2 (EMBEDDED;PI)
Too many options: Success

It looks like the Luna config file is the culprit, I’ll start playing around with the config settings to see if anything helps.

As for steam, there weren’t any errors, it looked like it was trying to start the game, but just wouldn’t do it. I’ll see if the problem is present only when streaming, or if I can replicate the issue using the big picture mode on my pc. Also, some games seem completely unaffected, I was able to stream Skyrim (Although it did not recognize the keyboard). Perhaps that is part of the problem, Steam treats the keyboard like a virtual controller and refuses to launch games that lack controller support? idk, just shooting in the dark here.


After playing around, I think the config file generated by Luna for Moonlight is not in the proper format. I played around with the settings and was able to re-save the file and start moonlight using the config file from the command line. However, when I tried starting moonlight through Luna, it failed and I received the same error. i’m not sure how to set up Luna so that it will write the config file correctly.


Apologies for not getting back to you earlier, this somewhat slipped my mind between work and some private stuff on my plate. I’m really sorry :frowning:
When resaving the file, did you change any of the settings which might have caused moonlight to start properly or do you suspect the file to have “unparsable” contents (e.g. wrong line endings, …)? If the latter is the case, would you please send me both files (the failing and a working one; not just the contents, simply upload it somewhere) so I can have a look at it? Hopefully this is no biggy, but I’m sure we’ll be able to figure this out. (And if I forget the reply again, just ping me via a PN - some of the stuff posted on this forum or over at GitHub just gets lost in my daily flood of emails and GH notifications. While I do know that this is no excuse, I hope this somewhat explains part of the reason why I’m a bit slow to respond at times.)


Thank you exxe so much for your help. It turns out the problem wasn’t with Luna, Moonlight, or the config files at all. The real problem was with my CEC settings! Every time Luna started Moonlight, the CEC settings would switch off my TV. (Perhaps because Luna is closing OSMC) Oops! I feel like a bit of a fool for not looking at those settings earlier, I set them up when I was first setting OSMC and forgot about them. Thank you again for all your help, and don’t worry, Luna is working great now!


I would’ve never expected this to be a possible source of error. I’m glad things are now working for you!
Don’t hesitate to let me know if you run into any additional issues or got any ideas on how to make Luna better :slight_smile:


I’m using luna for quite sometime now and after installing the krypton beta I ran into an issue with the new OSMC skin.

When I try to access the game list it goes to an empty “movies” screen.
Works well with the official estuary skin, but not with osmc new skin.
I complained on their thread and posted some logs and the dev said it might be due to some skin patching from luna.

Can anyone confirm that luna is not working on osmc new skin?
here’s the log if needed:


While Luna can patch the current OSMC skin (read: not the new one), it’s not done automatically - you’d have to manually click the proper buttons to do so. Furthermore, only parts of the home screen are patched. It either wouldn’t change anything on a new skin or mess with your entire home screen or simply work (depending on the changes between the current and the new version of the skin, didn’t have a look at it yet).

Neither outcome would actually influence the game view. So it’s almost certainly not the skin patching, especially if you’ve never used that function anyway :wink:

Can you tell me the exact versions of OSMC and Luna you’re trying to use right now so I can have a look at this on the weekend?


OSMC version is the latest nov release.
I use kodi v17 beta(https://discourse.osmc.tv/t/testing-kodi-17-krypton-beta-builds-for-all-platforms/) with the new osmc skin ( https://discourse.osmc.tv/t/testing-new-osmc-skin-for-krypton/ )


Latest Luna version (0.6.3.) as well or an earlier one? The early 0.6.x versions had some strange issues at times :wink:

While you’re digging into all those beta releases anyway, you could also try using Luna’s current dev branch. It might make matters worse, though, because I don’t even know what’s working or not right now (most of the basic stuff should work however). Would require you to uninstall the addon and manually clear the addon’s path (in ~/.kodi/userdata/addondata/script.luna; there’s also a hidden folder inside called .storage).


It’s the latest 0.6.3
Ill try using the dev version as soon as I’m close to my rpi(ill be away for a few days…)
Thanks for the help


Got back to this problem! sorry for the delay!
so today I installed luna 0.7 rc1 and I can’t even add a new host.
I cleaned up and installed from scratch and I get the following error after the install:
20:02:27 59.410374 T:1260123120 ERROR: Exception in thread Thread-5: Traceback (most recent call last): File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner self.run() File "/usr/lib/python2.7/threading.py", line 763, in run self.__target(*self.__args, **self.__kwargs) File "/home/osmc/.kodi/addons/script.luna/resources/lib/core/updateservice.py", line 56, in check_for_update update_storage.sync() File "/home/osmc/.kodi/addons/script.luna/resources/lib/storageengine/storage.py", line 53, in sync fileobj = open(tempname, 'wb' if self.file_format == 'pickle' else 'w') IOError: [Errno 2] No such file or directory: '/home/osmc/.kodi/userdata/addon_data/script.luna/.storage/update.tmp'

So I manualy created the .storage dir and I passed got to the menu where I tried to add a new host… but nothing happened.
This was the error I got on kodi.log:

20:04:17 169.562500 T:1354019824 NOTICE: [script.luna.controller]: Getting Host Status 20:04:17 169.571930 T:1484780528 NOTICE: [script.luna.controller]: Couldn't load discovery agent 20:04:17 169.580948 T:1354019824 NOTICE: [script.luna.controller]: Getting Host Status ... Done

This works OK on estuary. seems that luna is trying to show a numeric pad to insert a IP address but on osmc skin it doesn’t show :frowning:


Thanks for your extensive feedback! Sadly, I didn’t find the time to test Luna (neither the old, nor the new version) in combination with the new OSMC skin.

I’ve created an issue on GitHub to track the first error (shouldn’t be too hard to resolve).

The second part of the logs you’ve posted aren’t errors. Luna has mDNS support now, but only if the zeroconf package is installed, which needs to be done so using pip. Since I can’t enforce this, using mDNS is entirely optional and done automatically - if zeroconf isn’t installed, the discovery agent can’t be loaded (it fails right on import), which subsequently triggers this log entry as information.

And yes, if the discovery agent can’t be loaded or fails to discover any hosts (there’s a bug on the current version of zeroconf, which caused some problems), the fallback is always an IP input field. That’s a Kodi standard class however, which is supposed to work on every skin.
I’ll try to have a look at this soon and see if this also happens on a new addon which just opens this kind of dialog.

Meanwhile, I’d suggest either installing zeroconf and rely on mDNS to discover your host or pair using another skin and just switch back to the new OSMC skin afterwards.


I have zeroconf installed and the input field seems to be summoned but hidden in the background.

With 0.7 I was able to add the host with estuary but then I ended up having the scraper-chain issue… so 0.7 is a no go for me at this point.

Back to 0.6.3 with estuary :frowning:


Just to be clear about the scraper-chain issue, you’re referring to this one?

I’m sorry the current pre-release version of Luna has been a bad experience for you so far. I’ll try to get rid of the blocking bugs as soon as I can.