[HowTo] Install a vnc server on the Raspberry pi


if i remember correctly /etc/system.d/system


Thanks found it. So i have to replace the following lines below with yours above? Can i comment out the line instead of replacing them. Is the # in front of line for commenting out?


Description=VNC Server
After=network-online.target mediacenter.service


you do as you please, the main part is to get the mediacenter parts out


Cheers @Joakim_Sandstrom works great thanks again for all your work :smiley:



This tutorial, though my reply unrelated to OSMC, gets RetroPie over dispmanx working where other solutions WILL NOT! I’d even attempted the tightvnc installation from the repo, which simply crashes EmulationStation, and RealVNC which does not get the SDL dispmanx working. This was the ONLY solution which worked without affecting game framerates or crashing EmulationStation.

If going for RetroPie, simply delete the lines in reference to mediacenter.service in dispmanx_vnc.service when you create it, and bump up the framerate to 29 and drop the BPP to 16. Perfect!


Nice, and does the 45frames work ? I thought it was crashing with anything above 30…but then again that was with kodi running not retropie :slight_smile:


As a cluster, yes. I have a STe-oil cooled x4 pi cluster that works splendidly up to 60fps w/ 1 TB shared storage.

I have a lot of non-standard configurations. But for the rest of the threads sake, it works up to 29 FPS, as long as you aren’t pushing a heavy overclock or doing mods.

I edited the value to accomidate this above.

For your info, though. :slight_smile:

The furthest I have been able to push a pi with an adafruit certified-rPi 5.25v 2.5a adapter with an ambient temperature of near 68 degrees ferenheit with an aluminam heatsink and Arctic Silver thermal compound with a forced air 120mm Antek fan mounted inside of a display case with a 6x5x5 surface area, was a clock of 1375 mhtz, 500 mhtz RAM clock.

The STe tech oil mod with an XSPC Ion and a bitspower raidator and a push/pull x2 Corsair 120mm fan with a surface area of 10x10x10 inches of oil in an ambient temperate of 68 degrees farenheit will net you a steady 1425 mhtz before you begin the overheat cycle and the yellow lightning bolt warning.

Sorry to be so specific. But in overclocking, there are way too many variables. A few being the cubic surface area of your enclosure, ambient temperatures, and fan speed and efficiency…

There’s countless arguments on the Overclocking forums which variables count. :stuck_out_tongue: I just specify as many as humanly possible.



When I’m trying to enable the service (sudo systemctl enable dispmanx_vncserver.service) I get this error: Failed to execute operation: Bad message

Do you have any ideas to fix it? This question may be a dummy one, sorry for that.

I have a PI Zero.

Thanks in advance!


Is it really worth the hassle and money to get 200 MHz more?


Hi guys, I am having trouble compiling although at one time or another I got the server working! However, now when I try to compile I receive the message

g++ -Wall -std=c++11 -O3 -DHAVE_LIBBCM_HOST -DUSE_EXTERNAL_LIBBCM_HOST -DUSE_VCHIQ_ARM -I/opt/vc/include/ -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/interface/vmcs_host/linux -c main.cpp -o main.o
main.cpp:18:25: fatal error: libconfig.h++: No such file or directory
#include <libconfig.h++>
compilation terminated.
Makefile:26: recipe for target ‘main.o’ failed
make: *** [main.o] Error 1

and that is despite being inside the dispmanx_vnc-master folder and the time of the make request.



Did you install the necessary dependencies?
try: sudo apt-get install libconfig+±dev


As @patrikolausson asked have you installed all dependencies? I just yesterday compiled the vncserver on a fresh install and all worked without an issue when following the steps at the top of this thread 1 by 1.


I just installed “libconfig+±dev” as Patrik mentioned and when I did make again it created “dispmanx_vncserver”. Now! I guess the only things left to do is created and edit the configuration files for run on reboot?


Trying to achieve the run on reboot I get:

sudo systemctl start dispmanx_vncserver.service
Failed to start dispmanx_vncserver.service: Unit mediacenter.service failed to load: No such file or directory.


Did you do the part where it says sudo vi /etc/systemd/system/dispmanx_vncserver.service and bellow ?
Thats where you create this file.


Yes, this is what I have in that file:

Description=VNC Server
After=network-online.target mediacenter.service

ExecStartPre=/sbin/modprobe evdev


Am I missing something?

I am using Raspbian Jessie is that the problem?

Also, /sbin/modprobe evdev is not listed!


You mean you are installing this on Raspbian and not OSMC?
If so why don’t you use the install instructions for Raspbian?
If you are on Raspbian than you obvisouly would not have “mediacenter.service” so remove
After=network-online.target mediacenter.service Requires=mediacenter.service


Tried OSMC but I would need to remove and swap sd cards if I want to use a different operating system! There is a Raspbian version of the setup instructions, where? when I googled “dispmanx_vnc” it lead me here. However, I have installed Kodi under Rasbian so do I need to change/add something to the setup to reference that?



Ah! I was thinking that those instructions wouldn’t allow me to send programs, etc running behind the scenes to vnc viewer, etc that is I chose “dispmanx_vnc”.