How To Raspberrypi with Boblight OSMC (any version)


#1

Make it work Boblight with OSMC any version images
You need to compile binaries boblightd and libraries go;

Uses PuTTY and WinSCP tools por this tutorial.

First you have to be root follow; Ssh root login

apt-get update
and
apt-get upgrade

apt-get install make gcc g++ unzip libtool libboost-dev libusb-1.0-0-dev libudev-dev git libx11-dev libgl1-mesa-dev libxrender-dev libxext-dev portaudio19-dev libavcodec-dev libavformat-dev libswscale-dev libavdevice-dev subversion gawk libx11-dev libgl1-mesa-dev libxrender-dev libxext-dev portaudio19-dev libavcodec-dev libavformat-dev
libswscale-dev libavdevice-dev

After;

cd /
mkdir boblight-sources
cd boblight-sources
svn checkout http://boblight.googlecode.com/svn/trunk/
cd trunk

Prepare to compile binary boblightd;

./configure --without-portaudio --without-x11 --with-ffmpeg
make
make install

Finally obtiend libraries and binary. Link libraries;

ln -s /usr/local/lib/ligboblight.so /lib/libboblight.so
ln -s /lib/libboblight.so /usr/local/lib/ligboblight.so

Create script at initial running daemon boblightd, edit with nano or WinSCP file called boblight.sh in /etc/init.d, named boblight.sh with this code;

#! /bin/sh
### BEGIN INIT INFO
# Provides: blabla
# Required-Start: $syslog
# Required-Stop: $syslog
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: blabla
# Description:
#
### END INIT INFO
/usr/local/bin/boblightd -f

Sure permition file with 0755
After this uodate script at init;

update-rc.d boblight.sh defaults

Reboot you RBpi.
You have found boblightd compiled. work with drivers TLC5940, WS2811 and WS2812 and more.

Install Kodi-boblight, configure … etc.

My video on start; https://youtu.be/Rq8Jvs1pTLw

Best regards. Enjoy!


#2

During the ap-get install command it asks if i would like to continue (Y/n)? i type Y and press enter and it says Abort. What’s up with that?


#3

It’s a copy & paste problem. The command is not properly formatted. If you install the packets in smaller portions it will work fine.


#4

“failed to create symbolic link ‘/usr/local/lib/ligboblight.so’: File exists”

Not sure why I get this error, hopefully not important.

BTW the url is wrong, I downloaded the whole source as zip and unzipped.


#5

Nice tutorial anyhow:) Not sure why this cannot be simply downloaded from repository?


#6

404 error when going to the link

root@osmc:/boblight-sources# svn checkout http://boblight.googlecode.com/svn/trunk/
svn: E160013: Unable to connect to a repository at URL 'http://boblight.googlecode.com/svn/trunk'
svn: E160013: '/svn/trunk' path not found

#7

Same problem here. The link is down.


#8

Did you manage to setup boblight on your RPi?