[HOW-TO] Install Sonarr


#1

[I am using vim but you can use nano as it’s installed by default. So where you see `vim` in a command just transpose it with `nano` if you prefer]

First of all to avoid dependency issues install the following;
sudo apt install libmono-cil-dev

Now add Sonarr’s Repository
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys FDA5DFFC
Then this
echo "deb http://apt.sonarr.tv/ master main" | sudo tee /etc/apt/sources.list.d/sonarr.list

Next update and install
sudo apt update && sudo apt install nzbdrone

Let’s just make sure the permissions are correct on the directory for Sonarr
sudo chown -R osmc:osmc /opt/NzbDrone

Now create the systemd service to start it at boot

sudo vim /etc/systemd/system/sonarr.service

[Unit]
Description=Sonarr Daemon
After=syslog.target network.target

[Service]
User=osmc
Group=osmc

Type=simple
ExecStart=/usr/bin/mono /opt/NzbDrone/NzbDrone.exe --nobrowser
TimeoutStopSec=20
KillMode=process
Restart=on-failure

[Install]
WantedBy=multi-user.target

Save & Exit
Now enable the service
sudo systemctl enable sonarr

Start the service
sudo systemctl start sonarr

Lastly check it’s running
sudo systemctl status sonarr

Now open up a browser from your computer (on the same network) and enter

<IP_ADDRESS>:8989

Where <IP_ADDRESS> is the IP of your OSMC box


#2

This is a great post but unfortunately it does not work with the Vero 4K. The apt-sonarr.tv repo does not have binaries for arm64. Is there a way to still install it?


#3

For Vero 4K you want armv7 – same as Pi2/Pi3


#4

Yip, you have to enable multiarch on dpkg and apt.

(https://wiki.debian.org/Multiarch/HOWTO)

I will try this and let you know. Thanks.


#5

Vero 4K is already using ARMv7 userland.

You shouldn’t need to change anything.


#6

Can you explain this error then?


#7

I managed to sort it by rather adding the following entry to the sonarr.list file.

echo "deb [arch=armhf] http://apt.sonarr.tv/ master main" | sudo tee /etc/apt/sources.list.d/sonarr.list


#8

Both architectures are available (because of kernel).
What you posted isn’t an error per se, but rather just a message that there is no aarch64 repo. This isn’t a show-stopper.


#9

Thanks por the post, it works great!
Still, high CPU usage because of Mono (load average: 6.19)
Is it just me? or a common issue?


#10

It is August 14, 2018, I am running the newest OSMC version (Kodi 17.6) on my Raspberry Pi 3 Model B+ and I managed to install Sonarr by following this tutorial.


#11

It’s a common issue