HDR Slight flickering (Workaround available)


Just tested something I read some posts ago… fixing Kodi to not switch refresh rate, I mean playing my UHD remuxes at 60Hz, makes flickering on HDR movies dissapear.

Seems like the problem is just at 24Hz.

Sam, if can provide logs or some kind of help to debug this, please ask me.


@sam_nazarko: Yes for sure. I checked it using the infoscreen of my TV/Projector and HDFury integral.
I already tried to record the mentioned noise but failed. Hopefully I will have some sparetime on upcoming weekend to give it another try with my DSLR camera.


That’s always been the case. The workaround mentioned in the thread title forces 60hz playback.


Oh well, it was too good to be true, I have this flickering issue too on my LG E6 OLED TV.

It’s really hard to capture but in this scene it’s pretty unbearable: https://www.youtube.com/watch?v=kAlVEVkKeO4

It can be seen around Halle Berry’s head in the light areas and it’s much worse than it seems on youtube.

Here’s also my log, although the issue should be rather clear now: http://paste.osmc.io/hubucekaqo

If you use the aforementioned workaround make sure that the setting “Adjust frequency” under Playback is turned off, else the script won’t have any effect. For now I’m turning this setting off whenever I watch a 4K movie and turn it back on afterwards. Unfortunately I didn’t find a way to change this particular setting via the Kodi callback addon. Maybe it could be introduced as a special option until a real solution is found.

It’s really just a workaround and I hope @sam_nazarko is still on it. I would consider going for the Apple 4K but that doesn’t have a chance of getting packed 3D playback at any point so I’m hoping for the continued strong software support for OSMC.


@sid6581 Script works fine with adjust frequency, you might have to increase the sleep depending on other settings (I have it at 7)


I sent @Martorias a test build yesterday. Nothing solid yet unfortunately but I’m continuing to work on this. A second pair of eyes is always helpful.

We tested the 4K New York clip and it was fine, but some others aren’t.



Thanks, it started to work as soon as I restarted the Vero 4K :slight_smile:


@Martorias How’s the test build working for you? Just eagerly awaiting a fix…


He hasn’t noticed any improvements yet, but I have more data points


Yeah what Sam said :slight_smile:


Hi to all

I also had a problem of flickering picture in HDR movies but today I turn on two settings in my Philips POS 9002 oled TV and flickering dissapears.
This two options are:

  1. Noise reduction - Maximum
  2. MPEG distortion reduction - Maximum

I have other problem… In some movies there is weird colour disortion. Mostly in blue, green areas but I don’t know how to describe it correctly. I attach 2 photos of Blade Runner.

Any ideas what the problem is?

Best regards


The colour issue seems to be misconfigured dithering I believe.


Hi Sam
Thx for answer but I don’t understand what should I do to make it better?
Best regards


This shouldn’t be necessary at all. These settings smoothen the picture so that noise and mpeg artifacts are removed but with a hefty cost to sharpness and clarity. Maybe this is also the cause for that distortions? I would turn them off and either try the workaround mentioned here or wait for Sam to fix the issue.


You have right but…When I turn off this option flickering ib bad and picture quality (colour disortion) it’s much worst then when it’s on.
Best regards


The more I read in this forum the more it becomes obvious that buying the Vero 4K was a bad mistake.

Enabling noise reduction as workaround for „proper“ picture quality?

Playbakck with non native refresh rates to get rid of flickering?

From the enthusiasts point of view two dealbreakers. I am very disappointed.

How can I send back the Vero?


Do you even have this issue? Afaik it only happens for owners of some OLED TVs (including mine ubfortunately).


I have the same issues without an OLED TV, just a Philips 50PUS6262/12.


Got my Vero 4k last week. Very nice bit of kit, except for this flickering and banding (looks similar to @lukcinek 's screenshots but hard to be sure) at 2160p 24Hz.

For reference I am connecting to an LG OLED B6 through a Denon X3300W. My main test clip is one I have ripped myself from my own 4k Bluray - the opening studio logos on Guardians of the Galaxy 2. The bright red “Marvel” logo shows both issues perfectly.

I can make the flicking go away (as others have reported) by switching the GUI to 2160 / 60Hz and disabling refresh rate switching (which if my understanding is correct is actually refresh rate AND resolution switching - might be worth making that clear in the hint text). Interestingly I still get bitstreamed audio so long as I don’t enable sync playback to display. So far I haven’t noticed any audio sync issues, although if I get too carried away seeking, the audio stops working until a stop / restart. In the real world rather than testing though this is unlikely to be an issue I think.

And I can make the banding go away by switching output from the Vero to 4:4:4 by modifying /sys/class/display/mode. (echo “2160p60hz444”>/sys/class/display/mode). I know it shouldn’t work and is outside of HDMI spec, but it does seem to work and removes the banding…

With these two changes, the Vero output appears near as damnit identical to playing the original disc on my Samsung UBD K8500, although the OCD part of me knows it is 60Hz rather than 24Hz :astonished:

Whilst testing on the K8500, I noticed it only has four options for chroma sampling - 444, RGB Full, RGB Limited, and Auto (the default). It makes me wonder if “Auto” is defaulting to 444 (within HDMI spec for 24p, which I also have enabled on the K8500). Unfortunately it’s hard to tell for sure as neither my Denon nor LG give that level of detail on what is being input. If that is correct though, maybe the B6 (or the X3300W) don’t like receiving 4:2:0 or 4:2:2? Seems unlikely but…

Not sure if any of this helps anyone but thought I’d share, just in case. @sam_nazarko I’m happy to be a guinea pig for any potential improvements you have in mind. Or if you’d like to see the test clip I use just let me know.

Sorry for the massive post!

Cheers all,


When I tried echo “2160p60hz444”>/sys/class/display/mode on my Vero 4k and Philips POS 9002 Oled Tv there was only blue screen.
Best regards