HDR Slight flickering (Workaround available)


#122

This problem can be replicated on an LG OLED B6 and the 49UJ630V. I recently purchased the latter as a user suggested the problem was exclusive to OLED sets, but it definitely doesn’t seem to be at all.


#123

Maybe two separate issues then? I can’t think of any other explanation as to why you’ve resolved the issue on the LED screen you have yet the problem remains on peoples Oled’s. For the purposes of clarity, I have an LGE6 which showed the issue rather than a B6. The Sony A1’s are also confirmed by users on here as having same problem. (Flickering in bright areas on hdr which persists when paused and disappears when 60hz is forced)


#124

Running at 50/60hz is not a fix for a 24fps film though, however temporary. Yes, it’s a workaround, but not really an acceptable one.

For what it’s worth, the flickering is worse in the latest release than in the previous one. At least on my LG B6 OLED.

Thanks

-Mat


#125

I think it’s more likely that some panels show the problem more clearly or have a lower degree of tolerance, which makes it more prominent.

Sam


#126

See my earlier post though. Since the January update, more media files show flickering, and in fact the gui now flickers when it previously didn’t. This is (as you know Sam) on a 24hz refresh rate

Thanks

-Mat


#127

Does anyone else find the same? Was it only after the last update that this started?

Sam


#128

I honestly can’t tell the difference when running 24hz and 60hz using a 24fps video. I’m guessing the TV goes to 120hz mode and runs all frames 5 times to even it out. I do have some minor tru-motion setting so perhaps that’s what “fixing” it for me.

The only times I’ve seen flicker in the menus is when I’ve been messing with stuff and it’s stuck at 10bit 24hz for some reason.

@sam_nazarko I’ll test when I get home today if I can get flicker in the menus by forcing 24hz or other settings to see what it is. I’m thinking it’s the incompatability of 24hz 10bit 4:2:0 (which isn’t working on the LG, only 4:4:4 for <30hz and the lg won’t do HDR at 4:4:4)


#129

It’s only on menus with large expanses of the same colour - so not much on screen. I use confluence skin.

I certainly don’t remember seeing flilckering with any kind of menus before this release. I only used to get it then when trying 4k HDR media

I don’t know of a way of telling the bit depth I’m afraid.


#130

Ok I’m using Estuary so perhaps it’s not as noticable or something, I’ll have to check. Are you using 24hz in the menus though?


#131

I am because most of the media I watch is 24hz so then I don’t have to wait for the tv to change it’s display rate. It’s the little things… :slight_smile:


#132

That would certainly be a new development because I only saw flickering in HDR modes. I didn’t run the menus at 24hz but I didn’t see any flickering in SDR content irrespective of framerate so would have been surprised if this issue appeared in the GUI. I still genuinely think this is an oled rather than LG issue though with the caveat that LG make the panels for Philips, Panasonic, Sony etc… what I mean is the issue appears in Sony’s Oled sets but not their lcd ones. It appears in a range of LG Oled’s and up until Sam’s post above, my understanding was that the rest of their range was unaffected. My gut reaction upon seeing the fault was that it was unlikely to be a software issue however I’m not informed enough to be certain of this. It did present as something which might be caused by a dodgy cable or hdmi incompatibility but that doesn’t seem to be the case either. Hopefully a fix can be found soon.


#133

No, it is not an OLED thing because as I already wrote before the flickering also appears on my Sony Beamer VW760 which is LCOS based.


#134

Just checked, 24hz (1080p or 2160p) gives flickering in menu. At 24hz it’s sending 8bit 4:4:4 and at 60hz it’s 8bit 4:2:0.

Edit: actually noticed I never get anything above 8bit at all now. I tried both 2160p hdr stuff and 1080p 10bit sources. The line from rc.local was gone and after echoing it I get the right stuff. Flickering seems to be the same though. I’m running 2160p60 permanently for now.

Edit2: running a 1080p24 movie in 2160p24hz doesn’t seem to flicker… I’m confused by all this :slight_smile:


#135

Could this explain why I have what seems color issues on 10bits streams ?


#136

How do I run 2160p@60hz? Only 2160p@24hz is available from KODI.


#137

I thought I read somewhere that the 444,10bit in rc.local wasn’t needed anymore but seems it’s needed for me atleast.

@acidduck if I select 3840x2160p in the system settings I can chose up to 60hz in the refresh rate setting below. Can’t you? Make sure you boot the device with your TV/receiver powered on so it gets the correct available resolutions


#138

No, I can only choose between 23.98hz and 24hz. :thinking:
Vero4K is connected directly to my TV, which is an LG OLED65B6V.

Edit: It’s probably due to my HDMI cable. Will try a high-speed one!


#139

Check Display Caps with grab-logs -P -z


#140

Yeah that must be it. I got a 55b6 so it should definitely be possible :slight_smile:


#141

Switched to a HDMI cable labelled “hi-speed” but still no 50/60hz option. :confused:
2160p60hz is available when using grab-logs -P -z.

Which HDMI spec should the cable support?

Edit: Ok, I need Premium High Speed HDMI…