HDR Slight flickering (Workaround available)


#102

Ok that’s cool! So seems like a good player then eh? Does it do kodi or is it some other player? I haven’t looked at it at all tbh, not a big fan of Apple stuff.
I just tried a 24fps hdr movie that flickers but the noise settings didn’t change anything. Flipping to 60hz using callbacks and it’s all good.


#103

Yeah I’m liking it. I use an app called Infuse which is great for local media. It handles pretty much any file and format you can throw at it. Kodi isn’t available but plex and Mr MC are. Mr MC is a Kodi derivative without the ability to run add ons. Way off topic here now but feel free to PM me if you want further info.
Sam…feel free to delete these OT posts


#104

I did install the new update on my Vero4k but the HDR issue regarding flickering in bright areas has not been solved. On my projector (Sony VW760) there is only some slight flickering but on my LG OLED scenes with for example sky and clouds are mostly unwatchable. Any idea how i can help to find a solution? I specially bought the Vero4k in order to watch HDR content.


#105

I have done some recent testing on an LG 49UJ630V and could reliably reproduce the flicker. Prior to yesterday’s update I did notice a bit of flickering on scenes, and it could be produced when a scene was paused as originally reported, but this doesn’t seem noticeable anymore.

I will re-test with OP’s sample

Sam


#106

Thanks for you quick reply. I used the pool scenes with sky and clouds from the beginning of Life of Pi for testing purposes. Maybe you can better reproduce it with these scenes.


#107

I just updated and also confirms problem is still present which is disappointing because I waited so long for this update.
For testing I use the movie Crouching Tiger which begins with a logo with blue background. Flickering is very strong in this situation.


#108

Just did some more testing (all HDR):
1080p / <=30Hz: flicker
1080p / >=50Hz: ok
2160p / <=30Hz: flicker
2160p / >=50Hz: ok

So itˋs definitively dependent on the refreshrate, but itˋs independent from OSMC, because the issue also exists on my other AMLogic S905X based Hardware using Libreelec 8.2.2.3

Whats making me nervous is that the flickering also appears when the video is being paused. In my opinion this means that it has nothing to do with colour bit depth, but that there is something wrong with the HDMI-Signal being outputted from the AMLogic chip. Hopefully itˋs not a general hardware issue with this AMLogic chipset!


#109

This is quite useful. Thank you.
Do you have another (non AML) device to test HDR with and check the refresh rates too? Unfortunately I only have one other device that is not AML based.

Sam


#110

Some more infos:
Flickering also appears within Kodi Leia (OSMC and Libreelec) and the flickering is not only visible in video beaing played but also in the Kodi GUI (for example the box which highlights the current cursor position is fully flickering).


#111

Unfortunately not. I bought a Kabby Lake based system some time ago in order to build up a 4k/HDR capable client. At this time it was unkown that Kabby Lake will never get HDR.


#112

OK – I’ll give this more testing. It’s quite annoying this issue is still present in some areas.

The fact it’s only present on some refresh rates suggests a PLL issue or timing / clock issue, particularly as it flickers in and out.


#113

I totally agree with your conclusion.


#114

I’d like to chime in that watching a 1080p24 10bit video (non-hdr) also causes flickering for me. If i set resolution to 2160p60hz420 then the flickering is gone. I remember that picture with different color depths and refresh rates which indicates that <30hz is only possible in 4:4:4 and not 4:2:0, and the LG TV doesn’t seem to like 4:4:4 (unless it’s set to pc mode which disables all post processing).

It doesn’t explain why it works on other devices like the shield or chromecast, but since the TV doesn’t display refresh rates and other info it’s hard to say exactly what’s going on.


#115

I too have noticed the flickering is still there (a 24hz 4k rip of Blade Runner in HDR) but I’ve also noticed it on certain screen on the KODI GUI that I haven’t seen before. I run my GUI at 24hz since most of my media is that rate, but will try at a higher rate later and report back

Thanks

-Mat


#116

This is a problem I’m having with LG sets.
My testing also seems to be skewed by some horrific PWM like flickering on the display.

I’m not sure if this is an effect of some of the picture settings; or part of the charm of the cheap and cheerful sets (only purchased for testing HDR on LG sets).

Time for further testing.


#117

Just tested LibreELEC on an S912 device and the flickering is gone!

LibreELEC on a cheap S905x device has the same flickering as on the Vero4K (as expected).

Is the issue HW related or is the S905x not configured the right way?


#118

I don’t think it would be hardware related.
I think the S912 has different drivers and kernel. I don’t know much about the S912 or LE unfortunately, but I can ping a developer and see if there have been changes.

The HDR patches we have are bolted on. It’s possible they are using a newer drop of the AML kernel (we haven’t done this yet as things need testing) and that this is no longer necessary.

3D was broken temporarily when AML tried to add DV support to S912, as auto switching uses the same registers. It’s possible they’ve broken a check in the kernel.

Sam


#119

Why does the subject say “Solved for now”? How is it solved? I still got flickering in HDR. :thinking:


#120

There’s a “workaround” , try running at 50/60hz and flicker should be gone.


#121

That’s not an oled set I’m afraid. This has something to do with oled panels rather than it being an LG specific issue (although they do make all oled panels available in commercially available TVs). This issue has been confirmed on the most recent Sony Oled.

It seems that the core issue behind fixing this problem is you haven’t actually been able to reproduce it. This is leading to tweaks and updates indicating it’s fixed when, if you’d been able to test on an oled, you’d realise it wasn’t.

Obviously I’ve moved on from this device because of this issue so I can’t really help with any troubleshooting. I just wonder if there’s any poster on here lives close to Sam and might be able to allow him access to their Oled so he can get a handle on what the issue is?