Forked-daapd


#23

OK, so it looks like there is no hardware volume control defined. If you want a volume control you will have to create a softvol. From the way it’s done on vero4k, you could try this in your asound.conf:

pcm.!default {
        @args [ CARD ]
        @args.CARD { type string }
        type softvol
        slave.pcm {
                type plug
                slave {
                        pcm {
                                type hw
                                card $CARD
                                device 0
                        }
                }
        }
        control {
                name "PCM Playback Volume"
                card $CARD
        }
}

ctl.!default {
type hw           
card 0
}

then see if amixer/alsamixer is showing a volume control.


#24

thx for the instructions. now i have a device in alsamixer where i can regulate the volume. apparently it is not the output device i want to control (at least it does not change the volume of the local output that forked-daapd uses with the config-file above. so, ho do i specify that controlable device in forked-daapd.conf?

cheers
bendsch


#25

i am able to control the volume of the pcm device via mpd/mpc commands now. unfortunately it has no effect on the volume of the output sound (sound is playing but sound-volume stays at the same level no matter how high or low the controler is) …

at the moment the relevant section in forked-daapd shows like that:

#Local audio output
audio {
#Name - used in the speaker list in Remote
nickname = “Computer”

#Type of the output (alsa, pulseaudio, dummy or disabled)
type = “alsa”

#For pulseaudio output, an optional server hostname or IP can be
#specified (e.g. “localhost”). If not set, connection is made via local
#socket.
#server = “”

#Audio PCM device name for local audio output - ALSA only
card = “hw:0”

#Mixer channel to use for volume control - ALSA only
#If not set, PCM will be used if available, otherwise Master.
#mixer = “PCM”

#Mixer device to use for volume control - ALSA only
#If not set, the value for “card” will be used.
#mixer_device = “PCM”

/etc/asound.conf is ecaxtly as you suggested.

what am i missing?


#26

help, anybody?