External Gigabit Adapter on Vero 4k+?


Im in my OSMC and it says Status: No wireless connection and gives me an option to Enable Adapter. And in all tests I had removed the usb adapter completely and rebooted the device. It’s ok just been a little frustrating. I hope i haven’t come across too negative, I have yet to test a unit that did a better job overall with kodi.


In the log, it was clearly enabled and successfully connecting:

Nov 01 12:00:57 osmc wpa_supplicant[477]: wlan0: Trying to associate with 08:9e:08:ea:fd:31 (SSID='Tardis' freq=5745 MHz)
Nov 01 12:00:57 osmc wpa_supplicant[477]: wlan0: CTRL-EVENT-CONNECTED - Connection to 08:9e:08:ea:fd:31 completed [id=0 id_str=]
Nov 01 12:00:57 osmc connmand[388]: wlan0 {add} address label wlan0 family 2

So to ensure that your video traffic isn’t going via the wifi channel, you need to keep it disabled for now.


Sorry – I thought you’d uploaded a new log.
The log you uploaded previously shows that WiFi was being used at the time, not either of the available Ethernet connections.

Have you since tried with Wireless disabled and the USB adapter unplugged? You may be pleasantly surprised.

You do not need to use fstab mounts.

If you’re getting 900Mbps+ via the internal adapter, there’s not a hardware issue at play here. Content will also play properly.

If you genuinely believe the hardware is faulty I recommend you contact support@osmc.tv where we can take a thorough look at it.



Well it says disconnected like I said and the issue remain unchanged.


At the time you posted the logs, it was clear that WiFi was connected and being used.
Please try again and upload a log, and we will be able to advise.

So far we haven’t seen any attempt to play any content using the internal Ethernet connection.




This only makes sense if the external Ethernet adapter had the same issue, but it works perfectly fine. I’ It’s ok, I understand that despite that its still an issue with “my” network. And if I sent it back i am sure it would test fine as it also tests fine over here. It just doesn’t work fine. A new one would most likely do the same thing based on what you have told me.

At least it works :wink:


Sorry replies are coming out of order. Creating new logs now. Same problem is happening though and wifi is most definitely showing disconnected.

In fact when later I enabled wifi to test that it worked better.


The only way to properly test things would be to disable WiFi, unplug the USB Ethernet adapter and try playing some content.

From your original post I wonder if you have started with the assumption that the internal adapter must be defective; but your tests so far suggest otherwise.

If you want to use the external Ethernet adapter, you’re of course welcome to. The offer to examine things in more detail is still on the table however. This isn’t something we plan to remedy in a chipset or hardware revision; as we have now resolved the issue with the small number of Ethernet jacks affected (a raw materials problem) and improved our test suite to pick this up.




Ok I am running a new log because your sorta right, it wasn’t connected to the wifi but the adapter was enabled. Results are the same, I am only using the smb mounts.


wlan0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC>  mtu 1500
        inet  netmask  broadcast
        ether 10:d0:7a:b2:46:d2  txqueuelen 1000  (Ethernet)
        RX packets 824  bytes 166012 (162.1 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 233  bytes 48935 (47.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

You are still connected to WiFi .

You also seem to have added NFS fstab mounts, but you are using Kodi SMB mounts. No need to use fstab mounts, but this is to let you know that they won’t be utilised as a result.


Ok I am running a new log because your sorta right, it wasn’t connected to the wifi but the adapter was enabled. Results are the same, I am only using the smb mounts.



That’s better. The log doesn’t show buffering issues however.


I didn’t see them when I looked through the logs either. Oh well, I swapped back to the usb adapter and all is fine. Is it safe to crack the case open and check connection, solder points etc?


This would void your warranty. I don’t think you’d see anything from a visual inspection. Your speed test is showing good speeds; so I don’t think there’s a hardware issue.


Ok thanks


Just wanted to post a follow up on this. After being told repeatedly that there was an issue with my network or something and that the tests happening in house would have caught a bad network port (the tests they had me run also looked fine) I ordered another vero4k under another account and it showed up and the internal network adapter worked fine.

I was honestly very put off by the defensiveness that the product could not be defective and when they have exchanged for others those units were not defective either. We purchased these products for review purposes and to check compatability with our Kodi plugin. My conclusion is that the tests are not uncovering the bugs and overall was dissapointed with the amount of hoops you have to jump through because it “can’t” be an issue with the product. We have scrapped our review plans and will wait for future version or firmware before we begin testing for publication. I would suggest however if you get frustrated that it’s not working right, return or exchange and understand that the tests are not uncovering the issues. At least with the network adapter.


I’m sorry to hear you are still experiencing problems.

Please can you let me know the two order numbers?

You are welcome to return any affected device for warranty replacement. We will test it upon receipt.

I couldn’t find a support ticket with this request however.

All devices shipped are run against an extensive test suite. As of the end of September, this also tests Ethernet performance. The iperf tests you have run show that your Ethernet port is performing as expected.

Can you confirm that the new device is running in the exact same location (same power supply, Ethernet cable, connected to same switch) etc?

This is not true.

There have been 53 devices in the last three months that have been replaced due to a faulty Ethernet port. Every faulty device showed problems with Ethernet performance via iperf. Your device doesn’t — so it’s unlikely to meet the characteristics that would make the port faulty. We are confident that we have identified affected boards and we have resolved the issue in production.

Nonetheless, we are happy to swap this for you and I’m happy to take a call about this.




One further suggestion would be to completely reinstall OSMC on the affected device, and use a USB stick to make a backup from the working device and transfer it over to the device where you have experienced issues.