Easy access to audio settings


#1

Hopefully this is the appropriate forum for this.

I would say half the time I use my Vero 4K, I’m using my home theatre system and thus have 5.1 sound. However, the other half of the time, I’m using headphones. Often, I’ll be into a movie wearing headphones and I’ll realize that I’m hearing the back channels or the audio just sounds off.

I would like a way to easily switch between the audio output modes without having to burrow through several menu layers.


#2

Interesting request. IIRC there was a Kodi plugin which permitted this some years ago; but I don’t remember what it was from the top of my head.

Sam


#3

https://kodi.wiki/view/Video_playback#OSD_audio_and_subtitle_settings

Audio OSD doesn’t provide access to the necessary settings?


#4

I think he wants a way to change hardware output (hdmi, analog, bluetooth), not the audio language tracks.


#5

Did you confirm that audio output device is not available from that menu? I’m not in front of a 4k to check at the moment. This ability may also be skin dependent but, the link I provided indicates the below quote, though not pictured.

Audio output
Select output device for the current stream


#6

It shouldn’t be back channels. If kodi is set to 5.1, you will get front left and front right on the analogue output. Why it’s weird is that the main dialogue is on front centre. I think all that’s needed is a quick way to change the speaker layout to stereo. Or have I missed something?

It would be nice if analogue was always mixed to stereo even if speakers are set to 5.1 but I’m pretty sure tha’s not possible.


#7

It’s not there (I’m using a custom skin though).

The thing is that it’s also not visible in the picture which shows the default Kodi skin, so…

@BGIYYZ please check and report back.


#8

There is no way to choose headphones as the audio output on Vero4k. I think it’s channel layout he needs. That’s not there either but might possibly be added.


#9

I will check it out when I’m in front of it and will report back.


#10

This could probably do what you want by adding key shortcuts for the required audio profiles (audio device and speaker layout):

https://kodi.wiki/view/Add-on:Audio_Profiles


#11

I think my problem might have stemmed from not understanding some of the settings available to me.

First, I’m using the Grid skin for Kodi. If I go to system setting>audio>number of channels and set it to 2.0, and watch a video file with 5.1DTS audio, all is fine while using headphones.

If i go to system setting>audio>number of channels and set it to 5.1 and watch the same video file using headphones, I hear the back channels only.

I have since found (due to my ignorance about some settings) that if I’m watching the video file and push the centre OK button on my remote, go to audio and subtitle settings and turn on “allow passthrough”, audio seems right in my headphones. I certainly can at least hear the front channels.

Not knowing what passthrough meant was my problem. This menu is pretty easy to access from within a movie, so I’m happy.

I guess my question has been answered. Thanks everyone!


#12

As you’re happy with your solution, I’ll tick your reply as the solution to this thread :+1:t2: