Config.txt not loading in myOSMC


#1

Hi
have updated config.txt via nano.

now osmc is not reading config.txt any more.

How to solve this issue?

Is there a initial config.txt to be used ?

Thanks T


#2

I think the easiest is to revert in nano the changes you have made.


#3

I did some changes, do not exactly realize which one caused the problem?
are comments a problem?
sequenz of command?

will try some

thanks


#4

run grab-logs -p and share the URL than we can give advice


#5

Hi Thanks

please see here:
https://paste.osmc.tv/xitatalila


#6

Well as a start I would remove the characters you have around the = in this line
hdmi_ignore_edid_audio = 1


#7

ok will try
thanks

done, does not help

still unable to open config dialog in myosmc


#8

Ok, I copied your contents into a new config.txt on my system and was able to open it in MyOSMC.
So suggest you copy and paste the contents of mine into a clean one on your system and try.

If you still have an issue I suggest to enable debug logging and upload logs after you try to edit it vua MyOSMC.

Here is mine working with your content. You can directly copy it on your system.
sudo wget -O /boot/config.txt https://paste.osmc.tv/ukawenecob

Check the contents afterwards with cat /boot/config.txt


#9

Hi
thanks for your support
still not working:
https://paste.osmc.tv/idohobejoq
very strange


#10

strangewise
I had added the entry in another try:

dtoverlay=hifiberry-digi

which is deleted after I open via myOSMC.


#11

Enable debug logging and upload logs after you try via MyOSMC


#12

Hi,
debug logging was enabled…
where can I confirm it?


#13

try to verify it


#14

https://paste.osmc.tv/abigahonoh

new log here.


#15

But you didn’t upload logs. With that command you only uploaded the config.txt file.
Full log upload grab-logs -A


#16

sorry,

https://paste.osmc.tv/kolucaqeha


#17

Are you sure you have chosen “Open Config.txt Editor”? Because your log file does not show any entries for config_editor.py


#18

Hi
do you mean : in myOSMC edit config.txt?
yes I did this.
this is the screen when I press: PI Config in myOSMC

i do see:
14:34:41.607 T:1682436864 DEBUG: osmc_settings: <OSMCSettingClass(Thread-12, initial daemon)>
14:34:41.608 T:1682436864 DEBUG: osmc_settings: False
14:34:42.248 T:1203761920 DEBUG: OSMC PI Settings extracted from the config.txt
14:34:42.248 T:1203761920 DEBUG: OSMC PI hdmi_force_hotplug : false

latest log: https://paste.osmc.tv/momaxuxanu

Am I doing a wrong thing?


#19

Well I don’t think that you are doing something wrong. But based on the picture above that doesn’t look right.
And I meant “Config Editor” -> Open Config.txt Editor"
But based on the picture it might also be other addons breaking it


#20

Hi
where do I find config.txt editor? in osmc?
I only used it via myOSMC : Pi config : that is the screen

or via nano …