Choppy video since Krypton update on Vero 1

#102

Thanks @Duncan and @Smurphy for trying to help.

I already have an advancedsettings.xml and I’m also using the new cache-setting with readfactor 4.0.

I installed ethtool and set it to 100MBit/s as described.

Unfortunately this doesn’t change choppy playback for my movies one bit. It’s a regular choppyness, like a missing frame every second.

dpkg -l | grep vero-mediacenter-osmc tells me I’m using 17.0.0-14

I will make new logs now, stay tuned…

0 Likes

#103

Did you by chance checked if there is not something else running on your Vero using up all your CPU???

Try running “top” through the console (use putty or ssh under linux to connect to it).
That can also be a possibility.

0 Likes

#104

The system is 96% idle according to top.

0 Likes

#105

Debug-Logs @ http://pastebin.com/raw/FBzLenRX

I played two movies for a few seconds with choppy playback.

0 Likes

#106

So, I

  1. made a backup of the SD card with OSMC 2017-01.01
  2. updated to OSMC 2017-02.02 using “apt-get update + dist-upgrade + final reboot”
  3. rechecked whether surging video issue still there (yes)
    whenever I start a choppy video the dmesg cmd shows 2 new entries
    [ 1430.068742] mxc_vpu 2040000.vpu: Physical memory allocation error!
    [ 1430.068768] mxc_vpu 2040000.vpu: Physical memory allocation error!
  4. Installed Sam’s fix (wget + dpkg + reboot)

But it did not improve anything. Also after the installation of the fix I can see the dmesg entries

[ 216.820054] mxc_vpu 2040000.vpu: Physical memory allocation error!
[ 216.820076] mxc_vpu 2040000.vpu: Physical memory allocation error!

for 1080p video using nearly full HD resolution.
The video files resides on an EXT4 hdd connected to the Vero.

root@osmc-vero:~# dpkg -l | grep vero-mediacenter-osmc
ii vero-mediacenter-osmc 17.0.0-14 armhf Media Center package for OSMC

http://paste.osmc.io/evitihasak

Will go back to OSMC 2017-01.01.

0 Likes

#107

@JimKnopf

Hmmm …

====================== systemd =================== 86JFGfNO
total 756
-rw-r--r--  1 root root   403 Jan  7 05:13 -.slice
drwxr-xr-x 19 root root 12288 Mar 13 19:32 .
drwxr-xr-x  8 root root  4096 Jan  1  1970 ..
...

That “-.slice” is a typical signature of the Lavasoft trojan horse.
Could you log in as osmc (with putty or ssh) onto the Vero, then execute the command: "top"
and take a screenshot.

If they have replaced the programs etc. (top) it will hide itself so you won’t see it.
Then please provide a: cat /proc/loadavg
which will output the load actually handled by your vero CPU.

Please make sure Kodi is not running.
sudo service mediacenter stop
Wait 5 Minutes, then check the load of the vero again.
and drop us the data returned.

You can also use: top -d 1 -b -n 1
Will show all running apps and their respective load and mem usage.

0 Likes

#108

@Smurphy You talkin’ to @JimKnopf?

0 Likes

#109

I’ve got the test file from @pepto and can confirm that this file does not play smooth on my Vero1 either.

Tomorrow I can install Jarvis on the Vero1 to check if it play there, if it have any interest??

0 Likes

#110

@pepto: Yes. Will update

0 Likes

#111

@Smurphy This is the root file of the slice unit configuration, see also https://www.freedesktop.org/software/systemd/man/systemd.slice.html

Please, only facts and no speculations combined with smattering!

0 Likes

#112

You got me there. When looking for slice, the most things I did find were hints on the lavasoft trojan.
Reason I asked also for top output. Gives an indication on what is running most and causing high CPU load, which is also one of the reasons the Vero 1 can playback video in choppy mode…

0 Likes

#113

@sam_nazarko: Is there still a need of video clips to reproduce the issue?
If yes, I could try to generate a bunch of scene video clips out of a lot of films identified with the problem.

0 Likes

#114

So, a simple ‘yes’ or ‘no’ would be fine after 2 days …

0 Likes

#115

Hi @JimKnopf

Sorry – it’s quite busy around here. I wanted to reply when I had some further information. I’ve been watching TV on my Vero 1 for a couple of days and didn’t have problem with the content I was playing (typically 1080p H264, with a passthrough track). I understand that’s not helpful for your situation, but wanted to see if I could typically reproduce this here.

If you PM me some sample clips that cause problems, I will take a look. Unfortunately there seem to have been some changes to VideoPlayer that have caused regressions for i.MX6. I’ll do my best to look at them and see if I can find a way to resolve them.

A debug log using the new build would also be helpful.

Cheers

Sam

0 Likes

#116

@sam_nazarko Just to make sure: Did you ever check the test-clip (choppy.mp4) that I sent you on Feb12? It plays choppy for other Vero 1 users on Krypton as well and I pasted debug-logs to pastebin.

0 Likes

#117

@pepto: Invited you in a private com with Sam. Could try to dup the prob with some of the scene clips provided?

0 Likes

#118

So I tried the update to because for some people it worked. It didn’t change anything but it killed my settings ( lost language, video, audio, etc)
Checked my network speed and it is active on fast ethernet (100Mb).
In the debug window the skips where very high with 1080p
content so maybe that info can help.

If I can help any other way let me know.
Still hoping on a fix soon

0 Likes

#119

@leurb: Can you confirm with your environment that the skip rate goes to 0 (means counter does not grow anymore) if you set the zoom amount to 0.9 and below when using full HD material (1920 x 1080 with NO (!!!) black bars at top and bottom? See

0 Likes

#120

@JimKnopf: Yes I can confirm that that the skips rate does not grow anymore with the 0.9 Zoom amount.
I tested exactly as you mentioned with orgininal NO black bars.

Looks like a good point in the direction of the cause.
For now also a workaround to at last watch 1080 content.

0 Likes

#121

I also can confirm that this is working. I finally have hope that my Vero 1 is still usefull. Don’t know how you came up with this solution, but THANKS! @sam_nazarko I presume that you are still working on a fix? Your original fix did nothing for me. Hopefully, this will help you figure out what is going on.

0 Likes