Choppy video since Krypton update on Vero 1

#82

A lot better. But on my 4k I’m going for wired. Speeds are good. But there stil is some lag in starting. On LAN the videos start almost immediately on wireless not. Not even on the 4k. I will test again when I buy the Netgear R7000.

Thanks again for the help!

0 Likes

#83

In the next update, there will be an improvement to the preload buffering on Vero 4K. I’ve switched my Vero 4K over to WiFi for watching now as it keeps things a bit tidier this way.

Sam

0 Likes

#84

@Duncan, so what did you change that helped? Was it the 20/40 setting in the router?

It may help others to know what you did.

I’ve always been curious about the buffer settings in advancedsettings. I’ve never used them. Maybe I’ll turn them on on my bedroom Pi2 (Connected via OSMC AC dongle) and see what happens.

1 Like

#85

Yes, set to auto a router will check wich is the best. In MacOs you can press option (alt) and then click the wireless icon. Then and only then you can see and click Open Wireless Diagnostics. Ignore the window that opens and at the top of the screen click Window and then Scan. Now you see all wireless connections from all the people in the neighborhood and which channel their routers are using.

I chose channel 3 which was not used by anyone.

0 Likes

#86

What helped the most was the 20 to 40 setting. Channel is important and should be checked too. The setting b,g + n to only n didn’t help a great deal but switching between 20 to 40 can happen is b or g devices connect so then you wil definitely notice speed changes.

I never used the buffer setting in advancedsettings.xml.

1 Like

#87

I’d think that forcing the channel is a short-term fix. What happens when a neighbor starts using the same channel. (Something I don’t have to worry about as there is no neighbor close enough to interfere :wink: )

0 Likes

#88

True. I wish I had your luxury. I still hate it that my neighbours router weatherbutterflies is stronger than my ZTE router. :rofl::disappointed_relieved::sob::sob::sob:

0 Likes

#89

Getting the R7000 will help with the 4K at least since you’ll get the AC speeds. And it could help with the N devices, since you will have one less N device on the network fighting for resources.

1 Like

#90

I think you are right. Now do I sell sone Bitcoins or wait on my march salary. Lol. :grin::rofl:

With my third son on the way I have to prioritize. But they make me richer than money can ever make me.

0 Likes

#91

Wait for March<sell bitcoin in the long term! Only a month away :wink:

1 Like

#92

Don’t worry – at least you didn’t have all of your coins in Mt. Gox :head_bandage:

1 Like

#93

True dat. But I only got them a month ago. But at least I didn’t crash a harddisk with a ton of Bitcoins like a colleague, without a back-up. Ahh well. At least he doesn’t have to pay alimony. Maybe build a rack of Vero 4k’s and start mining. :wink: :joy:

0 Likes

#94

No offence guys, but could you maybe keep your discussion about WLAN and Bitcoins out of this thread - at least as long as the issue at hand doesn’t seem to be fixed yet?

Is there any way I could help? Would more test-movies help?

0 Likes

#95

@pepto it seems improved here. Were you able to play that clip in the past with Jarvis?

At this point a debug log might be helpful as @Duncan and @thansen_dk both reported the issue as resolved

0 Likes

#96

Yes, they played smooth like butter using Jarvis and the versions before that. I guess @Duncan and @thansen_dk had a different issue then, as the issue is completely unchanged for me after I installed your patch (I’m the one who opened this thread originally).

Do you need more debug-logs than the ones I posted at the beginning of this thread? I’m at work right now, so this would have to wait until this evening.

Most of my movies play choppy since the Krypton update, including the test-file that I sent you earlier. I could send you more if that helps.

I would love my Vero to be able to play movies again like in Jarvis times. It’s been nearly a month now without being able to use it… :frowning:

0 Likes

#97

I have a suspicion here.
On one of my raspberry PI devices I keep having issues because the WiFi disconnects in the middle of playing back a song.
Is there a way to monitor the WiFi device? I kind of think there is something else going on here.

Depending on how fast it reconnects, it can get shoppy

0 Likes

#98

I don’t use WiFi, my Vero is connected via Ethernet.

0 Likes

#99

Yes – I need debug logs again, because the debug logs no longer apply to the updated build.

Also dpkg -l | grep vero-mediacenter-osmc so we can verify the build is installed correctly. Make sure Adjust Refresh Rate is enabled.

0 Likes

#100

Hmmm…
Did you then setup the cache in the advancesettings.xml file?
I always needed it. On the Vero 1 I also needed to slow down the network interface to 100Mbps, as the switch I had at that time was not really good at handling the flow-control.
On Vero 2 and Vero 4K, I need the cache settings too. Especially for playing back Flac audio files in high quality.
Check details here: http://kodi.wiki/view/HOW-TO%3AModify_the_video_cache (Note that Krypton changed the syntax from network -> cache.
Here is my entry for my Vero 1:

<?xml version="1.0" encoding="utf-8"?>
<advancedsettings>
        <cache>
           <buffermode>1</buffermode> <!-- Default is 1 -->
           <memorysize>139460608</memorysize> <!-- Default is 20971520 bytes or 20 MB -->
           <readfactor>5.0</readfactor> <!-- Default is 1.0 -->
        </cache>
</advancedsettings>
0 Likes

#101

@Smurphy is right, had the same issues on the Vero 1.

If ethtool is not installed:

sudo apt-get update && sudo apt-get install ethtool

To see the current settings:

sudo ethtool eth0

If:

Speed: 1000Mb/s

Then:

sudo ethtool -s eth0 speed 100 autoneg off

And test again. I always test it with a hq trailer from Blade Runner 2049. The smoke in the first scene hangs if eth0 is on 1000Mb/s speed and plays fluently on 100Mb/sec.

Download the mkv trailer here:

Blade Runner 2049

Kind regards,

@Duncan

0 Likes