CEC issues since xmas update

#90

I experience the same issue. In case extra logs would help, I am happy to provide them.

0 Likes

#91

The issue of AVR changing from Vero 4k input to its own home page when TV is switched on appears to be further upstream. reported here:

I’ve now resorted to disconnecting Vero 4k to stop TV from waking up.

0 Likes

#92

This is a libCEC bug to my recollection, and not necessarily platform specific. It’s to do with a member state variable handling the power on setting.

I need to re-visit as I remember we fixed it downstream in 2015; but when we bumped libCEC; we had been told the issue was fixed upstream so dropped downstream patches.

Things may not be quite right still. As always – it can be hard to test without hardware at hand, so I may need to produce a few test builds until we can work out what is going on in a more definitive way.

Sam

0 Likes

#93

Hey there everybody,

after living with pulling the plug on my lovely Vero 4K+ every day to reboot it I tried to analyse the root cause for the wake up once again…

But sadly I just cant find it in the log :frowning:

Can anybody point out what’s happening?
http://paste.osmc.tv/qigujosezi.vhdl

I know I have a rather heavy skin (Eminence 2 MOD) with lots of widgets loading content even when in “standby” but the same happens with the osmc skin. As stated above I just don’t a definitive trigger event.

What else can I try? Can I programmatically disable/reenable all addons via the standby.py/wake.py scripts?

waiting patiently for the new update - I know it’s a huge job for you guys!

cheers
Anthrax

0 Likes

#94

Unless you enable debugging there will be nothing to be found in the logs

0 Likes

#95

I’m pretty sure I have debugging enbled - I’ve got the overlay and marked all components… but after further inspection the component specific selection seems to get reset after reboot - is that true?

[EDIT] Ah -facepalm-, it seems I have never used the component specific dialog right. never okayed it because Ok-button was overflowed by dialog title. Now I feel stupid.

Will do another deep dive and’ll report.

Anthrax

0 Likes

#96

Actually you have, seems my browser showed my an old log that I had open.
Can you give again an explanation what actually is your problem? Also when it happens to upload all logs grab-logs -A

0 Likes

#97

After applying an updated version of this patch ( Revert LG reconnect request) : https://github.com/osmc/osmc/commit/92d993e631e7b97778e612326c99cce18e865a98#diff-2e8e2c2965f60f7853487182b8976b73
My system does not show this behaviour.

0 Likes

#98

I believe this fix is upstream now so it should be fixed with the CEC bump in v18 release

0 Likes

#99

An upstream “fix” for the regression was rolled into 4.0.3 but it didn’t sort out the the issue for my setup. I’m not sure whether having an AVR like in my setup results in the fix not working.

The original regression was introduced when a fix for another issue was adopted!
It is difficult to workout how many people were affected by the original issue vs those affected by the regression. The Holy grail would be finding a solution that does not cause regressions elsewhere.

0 Likes

#100

Might be worth us re-introducing it.

I remember @mk01 had a better approach some years ago; but I’m not sure if it’s still applicable to libCEC in its current state.

0 Likes