CEC issues since xmas update

#70

I will look in to this in more detail after v18 is released (shortly). We’ll get it solved – don’t worry.

Sam

0 Likes

#71

I also suspect CEC message
10:04 - Sending active source message for ‘Recorder 1’

may have a toggling effect on my AVR. i.e. If the AVR has already selected the OSMC input, when the command is sent, it results in the AVR changing from the OSMC input to displaying its home page.

0 Likes

#72

@sam_nazarko Here is my current theory of what is going on:

The TV wakes up to perform various maintenance activites in the middle of the night e.g. auto tune Freeview/Freesat channels etc. (As many freesat/freeview STBs do)

If the Vero was the last source when the TV was placed in standby, the Vero (and AVR) are also waken up.

A CEC instruction is sent to make the Vero the active source (by Vero?).

The TV then does not shutdown after it finishes its maintenance operation because it thinks the Vero is now active. The TV then becomes dependant on receiving a standby command from either the Vero or its remote control.

If there are are no other shutdown timers, (e.g. for inactivity), the TV remains on.

After turning off Freeview / Freesat on TV, it has not woken up in the night. Still monitoring however.

1 Like

#73

That shouldn’t be happening if that option is disabled under CEC settings.
I’m still investigating this problem. For now I think adding an option to disable the wakeup on resume from standby will suffice.

0 Likes

#74

Has this option been added somewhere? Would really like to stop this happening, but paranoid about oled burn in and whatnot.

0 Likes

#75

Not yet. Still investigating.

0 Likes

#76

I’ve swapped over to an S905X box with the stable release of CoreElec for a few days and the TV has not woken up in the night. I noticed that it has LibCEC 4.0.4.

0 Likes

#77

libCEC 4.0.4 is available in the staging repository. You could try that.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

0 Likes

#78

Also: can anyone confirm if this does not occur if they don’t suspend the Vero?

0 Likes

#79

Will try that too if i get time.

I thought this issue was related to the library auto updater as it seemed to go away when i disabled it, but thats not the case. Also noticed strange behavior on another TV, vero will immediately turn the TV off after i turn it on, even when I’ve already woken up the vero with a remote press. Usually after the second time its fine.

To reiterate though, all these behaviours are new to the last update, was working perfectly before that.

0 Likes

#80

hi,
it happened to me but somehow different

config:
Vero 4K+ --> AVR-X1400H --> OLED C8
also, all devices are/can be controlled with Harmony remote, so the CEC is disabled almost everywhere
I say almost because at least on Vero 4K+ I prefer it on - this way the Vero 4K+ RC is able to adjust the volume on AVR-X1400H
but, if I remember well, the option for signal source correcting is disabled in Vero 4K+ CEC

I must admit I have the bad habit of updating in command line every package available
I cannot remember when I realized that the custom shutdown doesn’t work anymore
if I leave the box ON, it will remain ON forever
but if I leave the box in suspend mode, it will not start by itself, maybe because CEC is turned OFF on TV and AVR

the most annoying problem was losing the ARC feature. after few days of panic and research I found out that a reboot of everything can bring the sound back
apparently everything is back to normal after the latest update (now there are no packages to update on my box)
the Kodi custom shutdown still doesn’t work

unfortunately right now I cannot upload the logs because I am not at home and I do not know how to enable Kodi debugging in command line

however, I can update libCEC for testing - should I do it now or after exporting the logs?

regards,
cgh

0 Likes

#81

Please go ahead and try the update

So this issue is only occurring when the suspend mode is engaged?
Can others confirm this?

Cheers

Sam

0 Likes

#82

For me, the odd steal-the-input on turn on thing only happened when the Vero was suspended. Though I’ll need to double check that I’ve not outright disabled CEC, because I may have.

0 Likes

#83

I think I know what’s doing this now.
Stay tuned.

But please try recommendations above. The more data points the better.

0 Likes

#84

after this update the custom shutdown timer works again, the box switch to suspend mode after the desired time
thanks!

0 Likes

#85

I’m almost certain I’ve experienced the random power ups a few times since i updated from the staging repository but they seem to stop when I enable logging. Strange

edit: I can confirm that I have experienced a number of the random power ups. However, they seem to stop when i enable debug logging. hence no logs.

0 Likes

#86

Left TV off overnight with logging running.
Spontaneously TV powered up at around 03:01 hrs.

Log Link:
http://paste.osmc.tv/ojeriveneh

0 Likes

#87

Because Kodi crashed

Mar 01 03:00:34 osmc kernel: kodi.bin[561]: unhandled level 1 translation fault (11) at 0x00000174, esr 0x92000005
Mar 01 03:00:34 osmc kernel: pgd = ffffffc060026000
Mar 01 03:00:34 osmc kernel: [00000174] *pgd=0000000000000000
Mar 01 03:00:34 osmc kernel: 
Mar 01 03:00:34 osmc kernel: CPU: 3 PID: 561 Comm: kodi.bin Tainted: G           O 3.14.29-139-osmc #1
Mar 01 03:00:34 osmc kernel: task: ffffffc05eb62000 ti: ffffffc0609e4000 task.ti: ffffffc0609e4000
Mar 01 03:00:34 osmc kernel: PC is at 0xaba2e088
Mar 01 03:00:34 osmc kernel: LR is at 0xabc87e9b
Mar 01 03:00:34 osmc kernel: pc : [<00000000aba2e088>] lr : [<00000000abc87e9b>] pstate: 88010030
Mar 01 03:00:34 osmc kernel: sp : 00000000ffd9ad60
Mar 01 03:00:34 osmc kernel: x12: 0000000043af0000 
Mar 01 03:00:34 osmc kernel: x11: 00000000ffd9ad78 x10: 00000000af5fef10 
Mar 01 03:00:34 osmc kernel: x9 : 00000000acd2b92c x8 : 00000000adeb7b7c 
Mar 01 03:00:34 osmc kernel: x7 : 00000000000000e8 x6 : 000000000000001f 
Mar 01 03:00:34 osmc kernel: x5 : 000000000000001d x4 : 00000000af5feb90 
Mar 01 03:00:34 osmc kernel: x3 : 0000000000000000 x2 : 00000000af5fef10 
Mar 01 03:00:34 osmc kernel: x1 : 0000000000000001 x0 : 0000000000000000 
Mar 01 03:00:34 osmc kernel: 
Mar 01 03:00:35 osmc sudo[538]: pam_unix(sudo:session): session closed for user osmc
Mar 01 03:00:35 osmc mediacenter[357]: /usr/bin/mediacenter: line 204:   538 Segmentation fault      sudo -u osmc $KODI --standalone -fs --lircdev /var/run/lirc/lircd
Mar 01 03:00:35 osmc mediacenter[357]: Kodi exited with return code 139 after 9 hours, 38 minutes and 14 seconds
0 Likes

#88

Addtional logs
http://paste.osmc.tv/musojinero

TV was off . Everything started waking up at about 19:20 .

0 Likes

#89

Looks like an addon crashed Kodi

0 Likes