CEC glitches


#21

I’ve checked the manual and the operation of my NR1603, and the HDMI Control setting enables both power-on triggers from other devices as well as passthrough. You can see from this shot that the 1603 has a more basic menu than your’s. I have never before checked passthrough in standby as TV sound is always routed through my main front speakers and I need the AVR to be running its pre-amp output into the external front amp with volume control via the TV. However, I did just check, and passthrough works.

You might be interested to know that when I switched HDMI Control off, as well as losing the ability for the TV to turn on the AVR, I also killed CEC to the Vero. I had to re-boot the Vero to get it back.

In the meantime, the OSMC Pi running to my kitchen system is behaving itself as well as the LE Pi did, whereas the Vero was just a non-starter in terms of CEC reliability, although in my other systems Vero/Panasonic combos are fine.


#22

Sorry for the late reply. Can you try the instructions here: HDMI-CEC some buttons not working on Vero2 that do work on Pi2

Sam


#23

thanks, can you point out the specific change I should make? Looks like I need to chase down an xml file?


#24

Yes — if you scroll up from above post you should see the detailed infob


#25

The thread you linked me to appears to suggest that a device_type key be changed to a value that mine is already set to. Here are some potentially relevant keys from my V4K+, should I be changing any of these in the peripherals.xml file?

<setting key="tv_vendor" type="int" value="0" configurable="0" />
 <setting key="device_name" type="string" value="Kodi" configurable="0" />
 <setting key="device_type" type="int" value="1" configurable="0" />
 <setting key="wake_devices_advanced" type="string" value="" configurable="0" />

#26

Just wondering to what extent there might be any chance of resolving the CEC compatibility issue I have with the Vero/speaker bar combo that does not occur with OSMC or LE Pi’s. in the meantime I have unwrapped a Vero remote for the first time (nice little thing) and I have a good connection, but it means I have an extra remote to have around that I don’t otherwise need when running a Pi. The benefits of the Vero can offset the minor inconvenience, but my inner geek is bugged by not knowing why CEC is better with a Pi, albeit in only one problem case out of the three systems I’m running.


#27

I suspect that changing device_type will do the trick.

The Pi and Vero CEC implementations are almost identical. However the Pi will behave as a Recorder and the Vero will behave as a Player. By changing the device type you can unify this behaviour.


#28

Sam, you’ve mentioned this a few times but never said what I should change the device_type key to. I just checked, my OSMC Pi has the same peripherals.xml entries as I previously posted for my Vero. So what should I do?


#29

4 would be worth trying.

Just to confirm: this issue only occurs when you turn the TV off? Are you standbying the device?


#30

Tried changing the device_type to 4 in both the central peripherals.xml file and, when that did not work, in the .kodi/userdata version, and neither fixed it. I had taken the trouble to stop Kodi first per the Wiki instruction.

Behaviour is as follows. With a Pi, I put the TV in standby (it’s never switched off), when I come back, one of two things happens: either the CEC is working, or if not, a quick switch away from the speaker-bar HDMI input and then back immediately wakes up CEC, and all is well.

With the Vero, I can get CEC to work after a boot, but if I put the TV in standby for around 10mins or so, when I come back CEC is totally broken, I have to reboot the Vero and cycle back and forth on the HDMI input and then CEC resumes, but only until the TV is next put into standby. This has not gone down well so either I use the Vero remote or go back to a Pi. The Vero’s technical advances over a Pi aren’t really needed for my kitchen system, so the Pi will probably be the option for now as it’s a little less hassle, but would be nice if we could get to the root cause of the problem.


#31

Thanks for explaining. Try enabling HPD Lock and rebooting


#32

Thanks, but unfortunately enabling HPD Lock has not fixed it.


#33

I’m not sure then unfortunately. Your log here: https://paste.osmc.tv/sebuyupoko shows CEC working and presses being received.

Sam


#34

As I recall this log started after a boot with CEC working, which I think shows in the log, then I turned off the TV for a while and when I switched it back on, CEC no longer worked.


#35

Does your TV have one of those menus that show if CEC devices are connected? It’d be interesting to know if the Vero disappears.


#36

The TV is of around 2010 vintage and the menus are quite basic, so I don’t have much more to go on.


#37

Do you have another TV to test with to see if you get issues there?

Cheers

Sam


#38

I’ve already tried my other Vero’s with my problem TV and they all have the same CEC problem with this specific TV, but they are all ok with the other systems I run.


#39

That’s annoying. I will see if I can reproduce issues with sets I have available