Can someone explain to me the whole inputstream adaptive stuff regarding DRM?



I wanted to migrate some sparingly used android apps to Kodi on my Vero 4k and the whole issue gives me an headache. I use a sports app called DAZN on my shield tv and I saw there is actually a kodi app. Tried to install it, that failed, error message that said it requires inputstream adaptive version 2.0.2… I can’t even find that version number, hightest seems to be 2.0.18 and that won’t install either. Are those higher version only for Kodi 18 alpha? Or just for some specific hardware?

Before I waste more time (already spent some hours without success), I just ask if it is possible to get such apps running on the Vero 4k with Krypton? Or do I need to install the alpha version of osmc/kodi 18, possibly as a dual boot?




We believe this is a Kodi specific function and as such you should look at addressing the question there.


Inputstream is in a state of flux and newer versions indeed come from Kodi v18 test builds.

Currently Amazon and Netflix seem to work and I am sure more will come soon. One thing for sure is that inputstream will be a prerequisite for watching DRM material.

You can try a V18 test build but you would need to reinstall to downgrade