Can I use Netflix on OSMC?(post 4)


#168

Hi @joakim_s Thanks for the guide. I followed everything and the install went fine. I can login to Netflix but I can not play any video. The errors in kodi.log are:
00:05:43.977 T:1746924256 ERROR: Traceback (most recent call last):
00:05:43.977 T:1746924256 ERROR: File “/usr/lib/python2.7/SocketServer.py”, line 290, in _handle_request_noblock
00:05:43.978 T:1746924256 ERROR: self.process_request(request, client_address)
00:05:43.978 T:1746924256 ERROR: File “/usr/lib/python2.7/SocketServer.py”, line 318, in process_request
00:05:43.978 T:1746924256 ERROR: self.finish_request(request, client_address)
00:05:43.978 T:1746924256 ERROR: File “/usr/lib/python2.7/SocketServer.py”, line 331, in finish_request
00:05:43.978 T:1746924256 ERROR: self.RequestHandlerClass(request, client_address, self)
00:05:43.978 T:1746924256 ERROR: File “/usr/lib/python2.7/SocketServer.py”, line 652, in init
00:05:43.978 T:1746924256 ERROR: self.handle()
00:05:43.978 T:1746924256 ERROR: File “/usr/lib/python2.7/BaseHTTPServer.py”, line 340, in handle
00:05:43.978 T:1746924256 ERROR: self.handle_one_request()
00:05:43.978 T:1746924256 ERROR: File “/usr/lib/python2.7/BaseHTTPServer.py”, line 328, in handle_one_request
00:05:43.978 T:1746924256 ERROR: method()
00:05:43.978 T:1746924256 ERROR: File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/MSLHttpRequestHandler.py”, line 63, in do_GET
00:05:43.979 T:1746924256 ERROR: dolby, hevc)
00:05:43.979 T:1746924256 ERROR: File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/MSL.py”, line 181, in load_manifest
00:05:43.979 T:1746924256 ERROR: request_data = self.__generate_msl_request_data(manifest_request_data)
00:05:43.979 T:1746924256 ERROR: File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/MSL.py”, line 485, in __generate_msl_request_data
00:05:43.979 T:1746924256 ERROR: plaintext=self.__generate_msl_header())
00:05:43.979 T:1746924256 ERROR: File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/MSL.py”, line 578, in __encrypt
00:05:43.979 T:1746924256 ERROR: return json.dumps(self.crypto.encrypt(plaintext, self.nx_common.get_esn(), self.sequence_number))
00:05:43.979 T:1746924256 ERROR: AttributeError: ‘MSL’ object has no attribute ‘sequence_number’
00:05:43.979 T:1746924256 DEBUG: ----------------------------------------
00:05:43.979 T:1267725024 ERROR: CCurlFile::FillBuffer - Failed: Server returned nothing (no headers, no data)(52)
00:05:43.980 T:1267725024 ERROR: CCurlFile::Open failed with code 0 for http://localhost:48171/manifest?id=80192751&dolby=true&hevc=false|acceptencoding=gzip&seekable=0&user-agent=Mozilla%2F5.0%20(X11%3B%20CrOS%20armv7l%207647.78.0)%20AppleWebKit%2F537.36%20(KHTML%2C%20like%20Gecko)%20Chrome%2F59.0.3071.115%20Safari%2F537.36:
00:05:43.980 T:1267725024 ERROR: AddOnLog: InputStream Adaptive: Cannot download http://localhost:48171/manifest?id=80192751&dolby=true&hevc=false
00:05:43.980 T:1267725024 ERROR: AddOnLog: InputStream Adaptive: Could not open / parse mpdURL (http://localhost:48171/manifest?id=80192751&dolby=true&hevc=false)
00:05:43.980 T:1267725024 DEBUG: AddOnLog: InputStream Adaptive: Session::~Session()
00:05:43.981 T:1267725024 ERROR: CVideoPlayer::OpenInputStream - error opening [plugin://plugin.video.netflix/?action=play_video&infoLabels=%7B%27rating%27%3A+0%2C+%27writer%27%3A+%27%27%2C+%27episode%27%3A+1%2C+%27plot%27%3A+u%27As+Bill+breaks+down+the+science+of+aging%2C+his+correspondents+try+bizarre+beauty+treatments+and+learn+how+spinach+could+transform+organ+transplants.%27%2C+%27season%27%3A+3%2C+%27tvshowtitle%27%3A+u%27Bill+Nye+Saves+the+World%27%2C+%27title%27%3A+u%27Cheating+Death%27%2C+%27mediatype%27%3A+u%27episode%27%2C+%27mpaa%27%3A+u%27-%27%2C+%27director%27%3A+%27%27%2C+%27genre%27%3A+u%27Reality%2C+Variety+%26+Talk+Shows%27%2C+%27year%27%3A+2018%2C+%27duration%27%3A+2148%7D&video_id=80192751&pin=False&start_offset=14]

Any idea what could be wrong?


#169

It works now, I think it was a left over of trying to get pi-hole working on OSMC. Got it fixed by disabling dnsmasq on the Pi and running pi-hole in a docker.


#170

Great, haven’t had time to reply.


#171

Thank you so much for your guide. It worked like a charm. My only suggestion is that you mention that you cannot use omxplayer hw acceleration with it. I tried and all I get is audio with garbled graphics, if I set the Video settings to MMAL hw accerleration then everything works and Netflix is displayed with SW acceleration (which for my RBPi3 works great with 720p video).

Robert


#172

Will edit the guide post to mention, mmal instead of omx


#173

I’m running the latest version of OSMC and Netflix plugin, but seem to be stuck in an install loop. From a fresh install of the plugin, I am prompted to install widevine (EULA, download, install, reboot). The download often stalls and freezes, at which point I unplug the pi, reboot and start again with a fresh install. When successful, I open Netflix after reboot, but am prompted to install widevine again. Has anyone else had this issue? What should I do to troubleshoot and/or fix this?


#174

Latest Version with Kodi 18 I assume?


#175

Kodi 18-ALPHA2


#176

Is there enough space on the SD-card for libwidevine to get extracted?, seems there is an error occuring somewhere inside inputstreamhelper (which downloads widevine).


#177

under dev/mmcblk0p2 12G is available (mounted on /)
under dev/mmcblk0p1 205M is available (mounted on /boot)


#178

It’s working for me for the first time since I installed this past winter! I:

  • uninstalled Netflix from repository
  • reinstalled pycryptodome
  • ran sudo rpi-update && sudo reboot
  • reinstalled Netflix from repository
  • ran Netflix and installed Widevine
  • success!

I suspect that my issues were largely related to being connected over wifi this whole time. The new releases of the Netflix plugin (13.8) and updates to Leia probably don’t hurt.


#179

I have some problems yesterday with Widevine but it was due to lack of free space. Today i use bigger SD card and install everything from tutorial. Even Widevine was installed without problems. But i cant play any wideo :frowning: when i click on something wideo loads but is not played. What can i do ? What to check ? OSMC logs for start ? or someone have such situation and resolve it already ?

Thanks :slight_smile:

[edit1] ehhh i restarted rpi3 and videos are played now :slight_smile:

[edit2] so i change tv to that one where osmc needs to work and change wired connection do wifi. And from that moment plugin stop to work… in logs i see something like that

osmc@osmc:~$ tail -F /home/osmc/.kodi/temp/kodi.log
                                              File "/usr/lib/python2.7/json/__in                                                                     it__.py", line 352, in loads
                                                return cls(encoding=encoding, **                                                                     kw).decode(s)
                                              File "/usr/lib/python2.7/json/deco                                                                     der.py", line 364, in decode
                                                obj, end = self.raw_decode(s, id                                                                     x=_w(s, 0).end())
                                              File "/usr/lib/python2.7/json/deco                                                                     der.py", line 382, in raw_decode
                                                raise ValueError("No JSON object                                                                      could be decoded")
                                            ValueError: No JSON object could be                                                                      decoded
                                            -->End of Python script error report                                                                     <--
10:58:52.183 T:1508897504 WARNING: CPythonInvoker(11, /home/osmc/.kodi/addons/pl                                                                     ugin.video.netflix/addon.py): the python script "/home/osmc/.kodi/addons/plugin.                                                                     video.netflix/addon.py" has left several classes in memory that we couldn't clea                                                                     n up. The classes include: N9XBMCAddon9xbmcaddon5AddonE
10:58:52.196 T:1449730784   ERROR: GetDirectory - Error getting plugin://plugin.                                                                     video.netflix/

[Edit3] after several restarts netflix is working ok again.


#180

Hi all,

Today I have followed joakim_s’ instructions to install Netflix, few comments below.

  1. RPi (or mediacenter) restart is necessary, otherwise you got some errors like
    10:58:20.706 T:1917356752 WARNING: CPlayerCoreFactory::GetPlayer(videodefaultplayer): no such player: dvdplayer

  2. Netflix video, audio and subtitles in a matter of minute playback get out of sync (first subtitles, second audio and then video), checked with few movies.
    Not usable at the moment :frowning:

Hope you can give me some hints to make it working properly. Thx in advance…

My config:
Player

  • Playback
    – Adjust display refresh rate: Always
    – Sync playback to display: ON
  • Processing
    – Allow hardware acceleration - OMXPlayer: ON (I cannot set it to OFF permanently: after marking it OFF, checking the Netflix movie and coming back to this setting it’s back to ON)
    – Allow hardware acceleration - MMAL: ON

System

  • Display
    – Whitelist: 1280x720p 50 Hz
    – Resolution: 1280x720p
    – Refresh rate: 50.00

Logs at https://paste.osmc.tv/lulavufoze

EDIT: It’s not a Netflix issue… EVERY video (including offline ones) is now out of sync… Leia issue? Any idea what to do next? Or downgrade back to stable 17.6. June release?


[TESTING] Kodi 18 (Leia) builds for Raspberry Pi
#181

Added the reboot comment in Guide, when it comes to subtitles i have never used em. Will check audio, never noticed it before. Might be the latest Leia build, since there was inputstream changes.

Edit: Tried 3 minutes of audio without subtitles (topgear) and no problems with sync, will try with subs enabled.

Edit2: Tried with subs, and no lag there either, running on 480p since it’s a pi2


#182

@joakim_s do you have any idea what can I do to diagnose my problem?

EDIT: I think I have sorted it out. It looks like
Settings \ Player
Playback
– Sync playback to display: ON

is the root cause. When turned off there are no sync issues at all. Also Audio Profiles plugin made it harder to solve, since it switches automatically between the audio sources AND all the other system options. So when I have changed any video option, it was set up back to previous one when second (or later) movie was played… Doh!

I also think that RPI 3 is able to play 1080p media from Netflix (even with extension board like Digiberry as in my case), but only for a limited amount of time. In around 10 minutes of playback it gets hot so red thermometer is displayed :slight_smile: But with display limited to 720p it works fine - full episode of Rick and Morty runs fine and it still handles such challenge with CPU temp of 74 deg C and CPU @1000 Mhz (plus we have hot days in Warsaw now, 30 deg C at 18:10. Looks like some small fan would do the trick…


#183

I can’t use 1080 whatsoever, it just starts stuttering immediately…720 is perfect though so I’ve reluctantly limited it in the settings.

It’s a shame but it looks like only two cores are being used for the decoding, so theoretically the pi3 probably has the power to decode 1080p, but it’s not being utilised.

Did you change any settings to get 1080p working? I’ve tried over clocking but it makes no difference at all.

It’s still pretty impressive for a little £30 device though.


#184

Since 2 days I cannot watch any Netflix movie anymore. I get something like this after navigation to desired movie and attempt to play it:

20:58:25.644 T:1917479632  NOTICE: WakeOnAccess success exit, server already running
20:58:25.942 T:1299182304 WARNING: CPythonInvoker(83, /home/osmc/.kodi/addons/plugin.video.netflix/addon.py): the python script "/home/osmc/.kodi/addons/plugin.video.netflix/addon.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon9xbmcaddon5AddonE
20:58:32.924 T:1307570912 WARNING: CPythonInvoker(84, /home/osmc/.kodi/addons/plugin.video.netflix/addon.py): the python script "/home/osmc/.kodi/addons/plugin.video.netflix/addon.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon9xbmcaddon5AddonE
20:58:40.120 T:1299182304 WARNING: CPythonInvoker(85, /home/osmc/.kodi/addons/plugin.video.netflix/addon.py): the python script "/home/osmc/.kodi/addons/plugin.video.netflix/addon.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon9xbmcaddon5AddonE
20:58:51.650 T:1917479632 WARNING: CPlayerCoreFactory::GetPlayer(videodefaultplayer): no such player: dvdplayer
20:58:51.653 T:1917479632  NOTICE: OMXPlayerUnsuitable OMXPlayer unsuitable due to audio sink
20:58:51.659 T:1917479632  NOTICE: VideoPlayer::OpenFile: plugin://plugin.video.netflix/?action=play_video&infoLabels=%7B%27rating%27%3A+0%2C+%27writer%27%3A+%27%27%2C+%27episode%27%3A+%27%27%2C+%27plot%27%3A+u%27Legendarny+kr%5Cxf3l+gitarowego+brzmienia.+Niezwyk%5Cu0142a+historia+prawdziwej+osobowo%5Cu015bci.%27%2C+%27season%27%3A+None%2C+%27tvshowtitle%27%3A+%27%27%2C+%27title%27%3A+u%27Keith+Richards%3A+Under+the+Influence%27%2C+%27mediatype%27%3A+%27movie%27%2C+%27mpaa%27%3A+%27NFLX-16%2B%27%2C+%27cast%27%3A+%5Bu%27Keith+Richards%27%5D%2C+%27director%27%3A+u%27Morgan+Neville%27%2C+%27genre%27%3A+u%27Dokumenty+biograficzne%27%2C+%27year%27%3A+2015%2C+%27duration%27%3A+4921%7D&video_id=80066798&pin=True
20:58:51.661 T:1390408416  NOTICE: Creating InputStream
20:58:51.960 T:1299182304 WARNING: CPythonInvoker(86, /home/osmc/.kodi/addons/plugin.video.netflix/addon.py): the python script "/home/osmc/.kodi/addons/plugin.video.netflix/addon.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon9xbmcaddon5AddonE
20:58:54.329 T:1390408416   ERROR: AddOnLog: InputStream Adaptive: Could not open / parse mpdURL (http://localhost:33493/manifest?id=80066798&dolby=true&hevc=false)
20:58:54.333 T:1390408416   ERROR: CVideoPlayer::OpenInputStream - error opening [plugin://plugin.video.netflix/?action=play_video&infoLabels=%7B%27rating%27%3A+0%2C+%27writer%27%3A+%27%27%2C+%27episode%27%3A+%27%27%2C+%27plot%27%3A+u%27Legendarny+kr%5Cxf3l+gitarowego+brzmienia.+Niezwyk%5Cu0142a+historia+prawdziwej+osobowo%5Cu015bci.%27%2C+%27season%27%3A+None%2C+%27tvshowtitle%27%3A+%27%27%2C+%27title%27%3A+u%27Keith+Richards%3A+Under+the+Influence%27%2C+%27mediatype%27%3A+%27movie%27%2C+%27mpaa%27%3A+%27NFLX-16%2B%27%2C+%27cast%27%3A+%5Bu%27Keith+Richards%27%5D%2C+%27director%27%3A+u%27Morgan+Neville%27%2C+%27genre%27%3A+u%27Dokumenty+biograficzne%27%2C+%27year%27%3A+2015%2C+%27duration%27%3A+4921%7D&video_id=80066798&pin=True]
20:58:54.334 T:1390408416  NOTICE: CVideoPlayer::OnExit()
20:58:54.546 T:1917479632 WARNING: OnMessage: Suspiciously long time to handle GUI_MSG_PLAYBACK_STARTED (2.87s)

#185

Mines been working fine, but this morning I can’t even login…saying check credentials.

Hopefully this is just a temporary issue.


#186

Latest commit just fixed the login issue…working great again now.


#187

Hey,

Since the June update my netflix addon stopped working.
Here is my log:
https://paste.osmc.tv/xikuyowuno
Any help is appreciated.

Thanks in advance!