Can I use Netflix on OSMC?(post 4)


#148

Yeah its still working, i just let the pi3 update to the latest version (its on the 24th May patch now), and just downloaded the addon and let it get the image that it wanted.


#149

Sanbird, which version of the addon do you have?

Hi Joakim, yes I had noticed all of the issues on github. I have tried a clean install of v18 and downloaded the plugin, but that doesn’t work. It is interesting that it is still working for Sandbird.


#150

Workin’ for me too, but i use HEAD from Github, just checkout the master repo and u’re good to go. :slight_smile:

And did u care about this part? It’s essential:

Blockquote
Crypto for netflix plugin:
sudo apt-get install python-crypto
sudo apt-get install build-essential python-pip
sudo pip install -U setuptools
sudo pip install wheel
sudo pip install pycryptodomex


#151

Hey Guys, I found a guide that worked covering the pycryptodome, the widevine, and the add-ons.

https://makingstuffwork.net/technology/install-netflix-amazon-prime-video-plex-raspberry-pi-kodi-osmc/

I can confirm the netflix plugins 13.2, and 13.6 work correctly.

Worked like a charm for me on my Pi 3, and Pi 3B+. Does need an occasional reboot, but thats to be expected on an Alpha build.

Hope this helps some out. :slight_smile:


#152

Will do a clean install and try to get netflix 13.6 working


#153

Good luck! Its been pretty good for me, was watching it in bed last night, streams like a charm on my 3B+. Since I have gone through it a few times I will help out if I can, but it was pretty straight forward…


#154

Did it 2 or 3 days ago without issues. :wink:


#155

Well with the latest Leia and 13.6 you get the request for mail and password then it bugs out, something with reg-expression in netflixsession.py. So i guess it’s not working in a new install


#156

Ah, ok, now i understand, but with master-git of netflix i had no issues. I had a backup and restored it, i think, that’s the difference. :smile:


#157

One thing to note is that this guide is using a specific Leia build, its not the latest…


#158

Edit: some confusion, sorry


#159

Oh, ignore me. Turns out I just had to reboot my Pi.


#160

Latest Leia and Netflix 0.13.7 addon is working for me, had to do a reboot after installing, but libwidevine extraction worked like a charm.


#161

Thanks for the heads up about the new version. Did you just update the addon? Or was it a fresh install?


#162

uninstalled the addon and then installed from the new zip


#163

I am using the 0.13.4 version


#164

mine also broke down today, i couldnt play anything. Removed the addon and the settings and installed the latest version, then rebooted, then it was playing fine again.


#165

Thanks for all this info @joakim_s! After having my Netflix suddenly stop working a week or two ago, I managed to fix it be basically reinstalling everything as laid out here. I’m currently on v17.8-225 of the Leia nightly and I’m hesitant to update that in case it breaks things again.

This week I suddenly started getting a notice that there is a Widevine CDM update available - the notice pops up when I start streaming an episode on Netflix, but only some of the time - like every 5th episode or something. I’m sure it would be fine, but things are working smoothly right now, so I’m ignoring the update notice each time. Do you know if that is something that is safe to do and that I should do now?

One additional random side-effect of all of this (and I’m not sure what cause this or even if it’s related in any way) - the Google Music Experimental add-on (this one I think) that I have has suddenly stopped working - I was using it recently, but now it crashes OSMC (sad face) every time I try to play anything on it. I’m not too bothered by that and I haven’t actually done any active debugging on it, but if you know of some kind of related conflict there, that would be good to know about :slight_smile:

Thanks for you work on helping the community with all this!


#166

Hi @hlashbrooke I don’t have a google music account so i can’t really help you trouble shoot it. My guttfeeling is that it’s an google drm app, which leads me to belive it uses libwidvine too, and it might need the latest libwidvine. But this is just guess work.

Since I’m fully aware about Leia beeing nightlys and netflix addon is still under development i expect breakeage, i still got the latest Leia and Netflix addon to work, so you should be safe to update, and there by getting the latest libwidvine.

PS. Backup is allways adviced :grin:


#167

Thanks! I’ll run some backups and tentatively update things to see what happens - hopefully it will all work out OK.