Can I use Netflix on OSMC?(post 4)


#104

Working :slight_smile: Thanks man. I forget to see the update from the ads-ons :smiley: Thanks a lot


#105

As far I get It - it is mod of original plugin with fixed issue of not listing content. Therefore you won’t exactly find it under original netflix plugin. It still showed as updated ~4 months ago


#106

today i got mine RPI 3 b+ ordered especially to improve hardware for netflix.

unfortunately SD card swapped from rpi3 with working system did not work.

then i tried to install fresh copy twice and no success. Is it my fault or Kodi 18 does not support raspberry pi 3 b+ yet?


#107

Kodi v18 is not related to whether Pi will work.
You need to update OSMC to 2018.03-2 first.


#108

thank for answer,

when I made a fresh instalation of OSMC and then follow with instruction sticked to 2nd post my system keeps hanging after this command:

sudo systemctl start mediacenter

i see ‘sad face’ then black screen and it continously repeats. I tried twice - always stopped at the same step


#109

You would need to use stretch-devel repository to install latest version of libbluray.


#110

how to do that?


#111

Check the Leia Thread where you installed the testing version from


#112

yesterday i followed gmc suggestion :

slight_smile:Builds post 193 use the new version of libbluray. You will need to use the devel branch, do a update which will then upgrade libbluray to 1.x.

You are still on an older version:

armv7-libbluray-osmc 0.9.3-4

To fix this:

sudo nano /etc/apt/sources.list

Then add:

deb http://apt.osmc.tv stretch-devel main

Do another update/dist-upgrade and the package should be upgraded.

After that you can revert back to stable branch (though not required) and then upgrade to latest mediacenter.

without positive results, i am trying again now


#113

Then provide debug logs so that we can check.


#114

excuse my ignorance but i am not very familiar with linux systems, may i kindly ask how to create logfile?


#115

Than maybe better not use testing/beta versions

Details can be found here https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request.
A quick command line solution is grab-logs -A and share the URL


#116

Now it Does work! I have no idea what did in another way yesterday but now i was able to instal KODi 18.0. So, now is the time to install NETFLIX for my wife - keep your fingers crossed:)


#117

Hi, I loved your guide, thank you so much!! I was able to install netflix this way, and I was able to login as well.

I am super new to Raspberri, OSMC, Kodi and sshing into things, so , sorry for my ignorance, I know it’s probably something super simple now.

After logging in, it actually fetch the profiles the first time, and then says netflix errors, check the logs :frowning:

I turned debug mode on and got the log out:

http://paste.osmc.tv/upekihuwam.vhdl

I hope this is what I needed to get to get help, if not can you let me know what to do?

I am driving crazy to get netflix to work on OSMC… I was able to get it working just on chromium, but it works super slow and sucks.

Thanks in advance,

Cheers

Dani


#118

Something went wrong with you log files

Have you tried, this post earlier in the thread. There has been an upgrade to the netflix addon


#119

Oh nice, I have not seen that, I will try it now, thanks!! :slight_smile: Will let you know how it goes. Thanks a lot for your help! Downloading the ZIP as we speak!!!


#120

Hi, can I bother you, still not working, I did update the plugin now, still not working, now it does not even logged me in.

I think I got the logs out better now as well: http://paste.osmc.io/xezomurofo.vhdl

Hope it helps, again thanks a lot for your help! :slight_smile:


#121

@joakim_s - thank you so much for the instructions and great explanation. Managed to get Kodi v18 installed, OSMC updates done and Netflix signon worked - eventually after restarting, uninstalling and re-installing addon. Can see my account and movies play perfectly.
Only thing - Do you have an suggestions on how I can make the interface more Netflix’ish and not the raw Kodi style skin?


#122

Will try myself, doing a clean install tonight and try to get it to run. There is so many diffrent variables to get it to work. But i’ll get back to you.

Edit: First problem i see is that xz-utils wasn’t installed which means there is an error extracting libwidevinecdm.so and copy it to the right place. so i’ve updated the script. Missing llibwidevinecdm.so will make the navigation work but startign the stream wont.

Edit 2: Will also change the guide to install the latest addon, insted of repro.


#123

If you want to change the layout of the addon, try chatting up the addon developer.