Can I use Netflix on OSMC?(post 4)


#288

Hey guys. Just installed the -345 version of the latest Leia Beta and everything seemed to be working great with installing netflix using the script given here and I tried it out and it was working great.

However, suddenly when I searched using netflix search it just kicked me out and now it won’t launch anymore… I tried uninstalling the addon and installing a fresh version from the netflix addon repo but still same… Here are my logs
it seems to be throwing PythonToCppException for some reason. Connection refused… Any ideas? Thanks!

EDIT
Enabled “auto login” in settings of addon and launching prompted me for password and username and now I am in. I don’t know for how long though and/or if this was what fixed it. Hopefully it stays working.


#289

Have you tried logout and/or switch account?

Might be that your credentials got messed up, but it’s hard to say from logs.


#290

Hey I made a new clean install from OSMC today. Then I tried to install Netflix with the netflix_prep_install.sh skript.
When I want to install the addon from the zip it says that it can’t satisfie pycrptodome dependecies.
How can i solve the problem


#291

Strange, I’ve used that script multiple times, there might be a screen saying this and this plugin installed, and pycryptodome isn’t installed. That’s OK since kodi isn’t aware that it’s already in the system. You should be able to just click OK.


#292

Hey I found my mistake. I thougt that the newest OSMC build uses Kodi 18 but it still uses Kodi 17.6. So had to install kodi 18 and now it works


#293

As mentioned in the Edit part I enabled auto login and then got to log in again and it seems to work for now again…


#294

After I reinstalled the plugin and gave my credentials Netflix works again. Thx for help Joakim!


#295

some VPNs are better than others. Someone I know said NordVPN works great for them.


#296

Hi @thatgibgun

Sorry, perhaps I wasn’t clear. I am able to watch Netflix using my VPN on my PC. But I am unable to when using my Pi, despite being able to connect to the same VPN server. Which I find rather odd.


#297

Apologies Mark, I was just scanning through the thread and misunderstood the ask here.


#298

Not to worry thatgibgun, reading it back, it is rather difficult to understand.

Thanks for trying to help though.


#299

Netflix streaming suddenly stopped working for me yesterday - I can open the add-on and browse content, but when I try to play something it gives me the loading spinner and then does nothing. I have updated to the latest Kodi 18 release for OSMC (350) and it still isn’t working. I uninstalled Nettflix and then reinstalled it using the netflix_prep_install.sh script and I’m still having the same issue.

Before this happened I had been getting occasional notifications of a Widevine update being available, but I hadn’t run the update yet. I know from past experience that this kind of issue where content won’t play is often a Widevine issue, but now no matter how many times I try to play something, I don’t get the Widevine update notification.

So is there a way to install/update Widevine without having to get the prompt? Like a script to run or something like that? I feel like that might solve this issue.


#300

Haven’t tried the latest update. Will do tonight and get back to you. -349 had some inputstream.adaptive changes, haven’t tried after that.


#301

I was having this same issue on 349 and I even rolled back to 345 to test and had the same problem.

Here are my logs if it helps at all: http://paste.osmc.tv/uximelugel - the error that I’m getting is at timestamp 20:44:12.018.


#302

Well it stopped working for me as well on -350, downgrade to -348 doesn’t help. See error reports on github, same error “KeyError: ‘viewables’” which suggest it might be something in netflix plugin that needs changeing.

From github: “Today netflix blocked msl. All script or tool, stoped working. Can’t download stream list.”


#303

Yeah - just saw that too: https://github.com/asciidisco/plugin.video.netflix/issues/530 - the add-on will need to be updated then, assuming they can work around this


#304

Someone worked out a fix and posted a ZIP of a fixed release with the workaround here: https://github.com/asciidisco/plugin.video.netflix/issues/532 - I’ve tested this and it’s working on -350 now.


#305

Thank you @hlashbrooke