Browsing SMB Workgroup using the Kodi Interface



I’ve read through all the SMB related posts that I was able to find and have not come up with anything to help with my issue.

To explain… First, this is NOT an issue with connecting to SMB shares. I am able to connect and stream files via SMB shares, however, this requires that I manually add the share path (smb://servername). I am able to successfully connect using SMBv1, SMBv2, and SMBv3.

The issue is that when I try to connect to a share by browsing via “Windows Network (SMB)” I just get an empty window. I used to see my workgroup, then from there I would see the windows computers in the workgroup (At least the ones registered on my WINS server). I’ve tried setting the max protocol to SMBv1, SMBv2, and SMBv3. None seem to resolve the issue.

This problem has only recently popped up (About 1-2 months) as I was able to browse the network that way before.

Any input that may be helpful towards resolving this would be very much appreciated!

Some information about my setup:

  • A Raspberry Pi 2 and a Raspberry Pi 3 both running OSMC v 2017.09-1
  • A computer on my LAN running Windows Server 2016 which has:
    –> Windows Shares for Kodi to connect to using a username and password on the server
    –> A central SQL server that Kodi connects to for the library
    –> A WINS server running in a Virtual Machine (Server 2016 Core)


This is an issue with current OSMC/Kodi that is not solvable for the time being. Browsing is not working.


Any ballpark idea when it might be resolved?


Unfortunately not for the time being as several components come to play that have let to this situation


Browsing the workgroup is a feature of smb v1 which is being removed due to it being a 30 year old protocol riddled with security issues. We see the same thing on windows networks when smb v1 is removed.

To my knowledge your need to use another advertisement protocol like Bonjour, but in practise it’s not necessary once you’ve got used to the change in behaviour.

OSMC does not find Network via SMB

Same issue here.Why does it work on Kodi 17.4 on my pc then?.I can browse my workgroup fully


Most likely because your PC is not blocking smb1 protocol…


I would update your PC.


Thanks for that guys


Hey Everyone,

From what I can gather, setting up an auto-mounted share in the fstab file is a decent solution to be able to browse shared folders using SMB 3.0.2.

Does anyone have any other suggestions?