Audio out - only spdif


So got my Vero 4k to replace my Vero 1.
On the Vero 1 I could only select spdif as audio out but on the Vero 4k I can’t find that option.

The result is that I have audio on the tv (from HDMI) and on the reciever (from spdif).

Does anyone know where you van disable audio on HDMI on the Vero 4k.

P.s. I bought the Vero for the spdif out option.




The Vero 4K has dual audio out; just select HDMI (not PCM) and you will get passthrough via SPDIF.

It’s not trivially possible at this time to disable the HDMI out for audio.



Audio is working but I get it on both HDMI (my tv) and SPDIF (receiver with 5.1)
Now I have to turn down my TV audio when streaming from the Vero 4k
That is in my case a downgrade from the vero 1 where you could select Spdif or HDMI.
Can I aspect this will be fixed in the next update from osmc or kodi ?

Tia Leon


Thanks for clarifying.

No – I don’t think so; it’s the design of the SoC. If your receiver / TV supports control for audio by source; then you can disable audio on the TV. Can you clarify why you have to separate audio paths for your TV; maybe there is a workaround or better way to plan for this.

Of course if you are unhappy with this, I wouldn’t want you to feel this is a downgrade and you are more than welcome to return the unit for a full refund



Hi Sam,

You can’t blaim this on the TV , it just processes the audio that is coming in.
I need control on the audio out from the mediaplayer and it really suprises me that you can’t.

In my setup video is going through HDMI to the TV and audio is going to my reciever by spdif (I have no HDMI on my reciever).
Now I experience audio on the TV speakers and my dolby surround reciever at the same time.
Before I start a media player stream I have to mute the TV but that gives an annyoing on screen sign so I have to put down the volume instead.
I never had these problems witk the vero 1 because there was full control on the audio out.

So I can not expect a solution from Kodi or OSMC in the near future.
The only solution I can think off is blocking HDMI audio with some kind of filter device but I am afraid it will downgrade my video (or I need to buy a very expensive one).
Do you have any other ideas ?

Tia Leon



I’m not blaming the TV for this one; I’m just explaining how the SoC operates. By default, audio will be sent to both the SPDIF and HDMI out. However; if the display is a DVI display, then we don’t send sound as this would cause problems.

Conversely, last year we had a problem with Vero 2 where one user couldn’t get sound, and only video. For this user, the issue was caused by a long HDMI cable which presented some problems with EDID reading. As it was embedded in the wall; it would have been quite an ask to tell him to change the cable so we had to come up with a work around. Because the EDID couldn’t be read properly; the device fell back to DVI (no audio) modes.

So this means that the SoC can be told not to send audio over HDMI; but usually this is reserved only for DVI monitors which don’t support audio.

It may be possible to leverage this to solve the problem. When I checked the Vero 4K kernel sources however; it doesn’t seem that setting IEEEMode changes audio mode anymore. So it needs further investigation.



Hi @leurb

Can you try running this command:

echo audio_off | sudo tee /sys/class/amhdmitx/amhdmitx0/config

and checking whether it works correctly for you?

If so, you can add this to /etc/rc.local before the line exit 0, and it will be persistent across reboots.




Hi Sam,

Command works correctly for me. Thanks
Only it is not persistent after reboots when I add this to rc.local (before the line exit 0) ?
Any idea why ?



What’s the output of

cat /sys/class/amhdmitx/amhdmitx0/config

If it looks good (ie audio_off) it might be a timing issue. Try adding sleep 2 before the echo line


Output is oké (it saus audio off).
Put in sleep 2 in rc.local but no result after a eenoog


Is that a reboot? :wink:

Try increasing the sleep, perhaps 5 or 10.

Thanks Tom.


Sorry for the auto dutch correction (something the tablet does).
I tried various kinds of sleep numbers until 100 but it still doesn’t execute with a reboot.
Can it be that I am doing something wrong ?

Tia Leurb


Try this instead:

echo audio_off  > /sys/class/amhdmitx/amhdmitx0/config

in rc.local


And if that doesn’t work, try repeating the line so the command is issued twice. I’ve noticed the driver code doing this in a couple of places.


It’ll be Kodi windowing bringup causing the problem I suspect
Kodi will do a mode switch and reset some of the amhdmitx state.

@leurb Does OSMC boot in a different resolution to the resolution you have set in Kodi?



Everyone thanks for your suggestions but it still isn’t persitent on reboots.

@sam I can’t seem to find a difference in resolutions between OSMC and Kodi. During the boot cycle the tv gets twice a new signal and says it is 1920x1080 @60hz.This is also the setting in system under the kodi settings. Everywhere I look on system information it says it is 1920x1080 @60hz.


You could try sleep 30 in rc.local (hacky)
or adding it in in XBMC and putting it under userdata directory.




Thanks but both options are not persistent with reboots.
Didn’t think this should be so hard but it seems otherwise.



What does your look like?

Logs will be useful; as they will show if audio is being muted (dmesg should say so)


Try this in your ~/.kodi/userdata/

import os

os.system('echo audio_off | sudo tee /sys/class/amhdmitx/amhdmitx0/config')

After creating the file, all you need to do is restart kodi (no reboot needed). If this works, you can remove anything you added to /etc/rc.local